Create Tagalog word list for autocorrect

RESOLVED WONTFIX
(NeedInfo from)

Status

RESOLVED WONTFIX
3 years ago
6 months ago

People

(Reporter: bhuang, Assigned: rudyl, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Create a Tagalog word list for keyboard autocorrect

Comment 1

3 years ago
Is there a list of English terms that is commonly used for autocorrect so that we may start localizing? Thanks!

Comment 2

3 years ago
Hi Robert, for autocorrect the idea would be to include a full Tagalog word list with some frequency information, and then there's code for making the best suggestions based on the user's partial input.  The good news is that I can probably do most of this for you :)

As it happens I worked on the first FLOSS spell checker for Tagalog about 10 years ago with a guy named Ramil Sagum.   It's not huge - about 18000 words and limited support for affixes and so on, but the coverage is pretty good for such a small list.

Nevertheless, I think it would be valuable to revisit the list and try to expand it, in particular making sure "new" words that we might have missed ten years ago are included.   Would you be interested in working on this with me?  Might be easiest to coordinate via email - feel free to drop me a line.

Comment 3

3 years ago
(In reply to Kevin Scannell from comment #2)
> Hi Robert, for autocorrect the idea would be to include a full Tagalog word
> list with some frequency information, and then there's code for making the
> best suggestions based on the user's partial input.  The good news is that I
> can probably do most of this for you :)
> 
> As it happens I worked on the first FLOSS spell checker for Tagalog about 10
> years ago with a guy named Ramil Sagum.   It's not huge - about 18000 words
> and limited support for affixes and so on, but the coverage is pretty good
> for such a small list.
> 
> Nevertheless, I think it would be valuable to revisit the list and try to
> expand it, in particular making sure "new" words that we might have missed
> ten years ago are included.   Would you be interested in working on this
> with me?  Might be easiest to coordinate via email - feel free to drop me a
> line.

Sure. Thank you very much Kevin! We have a localization sprint after the Easter Holidays, maybe we can focus on this one. I'm using bob@mozillaph.org

Comment 4

3 years ago
Created attachment 8601080 [details]
tl_wordlist.xml

Attaching a frequency list incorporating the words edited by the mozillaph.org team.  Frequencies based on about 6 million words of Tagalog crawled from the web.
Kevin: who usually helps in getting this in? Unsure of next steps to get a patch going :)
Flags: needinfo?(kscanne)

Comment 6

3 years ago
For all the other languages I've done, Rudy Lu has actually created and landed the change on github, e.g. bug 1050558, bug 1059745, and so on.
Flags: needinfo?(kscanne)
Ok asking for some help from Rudy then to get this in. Thanks!
Flags: needinfo?(rlu)
Hi, I will try to get this in, but first we need a keyboard layout for Tagalog.
Is it good enough to use Qwerty layout as English layout for Tagalog?
Flags: needinfo?(lebedel.delphine)
Flags: needinfo?(rlu)

Comment 9

3 years ago
(In reply to Rudy Lu [:rudyl] from comment #8)
> Hi, I will try to get this in, but first we need a keyboard layout for
> Tagalog.
> Is it good enough to use Qwerty layout as English layout for Tagalog?

Tagalog uses the English QWERTY keyboard layout. Thanks!
Robert, thanks for your help to confirm this.
Clear the ni for Delphine.
Flags: needinfo?(lebedel.delphine)
Created attachment 8603271 [details] [review]
[gaia] RudyLu:keyboard/Bug1149029-Tagalog_layout > mozilla-b2g:master
Assignee: nobody → rlu
Status: NEW → ASSIGNED
Comment on attachment 8603271 [details] [review]
[gaia] RudyLu:keyboard/Bug1149029-Tagalog_layout > mozilla-b2g:master

Hi Arky,

If possible, please help give feedback on this layout and dictionary.
Thanks.
Attachment #8603271 - Flags: feedback?(hitmanarky)

Comment 13

3 years ago
(In reply to Rudy Lu [:rudyl] from comment #12)
> If possible, please help give feedback on this layout and dictionary.

@Rudyl Currently on long trip to West Africa. Will try to test it ASAP. 

@bob Do want a take a shot at it? I'll help you with technical aspects of testing the Tagalog keyboard and dictionary.

Comment 14

3 years ago
(In reply to arky [:arky] from comment #13)
> (In reply to Rudy Lu [:rudyl] from comment #12)
> > If possible, please help give feedback on this layout and dictionary.
> 
> @Rudyl Currently on long trip to West Africa. Will try to test it ASAP. 
> 
> @bob Do want a take a shot at it? I'll help you with technical aspects of
> testing the Tagalog keyboard and dictionary.

Sure. No problem. Let me know what to do. Thanks!
Arky: any updates on this please? thanks!
Flags: needinfo?(hitmanarky)

Updated

3 years ago
Duplicate of this bug: 1183453

Comment 17

6 months ago
Firefox OS is not being worked on
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.