[FFOS2.0][FFOS2.2][Woodduck][Keyboard]The keyboard is different from Android‘s keyboard.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Keyboard
P2
normal
RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: sync-1, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created an attachment (id=1215582)
 the layout of Android keyboard
 
 Dear Mozilla:
 the Arabic keyboards of FFOS2.0&2.2 are the same layout. But it’s different form Android's keyboard layout,you can see the difference of them.
 However, here are the questions:
 1st:Does it make sense if I move the character which layout at the end of the third line to the end of the second as Android's keyboard layout.
 2nd:It miss some characters in FFOS keyboard layout, compare to the Android keyboard layout,is it right?
 3rd: Can you help me to change the layout of FFOS keyboard like Android keyboard layout.
(Reporter)

Comment 1

3 years ago
Created attachment 8585392 [details]
the layout of Android keyboard
josh, I think this might be by design. Could you please have someone to take a look?
Flags: needinfo?(jocheng)
Hi Josh,

   I find they are different between Woodduck v2.0m & Flame v2.0&2.1 and Flame v2.2&3.0, please reference "Contrast_figure.png", thanks.
Created attachment 8585865 [details]
Contrast_figure.png

Comment 5

3 years ago
Hi Delphine,
Could you help to find someone who can help answer the questions?
Thanks!
Blocks: 1054172
Flags: needinfo?(jocheng) → needinfo?(lebedel.delphine)
(Reporter)

Comment 6

3 years ago
Created an attachment (id=1216678)
 the layout of ffos keyboard
 
 this one is the ffos arabic keyboard,and the last one is Android Arabic keyboard
(Reporter)

Comment 7

3 years ago
Created an attachment (id=1216678)
 the layout of ffos keyboard
 
 this one is the ffos arabic keyboard,and the last one is Android Arabic keyboard
(Reporter)

Comment 8

3 years ago
Created attachment 8585872 [details]
the layout of ffos keyboard

Created an attachment (id=1216678)
 the layout of ffos keyboard
 
 this one is the ffos arabic keyboard,and the last one is Android Arabic keyboard
Adding Ahmed. 
Hi Ahmed, can you help provide feedback here?  For the 2nd question on missing characters, are those the characters found when hitting the shift key?
Thanks.
Flags: needinfo?(lebedel.delphine) → needinfo?(nefzaoui)

Updated

3 years ago
See Also: → bug 1039186

Comment 10

3 years ago
(In reply to sync-1 from comment #0)
> Created an attachment (id=1215582)
>  the layout of Android keyboard
>  
>  Dear Mozilla:
>  the Arabic keyboards of FFOS2.0&2.2 are the same layout. But it’s different
> form Android's keyboard layout,you can see the difference of them.
>  However, here are the questions:
>  1st:Does it make sense if I move the character which layout at the end of
> the third line to the end of the second as Android's keyboard layout.
>  2nd:It miss some characters in FFOS keyboard layout, compare to the Android
> keyboard layout,is it right?
>  3rd: Can you help me to change the layout of FFOS keyboard like Android
> keyboard layout.

Hi, 

for (1) and (3) it will be flexible if partner would like to customize by themselves. 

for (2), would you check if those missing char. can be found in 1st row after pressing shift key? If not please help pointed out which char. is missing specifically, thanks.


And FYI indeed we have keyboard layout refactored by 1039186 hence different in 2.2 and 3.0, which is the suggested design currently.

Updated

3 years ago
Flags: needinfo?(sync-1)
(In reply to Bruce Huang [:bhuang] <bhuang@mozilla.com> from comment #9)
> Adding Ahmed. 
> Hi Ahmed, can you help provide feedback here?  For the 2nd question on
> missing characters, are those the characters found when hitting the shift
> key?
> Thanks.

Hi Bruce,
The new keyboard layout has landed in 3.0 then I requested uplifiting to 2.2 and got it landed there as well. Thus, the layout is of 2.2 and raw 2.0 are not the same.

The spec for the keyboard is this, added in Bug 1039186.
https://bug1039186.bugzilla.mozilla.org/attachment.cgi?id=8550863
The main layout interface includes all the alphabet characters.
PS: the characters in small size are those fired after a long press on the key.
That's about the missing characters key.

For the Android layout, I think even that one differs from one version to another (not sure though) (so they'd have to precise which version, if that's *really* the case then please make sure you implement the layout in Android's latest version) :)
Flags: needinfo?(nefzaoui)
(Reporter)

Comment 12

3 years ago
(In reply to comment #8)
 > Comment from Mozilla:(In reply to Bruce Huang [:bhuang] <bhuang@mozilla.com>
 > from comment #9)
 > > Adding Ahmed. 
 > > Hi Ahmed, can you help provide feedback here?  For the 2nd question on
 > > missing characters, are those the characters found when hitting the shift
 > > key?
 > > Thanks.
 > 
 > Hi Bruce,
 > The new keyboard layout has landed in 3.0 then I requested uplifiting to 2.2
 > and got it landed there as well. Thus, the layout is of 2.2 and raw 2.0 are not
 > the same.
 > 
 > The spec for the keyboard is this, added in Bug 1039186.
 > https://bug1039186.bugzilla.mozilla.org/attachment.cgi?id=8550863
 > The main layout interface includes all the alphabet characters.
 > PS: the characters in small size are those fired after a long press on the key.
 > That's about the missing characters key.
 > 
 > For the Android layout, I think even that one differs from one version to
 > another (not sure though) (so they'd have to precise which version, if that's
 > *really* the case then please make sure you implement the layout in Android's
 > latest version) :)
 > 
 
 
 OK,I have found the missing characters. And I have another question, can I change the num layout when I using Arabic keyboard?For example,change 1 to ١.
 How can I do that?
> can I change the num layout when I using Arabic keyboard?For example,change 1 to ١.

Yes I'd be in favor of adding those eastern numerals if we can find a place for them in the keyboard.
need-info'ing Rami to give us his thoughts and probably provide a spec for such a layout.
If everyone is ok with such addition you could just go to apps/keyboard/js/layouts/ar.js and add them according to whatever spec provided.
Flags: needinfo?(timdream)
Flags: needinfo?(swilkes)
Flags: needinfo?(rami223)
Lancy: please follow this bug closely for updates on keyboard test cases. thanks
Flags: needinfo?(yulan.zhu)
Delphine,

OK, I will follow up on this issue and update Arabic keyboard test cases.
Flags: needinfo?(yulan.zhu)
Ahmed, I have no opinion on what's best for Arabic speakers :)
Flags: needinfo?(timdream)

Comment 17

3 years ago
Clearing the ni? for me. This likely won't be fixed in time for 2.2, so this change will likely be in 2.x or later. Flagging Omega since he owns UX for keyboard.
Flags: needinfo?(swilkes) → needinfo?(ofeng)
(Reporter)

Comment 18

3 years ago
(In reply to comment #14)
 > Comment from Mozilla:Clearing the ni? for me. This likely won't be fixed in
 > time for 2.2, so this change will likely be in 2.x or later. Flagging Omega
 > since he owns UX for keyboard.
 > 
 
 OK,I see. And If you have new keyboards layout. Can you notice me?
So I spoke about this offline with Rami, and he thinks that there shouldn't be both eastern and western numerals in one layout, and given the fact that we're talking about the Arabic layout here, he thinks it would be better to have Eastern Arabic numerals and continue with this bug.
I agree on that as the English or French layout will provide the western ones, it would be ideal to have the eastern ones in ar.js
Flags: needinfo?(rami223)
And thus, it wouldn't need a real spec IMO since it's just about replacing the top line numbers with the eastern numbers.
Clearing the ni? for me since Arabic is really over my head. @Ahmed, I think you can handle it. :)
Flags: needinfo?(ofeng)

Comment 22

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.