Closed Bug 1039186 Opened 6 years ago Closed 5 years ago

Keyboard's Arabic layout needs to be refactored

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect, P1)

All
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S5 (6feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: nefzaoui, Assigned: nefzaoui)

References

Details

Attachments

(4 files)

Arabic keyboard is still a mess in terms of characters ordering.
It would be nice to clone it's order from Android's.
Blocks: gaia-rtl
Two questions for lucky Bruce. :) 1) Is this a dupe of other keyboard work you have planned for 2.1? 2) Either way, who should be assigned to do this work? Thanks!
Flags: needinfo?(bhuang)
Also, Bruce, Ahmed can take on this work.
Attached file Arabic keyboard layout
I've attached a recommendation for an Arabic layout.  I don't think this blocks 2.1, but if Ahmed has time to work on it then it's definitely welcome.  
Will this refactor include Arabic numerals as well?
Flags: needinfo?(bhuang)
Blocks: keyboard-rtl
No longer blocks: gaia-rtl
This is of high importance for 2.2. Please let me know if this is a layout we can use for 2.2, and who will be available to implement it.

Bruce, I'm working on getting a list of all bidi languages that will need to be supported for 2.2. It's likely each of those will need a keyboard as well.
Flags: needinfo?(bhuang)
One more thing, I couldn't figure out how to type short vowels or simple letters like ئ or ؤ.
feature-b2g: --- → 2.2?
Ahmed, can you provide feedback on Bruce's proposed layout from comment #3? There are some variations from the android layout here so it would be great to get your input or alternate suggestion.
Flags: needinfo?(nefzaoui.ahmed)
(In reply to Bruce Huang [:bhuang] <bhuang@mozilla.com> from comment #3)  
> Will this refactor include Arabic numerals as well?
No I don't think we should add Arabic numerals just yet, if we're gonna use them it has to be done across all Gaia (time digits, Dialer, notification counters etc..)
AFAIK no current plans to do this at the moment so better use only western for now :)
Flags: needinfo?(nefzaoui.ahmed)
Ahmed, did you get a chance to take a look at Bruce's proposed keyboard layout?
Flags: needinfo?(nefzaoui.ahmed)
I got to admit it looks a little chaotic to me, I'm in favor of cloning the Android layout for a reason which is long pressing on a letter brings in all it's sisters in one place, so it's easier to memorize.
Looping in Rami, consulted this with him as he has better understanding than me when it comes to the Arabic layout and letters :)
Flags: needinfo?(nefzaoui.ahmed) → needinfo?(rami223)
I agree with Ahmed, the layout it is not common in our region and it will make people  get confused. I will do some modifications to it and re-attach the file again. When is the deadline for that?
Flags: needinfo?(rami223)
Flags: needinfo?(bhuang)
Bruce, can you estimate when the team will be ready to work on implementation for the keyboard?
Flags: needinfo?(bhuang)
It's not very resource intensive to actually create the layout, so if we can get this confirmed before sprint 3 that would give us a good buffer for code and visual reviews.
Flags: needinfo?(bhuang)
Bruce, let me know if anyone was working on this and might have a patch to land for 2.2. Bhavana and I are looking for the incremental RTL improvements that may be in (vs. "full RTL" support). Thanks!
Flags: needinfo?(bhuang)
feature-b2g: 2.2? → ---
Ahmed, Rami, Manel: Can you help weigh in here from your perspective if Keyboard layout is acceptable or not right now in Arabic? If not, we would have to block on this
Flags: needinfo?(rami223)
Flags: needinfo?(nefzaoui.ahmed)
Flags: needinfo?(manel.rhaiem92)
Delphine,
I already talked with Ahmed about this and I did a redesign of the keyboard layout. I want to clean the design. I will get back to you in couple of days on this.
Flags: needinfo?(rami223)
I revised the layout of the keyboard as you can see. Few of them have more than one letter, the above one are shown when the user do a long press on that key.
I revised the layout of the keyboard as you can see. Few keys have more than one letter, the above one are shown when the user do a long press on that key.
(In reply to Rami Khader from comment #16)
> Created attachment 8550863 [details]
> Arabic Keyboard Layout - revised
> 
> I revised the layout of the keyboard as you can see. Few of them have more
> than one letter, the above one are shown when the user do a long press on
> that key.

Thanks Rami! I also agree this is a layout we should be showing for an Arabic user.
I can provide a PR based on this.
Dylan, what do you think?

Thanks!
Flags: needinfo?(nefzaoui.ahmed) → needinfo?(doliver)
(In reply to Stephany Wilkes from comment #13)
> Bruce, let me know if anyone was working on this and might have a patch to
> land for 2.2. Bhavana and I are looking for the incremental RTL improvements
> that may be in (vs. "full RTL" support). Thanks!

No there has been no other discussion other than what's happening in this bug.  I think if the Arabic speaking users have a consensus here this is a good bug to include.

(In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #18)
> (In reply to Rami Khader from comment #16)
> > Created attachment 8550863 [details]
> > Arabic Keyboard Layout - revised
> > 
> > I revised the layout of the keyboard as you can see. Few of them have more
> > than one letter, the above one are shown when the user do a long press on
> > that key.
> 
> Thanks Rami! I also agree this is a layout we should be showing for an
> Arabic user.
> I can provide a PR based on this.
> Dylan, what do you think?
> 
> Thanks!

Ahmed, it would be great if you're able to implement this.  Please flag Rudy (:rudyl) for review when ready.
Flags: needinfo?(bhuang)
Sounds great to me, I think we should go ahead with it. Thanks Rami & Ahmed. Marking P1.
Flags: needinfo?(doliver)
Priority: -- → P1
Comment on attachment 8554557 [details] [review]
[PullReq] anefzaoui:bug-1039186 to mozilla-b2g:master

Ready for review. :)
Attachment #8554557 - Flags: review?(rlu)
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
feature-b2g: --- → 2.2+
Comment on attachment 8554557 [details] [review]
[PullReq] anefzaoui:bug-1039186 to mozilla-b2g:master

I'll give a r+ here, based on the assumption that the author is a native speaker of this language.

Ahmed, thanks for working on this.
Attachment #8554557 - Flags: review?(rlu) → review+
(In reply to Rudy Lu [:rudyl] from comment #24)
> Comment on attachment 8554557 [details] [review]
> [PullReq] anefzaoui:bug-1039186 to mozilla-b2g:master
> 
> I'll give a r+ here, based on the assumption that the author is a native
> speaker of this language.
> 
> Ahmed, thanks for working on this.

Thank you, Rudy :)
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8554557 [details] [review]
[PullReq] anefzaoui:bug-1039186 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): lack of support to RTL-related UIs
[User impact] if declined: keyboard characters' positions will continue to be random and unpredictable to the user
[Testing completed]: yes, device flame
[Risk to taking this patch] (and alternatives if risky): no risks
[String changes made]: no string changes
Attachment #8554557 - Flags: approval-gaia-v2.2?
Attachment #8554557 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Assignee: nobody → nefzaoui.ahmed
Target Milestone: --- → 2.2 S5 (6feb)
This issue is verified fixed on Flame 3.0 and Flame 2.2

The keyboard has been updated to the revised layout according to the attachment from comment 15

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Shallow Flash)
Build ID: 20150205010209
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: 34a66aaaca81
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Shallow Flash)
Build ID: 20150205002503
Gaia: c2047a46e29696238e9b4c9caaba47736421449a
Gecko: adfba0a07e9b
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
No longer blocks: keyboard-rtl
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
Flags: needinfo?(manel.rhaiem92)
Hello,
I was also wondering if you were going to add short vowels (or maybe I just missed them)?
Thanks!
(In reply to alizee.aubertin from comment #30)
> Hello,
> I was also wondering if you were going to add short vowels (or maybe I just
> missed them)?
> Thanks!

If you click the shift in Arabic keyboard you'll find them all in the first row.
Thanks! :)
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → ---
See Also: → 1149092
You need to log in before you can comment on or make changes to this bug.