bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Please make the Treeherder log viewer useful for developers

RESOLVED DUPLICATE of bug 1147958

Status

Tree Management
Treeherder: Log Viewer
RESOLVED DUPLICATE of bug 1147958
3 years ago
3 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8585517 [details]
Screen Shot 2015-03-30 at 10.54.41 AM.png

Here is the use case.  You get pinged by a sheriff because you have broken something.  They give you a link.  You open the link, and you get what's in the screenshot.

Now that is not exactly useful.  You have no idea what platform this log is on, what kind of build, what changeset, etc.  Basically the log viewer is barely usable for anything other than looking at the failure messages, which is very rarely enough information to act on anything.

The current workarounds include either going to https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound and try to decipher where the log came from, or bother the sheriffs with the above questions.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1147958
This is specifically for the test failures on Taskcluster-based builds. Taskcluster isn't reporting the proper information to Treeherder (or Treeherder isn't looking in the right place for Taskcluster stuff). Buildbot-based failures still report everything correctly.

Comment 3

3 years ago
I can assure you that's not the intended log viewer view.

The log link in question (to save others having to type manually - please paste directly in bugs if possible in the future :-)) is:
https://treeherder.mozilla.org/logviewer.html#?job_id=8230078&repo=mozilla-inbound

The problem is taskcluster pretends to submit buildbot-like logs (in lieu of bug 1080760) but for these specific jobs, the log format is broken.

Things that could/should be fixed:
* Taskcluster: actually create valid logs (bug 1147958; the main issue here short term)
* Treeherder: refuse to accept invalid logs or display a more appropriate message (need bug filed)
* Treeherder: show actual job info, not crap from the log header in the log viewer (bug 1060482 / bug 1057341)
* Treeherder: allow non-buildbot submitters to provide summaries directly and not require them to provide a log that we then parse ourselves (bug 1080760)

I've set a reminder for me to file a bug for #2 when I'm back from vacation.
Component: Treeherder → Treeherder: Log Viewer
OS: Mac OS X → All
Hardware: x86 → All
Filed bug 1149182 for #2 because I'm bored and Ed has enough to do when he gets back...

Comment 5

3 years ago
Superstar - thank you! :-)
You need to log in before you can comment on or make changes to this bug.