Closed Bug 1149662 Opened 5 years ago Closed 5 years ago

[Contacts] Evict the cache when the locale code changes

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: ferjm, Assigned: ferjm)

References

Details

(Keywords: regression)

Attachments

(1 file)

We are currently evicting the cache when the locale direction changes. But since bug 1144433 we are caching some localized strings, so we also need to evict the cache when the locale code changes.
Blocks: 1148654
Comment on attachment 8586218 [details] [review]
[gaia] ferjm:bug1149662.evictcachelocale > mozilla-b2g:master

Sorry I missed this one :(
Attachment #8586218 - Flags: review?(francisco)
This one is a leftover from bug 1144433. We need to block on this one cause otherwise a user that goes from one locale to another locale, won't see her contacts app updated with the latest translation (unless the locale changes the direction: rtl <-> ltr).
Assignee: nobody → ferjmoreno
blocking-b2g: --- → 2.2?
Keywords: regression
Blocks: 1144433
Comms triage: Follow up on bug 1144433 which is a blocker.
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8586218 [details] [review]
[gaia] ferjm:bug1149662.evictcachelocale > mozilla-b2g:master

Pretty straight forward patch.
Attachment #8586218 - Flags: review?(francisco) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8586218 [details] [review]
[gaia] ferjm:bug1149662.evictcachelocale > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1144433 
[User impact] if declined: A user that goes from one locale to another locale, won't see her contacts app updated with the latest translation 
[Testing completed]: Manual tests.
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: None
Attachment #8586218 - Flags: approval-gaia-v2.2?
Attachment #8586218 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.