[Contacts] Cold launching the app shows unlocalized text for a brief second

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: pcheng, Assigned: ferjm)

Tracking

({regression})

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 attachments)

Posted file logcat of issue
Description:
This issue occurs in Accented English. I cannot test this in French or other supported languages due to bug 1142758 present in current 3.0 master - the app doesn't get launched in the right locale/language.

STR:
0) Device is in Accented English
1) Cold launch Contacts app

Expected: Header and the rest of text display in Accented English upon launching

Actual: Header and other text display in English for a second before they become Accented. See video:

https://www.youtube.com/watch?v=K1flKwO97zQ

Repro rate: 5/5

Also attaching a logcat.

Device: Flame 3.0 Master (full flash 319MB mem)
BuildID: 20150317073344
Gaia: 738987bd80b0ddb4ccf853855388c2627e19dcc1
Gecko: 008b3f65a7e0
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
This issue does NOT occur on 2.2. Cold launching the app immediately shows all text in the designated language. Tested in Accented English, French, and German.

Device: Flame 2.2
BuildID: 20150317002504
Gaia: d0e09d5e6367e558824f9cbf691da99cedf63037
Gecko: 793d61bb0bd4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing]
Blocks: 1112551
This is probably because we delayed the lazy load of l10n on bug 1112551.
Assignee: nobody → ferjmoreno
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

Nominating this 3.0? since this a regression from 2.2.
blocking-b2g: --- → 3.0?
Attachment #8580655 - Flags: review?(francisco)
Comment on attachment 8580655 [details] [review]
[gaia] ferjm:bug1144433.contacts.l10n > mozilla-b2g:master

LGTM,

I guess if the cache patch goes to 2.2 this will need to be nominated to isnt?
Attachment #8580655 - Flags: review?(francisco) → review+
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8580655 [details] [review]
[gaia] ferjm:bug1144433.contacts.l10n > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1112551. If that one goes to 2.2, we need to take this fix as well.
[User impact] if declined: Awful UX. The user will see unlocalized content for a second.
[Testing completed]: Manual test.
[Risk to taking this patch] (and alternatives if risky): Low risk, we just cache the localized strings and show them before we load l10n.
[String changes made]: None
Attachment #8580655 - Flags: approval-gaia-v2.2?
blocking-b2g: 3.0? → 2.2+
Attachment #8580655 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Depends on: 1149662
Unable to verify this bug as it is blocked by Bug 1144838. The "Contacts" header is not accented at all on Flame Master.

Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150402063750
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: 35046df9df1f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Depends on: 1144838
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Depends on: 1151561
This issue is verified fixed on Flame 3.0 and 2.2. Cold launching Contacts app does not briefly show unlocalized text. Tested in Accented English, French, and German.

Device: Flame 3.0
BuildID: 20150420010204
Gaia: cb41d8421da5dc4f16ea566ea2917a9b7f828154
Gecko: 50b95032152c
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150420002502
Gaia: c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gecko: cc02ee38b252
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.