Closed Bug 11501 Opened 21 years ago Closed 21 years ago

[DOGFOOD] Panels to Add blank in Customize Dialogue

Categories

(SeaMonkey :: Sidebar, defect, P1, critical)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: paulmac, Assigned: waterson)

References

Details

(Whiteboard: [PDT-])

The second time you go into the Customize Sidebar dialogue, the available Panels
under "Add these Panels to your Sidebar" are gone.

Steps to Reproduce:
1) Click on Customize in the Sidebar
2) Click on Cancel in the Customize Dialogue
3) Click on Customize in the Sidebar again

Actual Results: No Panels are listed under "Add these Panels to your Sidebar",
though they were there the first time.

Expected Results: List of Panels such as Weather, etc. should be there

8/9 builds, all platforms
Assignee: slamm → waterson
This one may be related to 11258.
Status: NEW → ASSIGNED
Target Milestone: M10
Depends on: 11258
This still exists in 8/26 builds.
Note: 11258 is slated to be fixed in M11.
Severity: normal → critical
Summary: Panels to Add blank second time in Customize Dialogue → Panels to Add blank in Customize Dialogue
The Panels are now completely blank on 9/16 builds.
Depends on: 14755
Priority: P3 → P1
Depends on: 14857
Depends on: 14899
No longer depends on: 14857
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
I checked in waterson's fix.
Marking fixed.
Status: RESOLVED → VERIFIED
verified in 1018 builds - this has actually been working for awhile. Now to see
if we can actually do anything with them...
Blocks: 16950
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
it's back
Summary: Panels to Add blank in Customize Dialogue → [DOGFOOD] Panels to Add blank in Customize Dialogue
*** Bug 17724 has been marked as a duplicate of this bug. ***
This is the text from bug #17724:

The list of panels to add is blank in the Customize dialogue. It appears to be a
layout/rendering issue because you can click where they are supposed to be and
add or preview them. To reproduce:

1. Launch apprunner and click on Customize button.

Results:  List of panels to add is blank
Expected Results: Should be a list of Netcenter panels

Found using 110108 builds on all platforms.
if that's the case, it may be that i've broken the RDFGenericBuilder's
notification mechanism...
Whiteboard: [PDT-]
Customizing not for dogfood.  Putting on PDT- radar.
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
tree has regressed; need to have <treecol> or else content doesn't show up
(well, it does, but only 1px high)
Blocks: 17976
Status: RESOLVED → VERIFIED
verified fixed using 11/4 build   PDT be damned :-)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.