Closed Bug 1151206 Opened 5 years ago Closed 5 years ago

Using a theme hides minimize, maximize and close button in composer window [Mac]

Categories

(Thunderbird :: Theme, defect, major)

38 Branch
x86
macOS
defect
Not set
major

Tracking

(thunderbird38+ fixed, thunderbird39 fixed, thunderbird40 fixed)

VERIFIED FIXED
Thunderbird 40.0
Tracking Status
thunderbird38 + fixed
thunderbird39 --- fixed
thunderbird40 --- fixed

People

(Reporter: patrick, Assigned: Paenglab)

Details

(Keywords: regression, Whiteboard: [regression:TB38])

Attachments

(2 files, 1 obsolete file)

Attached image Screenshot
Using Thunderbird 38 b1.

If I enable a theme such as "brushed default" or "Fresh Green Leaves", then the buttons "Close", "Maximize" and "Minimize" are missing on Mac OS X (see attached screenshot). Using the standard theme, the buttons are visible. I tried several themes with the same result.

Setting to major due to high visibility.
Javi, can you reproduce?
Flags: needinfo?(leofigueres)
Summary: Using a theme hides minimize, maximize and close button in composer window → Using a theme hides minimize, maximize and close button in composer window [Mac]
Confirmed also on Thunderbird trunk build. However, I think keeping 38 in the version field could help when searching for the regression. It is also happening when opening the Address Book window, so not a Mail composer bug.
Component: Message Compose Window → Theme
Flags: needinfo?(leofigueres)
thanks for checking.  Agreed, it helps to have version of the regression set. But people change it anyway so it can't be trusted. I've gone to using whiteboard which can be reasonably be trusted to persist.
Keywords: regression
Whiteboard: [regression:TB38]
Attached patch Titlebar.patch (obsolete) — Splinter Review
This patch adds on OS X the titlebar structure to messageWindow, AB and Composer like we have already on main window. Some change in core must be made this necessary now.

Kent, I know you are not a peer for this kind (and especially on Mac) but Josiah has almost no time for reviews and you may want to add it in a beta. So maybe you can test it on your Mac mini. I have it tested on my VM only through monkey patching in omni.ja and I can not use try builds since April 1. as the windows have only black and white areas.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8596539 - Flags: review?(rkent)
Attachment #8596539 - Flags: review?(josiah)
Removed redundant code from previous patch which is already covered by messenger.css.
Attachment #8596539 - Attachment is obsolete: true
Attachment #8596539 - Flags: review?(rkent)
Attachment #8596539 - Flags: review?(josiah)
Attachment #8597203 - Flags: review?(josiah)
Comment on attachment 8597203 [details] [diff] [review]
Titlebar.patch v2

Review of attachment 8597203 [details] [diff] [review]:
-----------------------------------------------------------------

Seems alright, wish I knew what broke this though. More importantly though, I don't have a means to test this on a platform before Yosemite, which I would really like to do. Does anyone have a machine running OS X < 10.10.0?
Attachment #8597203 - Flags: review?(josiah) → review+
(In reply to Josiah Bruner [:JosiahOne] (needinfo! - Won't respond to CC)) from comment #6)
> Does anyone have a machine running OS X < 10.10.0?

I made my tests on Mountain Lion.
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 40.0
Although I took this patch in TB 38, there was an earlier TB40 patch "Bug 1145974 - Move more styles to shared addressbook.css" that caused a conflict that I had to resolve. Could you please check the file in comm-beta and confirm that the resolution of the conflict is what you want?
Flags: needinfo?(richard.marti)
The file is looking good.
Flags: needinfo?(richard.marti)
Status: RESOLVED → VERIFIED
Target Milestone: Thunderbird 40.0 → Thunderbird 38.0
Sorry, I forgot to set the status flags.

Patrick, my understanding of current practice is that Target Milestone reflects the release where the bug was first landed, not accounting for later uplifts.
Target Milestone: Thunderbird 38.0 → Thunderbird 40.0
You need to log in before you can comment on or make changes to this bug.