The default bug view has changed. See this FAQ.

Cross-posts won't send because Newsgroups: groups are separated with comma+space, not just comma

VERIFIED FIXED in Thunderbird 41.0

Status

MailNews Core
Networking: NNTP
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: WaltS48, Assigned: Magnus Melin)

Tracking

({regression})

Thunderbird 41.0
regression
Bug Flags:
in-testsuite +

SeaMonkey Tracking Flags

(thunderbird39 fixed, thunderbird40 fixed, thunderbird41 fixed, thunderbird_esr3839+ fixed, seamonkey2.35 fixed, seamonkey2.36 fixed, seamonkey2.37 fixed, seamonkey2.38 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150330154247

Steps to reproduce:

Wanted to followup to a news.mozilla.org newsgroup post in m.support.thunderbird and cross-post  and set Followuo-To:m.general


Actual results:

Received an Alert message; "A News (NNTP) error occurred: posting failed." 

Followed by a Send Message Error;

"Sending of message Failed
The message could not be sent because connecting to the news server failed. The server may be unavailable or is refusing connections. Please verify that your news server settings are correct and try again."



Expected results:

Message should have posted to m.s.thunderbird, cross-posted to m.general and Followup-TO: should have been set to m.general

This works properly using Thunderbird 31.6.0 where my server settings are identical.
(Assignee)

Comment 1

2 years ago
Should be due to bug 1143569.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1143569
(Reporter)

Comment 2

2 years ago
Thunderbird 38.0b4, 38.0b5, 38.0b6, 38.0.1 candidate (build1) and 41.0a1 are not fixed by bug 1143569

I tried xposting and setting Folowup-To: in Mozilla newsgroups for the first time since I filed this bug using 38.0b6 today and noticed it wasn't fixed.
The questions I would ask are:
* is the _original_ issue cited by your bug fixed by bug 1143569?
* is your _current_ a problem _caused_ by the fix in bug 1143569?
(Reporter)

Comment 4

2 years ago
No, the _original_ issue is not fixed by bug 1143569.
No, the current problem existed before the fix, which is dated 2015-04-29 for Thunderbird 38, which is after 38.0b3 was released, and why I tested 38.0b4 and 38.0b5 with new test profiles for each yesterday, to see there might have been a regression.

Comment 5

2 years ago
Whatever the issue here, WaltS48 is reporting this is still happening after the fix in bug 1143569, so either that bug needs reopening or this one. Let's reopen this one for now.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 6

2 years ago
I just completed some further testing and found this bug existed in Tb 37.0b1(BuildID:20150311003756), but not in TB 37.0a1(BuildID:20141231030200). I can't find Aurora builds to test.
(Reporter)

Comment 7

2 years ago
The first time this bug surfaces is with Thunderbird 37.0a1 (buildID:20150108030218). 

https://hg.mozilla.org/mozilla-central/rev/70de2960aa87
(Assignee)

Comment 8

2 years ago
Confirmed on trunk. Seems I can't have more than one newsgroups.
Status: UNCONFIRMED → NEW
Component: Untriaged → Networking: NNTP
Ever confirmed: true
Product: Thunderbird → MailNews Core
(Assignee)

Comment 9

2 years ago
Seems newsgroups headers that succeed (earlier) have

Newsgroups: mozilla.test,mozilla.test.multimedia


Newer, that fail have comma AND space
Newsgroups: mozilla.test, mozilla.test.multimedia
(Assignee)

Updated

2 years ago
Summary: Cross-posts and Followup-To: won't send in Thunderbird 38.0b1 → Cross-posts won't send becuase Newsgroups: groups are separated with comma+space, not just comma

Updated

2 years ago
tracking-thunderbird_esr38: --- → +
(Assignee)

Comment 10

2 years ago
Created attachment 8621169 [details] [diff] [review]
bug1151448_newsgroups_comma.patch

We had a test for this, but unfortunately the test was incorrect. 

Yes, in theory [FWS] is allowed after the comma, but addText(foo, true) adds the extra space even if things end up on the same line.
I'd just say it's not a soft break point, with little harm really done. News peculiarities...
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #8621169 - Flags: review?(Pidgeot18)
(Assignee)

Updated

2 years ago
OS: Linux → All
Hardware: x86_64 → All

Updated

2 years ago
See Also: → bug 1175041

Updated

2 years ago
status-seamonkey2.35: --- → affected
status-seamonkey2.37: --- → affected
Summary: Cross-posts won't send becuase Newsgroups: groups are separated with comma+space, not just comma → Cross-posts won't send because Newsgroups: groups are separated with comma+space, not just comma

Updated

2 years ago
Duplicate of this bug: 1175041
Comment on attachment 8621169 [details] [diff] [review]
bug1151448_newsgroups_comma.patch

Review of attachment 8621169 [details] [diff] [review]:
-----------------------------------------------------------------

::: mailnews/compose/test/unit/test_messageHeaders.js
@@ +263,5 @@
>    nntpServer.QueryInterface(Ci.nsINntpIncomingServer)
>      .subscribeToNewsgroup("mozilla.test");
>    let identity = getSmtpIdentity("from@tinderbox.invalid",
>      getBasicSmtpServer());
> +  fields.newsgroups = "mozilla.test,mozilla.test.multimedia";

Keep the space in this line--it will confirm that the test folds a "a, b" to "a,b".
Attachment #8621169 - Flags: review?(Pidgeot18) → review+
(Assignee)

Comment 13

2 years ago
https://hg.mozilla.org/comm-central/rev/aaecae60620b -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
status-thunderbird38: --- → affected
status-thunderbird39: --- → affected
status-thunderbird40: --- → affected
status-thunderbird41: --- → fixed
status-thunderbird_esr38: --- → affected
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 41.0
(Assignee)

Comment 14

2 years ago
Comment on attachment 8621169 [details] [diff] [review]
bug1151448_newsgroups_comma.patch

Approval Request Comment
[Feature/regressing bug #]:js-mime
[User impact if declined]: can't post news posts to more than one group at once
[Describe test coverage new/current, TreeHerder]: xpcshell test
[Risks and why]: no risk
Attachment #8621169 - Flags: approval-mozilla-aurora?
Attachment #8621169 - Flags: approval-comm-esr38?
(Assignee)

Updated

2 years ago
Attachment #8621169 - Flags: approval-mozilla-aurora?
Attachment #8621169 - Flags: approval-comm-beta?
Attachment #8621169 - Flags: approval-comm-aurora?

Comment 15

2 years ago
Comment on attachment 8621169 [details] [diff] [review]
bug1151448_newsgroups_comma.patch

https://hg.mozilla.org/releases/comm-beta/rev/71c23450e64e
http://hg.mozilla.org/releases/comm-aurora/rev/291e12b9a709
Attachment #8621169 - Flags: approval-comm-beta?
Attachment #8621169 - Flags: approval-comm-beta+
Attachment #8621169 - Flags: approval-comm-aurora?
Attachment #8621169 - Flags: approval-comm-aurora+

Updated

2 years ago
status-seamonkey2.36: --- → fixed
status-seamonkey2.37: affected → fixed
status-seamonkey2.38: --- → fixed
status-thunderbird38: affected → ---
status-thunderbird39: affected → fixed
status-thunderbird40: affected → fixed

Comment 16

2 years ago
Comment on attachment 8621169 [details] [diff] [review]
bug1151448_newsgroups_comma.patch

http://hg.mozilla.org/releases/comm-esr38/rev/1db4c5ee3045
Attachment #8621169 - Flags: approval-comm-esr38? → approval-comm-esr38+

Updated

2 years ago
status-thunderbird_esr38: affected → fixed
tracking-thunderbird_esr38: + → 39+

Updated

2 years ago
Blocks: 1177041

Comment 17

2 years ago
http://hg.mozilla.org/releases/comm-release/rev/fd8425db2bfe SEAMONKEY_2_35_RELEASE_BRANCH
status-seamonkey2.35: affected → fixed

Comment 18

2 years ago
VERIFIED with  SeaMonkey 2.39a1 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0 from official download area)  Gecko/20100101  Firefox/42.0  Build 20150721221150  (Classic Theme) on German WIN7 64bit
Status: RESOLVED → VERIFIED

Comment 19

2 years ago
To be honest, my verification only was concerning the ""A News (NNTP) error occurred: posting failed.""-Problem.
that indeed has vanished with EN-US SeaMonkey 2.35(γ)  (Windows NT 6.1; WOW64; rv:38.0)  Gecko/20100101 Build 20150722220804 (Classic Theme) on German WIN7 64bit.

But crosspostings still fail. 
Multiple "Newstroup:" recipients: no posting at all will reach NG
Followup-To: will be ignored, only at "Newstroup:" recipient posting will appear.
New bug? Do I misunderstand something?

Details:
--------
a) I did several attempts to send a posting to news.mozilla.org
Newsgroup: mozilla.support.seamonkey
Newsgroup: mozilla.addons.user-experience
Newsgroup: mozilla.dev.apps.seamonkey
Seamonkey always showed a "sent succesfully" and message became sent in "Local Folders - Sent", but no message appeared in the NG

b) I did 1 attempt to send a posting to
Newsgroup: mozilla.support.seamonkey
Followup-To: mozilla.addons.user-experience
Followup-To: mozilla.dev.apps.seamonkey
Seamonkey showed a "sent succesfully" and message became sent in "Local Folders - Sent", but no message appeared in the followup-NG

c) I did 1 attempt to send a posting to News.Individual.DE
Newsgroup: alt.de.test
Followup-To: alt.fr.test
Seamonkey showed a "sent succesfully" and message became sent in "Local Folders - Sent", but no message appeared in the followup-NG

d) Now here I clicked "Reply All" Icon to the successful posting form (b) "SeaMonkey Add-on compatibility", but in the aswer message "mozilla.support.seamonkey" was missing, only Followup-To-Newsgroups appeared in address fields.

Updated

2 years ago
See Also: → bug 1189174
You need to log in before you can comment on or make changes to this bug.