(ShareTo) Pages added to reading list fail to open in reader view

RESOLVED DUPLICATE of bug 1151464

Status

()

Firefox for iOS
Reader View
RESOLVED DUPLICATE of bug 1151464
3 years ago
3 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

unspecified
ARM
iOS 8

Firefox Tracking Flags

(fennec+)

Details

(Reporter)

Description

3 years ago
In Safari, open http://www.neowin.net/news/lg-publicly-claims-that-apple-will-release-an-imac-8k-in-2015, enable the ShareTo extension and add to reading list.

Visit the reading list in Firefox and tap the added article. I'm not sure if that's our error but I see a TODO and a "There was a problem loading the content. Click here to load the original page"
I could not reproduce this error. I successfully added it from Safari and opened it from Firefox in Reading View via the Reading List.

Is it possible that there was no network connectivity when the item was opened from the reading list?

I just filed two bugs to get rid of those TODO messages:

https://bugzilla.mozilla.org/show_bug.cgi?id=1151465
https://bugzilla.mozilla.org/show_bug.cgi?id=1151464
(Reporter)

Comment 2

3 years ago
I believe this just might be the issue of seeing the interstitial errors before the data came in (how quickly can we get that?). Feel free to dupe.
It depends. We load the original page in the background in a web view. So it may take a while if the page is complex or if the network is slow. I think there currently is a 10 second wait before we decide the page has failed loading. If that is too short then we can tweak that.

I've duped this one to the 'we need a loading interstitial' bug. But please re-open if you think this is a different issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151464
tracking-fennec: ? → +
You need to log in before you can comment on or make changes to this bug.