[e10s] Flash widget disappears/flashes when caret is in the widget

RESOLVED FIXED in Firefox 41

Status

()

Core
Plug-ins
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Alice0775 White, Assigned: jimm)

Tracking

(Blocks: 1 bug, {regression})

Trunk
mozilla41
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm7+, firefox41 fixed)

Details

(Whiteboard: [testday-20150821] , URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
This problem does not happen without e10s.

Steps To Reproduce:
1. Open http://www.d-toybox.com/studio/weblog/show.php?mode=single;id=2013031500
2. Scroll to middle of page
3. Click windowed Flash widget
4. Click next Flash widget
   --- observe the windowed Flash widget disappears
5. Move mouse pointer around over sidebar at the right side of the page
   --- observe the windowed Flash widget flickers

Actual Results:
The windowed Flash widget disappears.
The windowed Flash widget flickers.

Expected Results:
Should not


Regression pushlog:
3eb6f6c017ce	Jim Mathies — Bug 1133237 - When transitioning from a shadow layer tree that has plugins to a tree that does not, make sure the old plugins get hidden properly. r=roc

Suspect: Bug 1133237
Flags: needinfo?(jmathies)
(Reporter)

Updated

3 years ago
status-firefox40: affected → ---
tracking-e10s: --- → ?
(Assignee)

Comment 1

3 years ago
new one for me, lets let this fall into our normal triage.
Flags: needinfo?(jmathies)
tracking-e10s: ? → m7+
(Assignee)

Updated

3 years ago
Blocks: 874016
Assignee: nobody → jmathies
(Assignee)

Comment 2

2 years ago
Created attachment 8623684 [details] [diff] [review]
patch v.1
(Assignee)

Comment 3

2 years ago
Created attachment 8623686 [details]
swf for test case
(Assignee)

Comment 4

2 years ago
Created attachment 8623687 [details]
flickeringtestcase.html
(Assignee)

Comment 5

2 years ago
Comment on attachment 8623684 [details] [diff] [review]
patch v.1

Apparently we can trigger remote layer tree updates without a reflow, so we shouldn't clear our cache of plugin data after we calculated it in the last reflow. In this test case the layer updates come through when you click on the middle (windowless) plugin and we have to add a focus rect and caret to it.
Attachment #8623684 - Flags: review?(roc)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1167978
Attachment #8623684 - Flags: review?(roc) → review+

Comment 7

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/355d8b0c09ef
https://hg.mozilla.org/mozilla-central/rev/355d8b0c09ef
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
QA Whiteboard: [good first verify][verify in Nightly only]

Comment 9

2 years ago
I have reproduced this bug with Firefox Nightly 40.0a1 (Build ID: 20150407030207) on 
windows 8.1 64-bit with the instructions from comment 0 .

Verified as fixed with Latest Firefox Nightly 43.0a1(Build ID: 20150822030206)

Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Whiteboard: [testday-20150821]
The bug is verified on Latest 7, too (Checked with Latest Nightly)

But I am seeing another issue now! When I go to the middle of the page, The first windowed Flash widget flickers. It is only can be seen, when you scroll!

So, maybe the issue is not fixed fully or a new issue has been arisen!

Needinfoing Alice, so that he can check the issue too and confirm here! He may can add some more context on this!
Flags: needinfo?(alice0775)
(Reporter)

Comment 11

2 years ago
(In reply to Hossain Al Ikram [:ikram] (QA Contact) from comment #10)
> The bug is verified on Latest 7, too (Checked with Latest Nightly)
> 
> But I am seeing another issue now! When I go to the middle of the page, The
> first windowed Flash widget flickers. It is only can be seen, when you
> scroll!
> 
> So, maybe the issue is not fixed fully or a new issue has been arisen!
> 
> Needinfoing Alice, so that he can check the issue too and confirm here! He
> may can add some more context on this!

Yes, I can confirm.
And the flickering problem seems to be duplication of Bug 1157708.
Flags: needinfo?(alice0775)
(Assignee)

Comment 12

2 years ago
(In reply to Alice0775 White from comment #11)
> (In reply to Hossain Al Ikram [:ikram] (QA Contact) from comment #10)
> > The bug is verified on Latest 7, too (Checked with Latest Nightly)
> > 
> > But I am seeing another issue now! When I go to the middle of the page, The
> > first windowed Flash widget flickers. It is only can be seen, when you
> > scroll!
> > 
> > So, maybe the issue is not fixed fully or a new issue has been arisen!
> > 
> > Needinfoing Alice, so that he can check the issue too and confirm here! He
> > may can add some more context on this!
> 
> Yes, I can confirm.
> And the flickering problem seems to be duplication of Bug 1157708.

Depends, if you have layers.async-pan-zoom.enabled set to false, it's bug 1137944. If not, then bug 1157708 fits.
You need to log in before you can comment on or make changes to this bug.