Closed Bug 1152117 Opened 5 years ago Closed 5 years ago

[NFC] NFC cannot connect to other devices immediately after NFC is enabled.

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S11 (1may)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: Marty, Assigned: dimi)

References

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files)

Description:
Immediately after enabling NFC in settings, the user is not always able to connect to other NFC devices. The phone will not vibrate, and the shrinking UI will not appear.

There is not any information recorded in the logcat when this occurs, so I am currently unable to attach a logcat of this issue.

This does not occur every time, and is often fixed by restarting the device.

Repro Steps:
1) Update a Flame to 20150407010204
2) Open the Settings app and enable NFC
3) Close the settings app and open the Gallery app
4) Touch the back of the DUT to another NFC enabled device and attempt to share an image from the gallery via the shrinking UI

Actual:
The phone does not vibrate, and the shrinking UI does not appear

Expected:
The phone is able to connect via NFC immediately after enabling NFC from settings.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150407010204
Gaia: c710bac533b76635161315bf907d004e000549cb
Gecko: ab0490972e1e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 4/8
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Broken functionality.

Adding qawanted for branch checks.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: qawanted
This issue reproduces on 2.2. Toggling on NFC doesn't always work for transferring files.

Device: Flame 2.2
BuildID: 20150407002501
Gaia: 5e09637414269728f6f1bc0152d0160f3b6b380e
Gecko: 245f37f44017
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

------

NFC does NOT seem to work on 2.1. Tried rebooting and all and couldn't get it to work.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
NFC was not supported in 2.1 if I remember correctly.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(In reply to Pi Wei Cheng [:piwei] from comment #2)
> 
> NFC does NOT seem to work on 2.1. Tried rebooting and all and couldn't get
> it to work.

(In reply to KTucker [:KTucker] from comment #3)
> NFC was not supported in 2.1 if I remember correctly.

NFC is supported since v2.0.

Please file another bug if you still met this problem in v2.1.
Thank you Yoshi for the information. This might be covered in bug 1146741 which is awaiting approval if not we will write up a new issue.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=NFC]
It seems not be able to reproduce, can you try new version?
Flags: needinfo?(pcheng)
I reproduced this bug 2 out of 2 attempts on today's 3.0 nightly. It doesn't really have to do with 'immediately' as title of this bug described, it's NFC sometimes simply doesn't work after enabling it. Rebooting the device seems to fix the issue. If you couldn't get it on first attempt, try disabling it and re-enable it.
Flags: needinfo?(pcheng)
Depends on: 1155251
blocking-b2g: 3.0? → 2.2?
Depends on: 1155887
No longer depends on: 1155251
Duplicate of this bug: 1155887
(In reply to Pi Wei Cheng [:piwei] from comment #7)
> I reproduced this bug 2 out of 2 attempts on today's 3.0 nightly. It doesn't
> really have to do with 'immediately' as title of this bug described, it's
> NFC sometimes simply doesn't work after enabling it. Rebooting the device
> seems to fix the issue. If you couldn't get it on first attempt, try
> disabling it and re-enable it.

I can easily produce this issue on 2.2 and 3.0 according to Pi Wei's reproduce steps. (disabling it and re-enable it)
Besides, disable/enable device screen would always fix this issue.
Assignee: nobody → dlee
blocking-b2g: 2.2? → 2.2+
I found turning on/off RF frequently may cause this issue in Flame.
In both diable/enable SE implementation, nfcd will check if it is in discovery mode now, if it is, it will turn off discovery mode, and reopen later.
So this patch is trying to only turn on/off RF once when enable/disable NFC.

Alison help test enable/disable NFC for 40 times and this issue cannot be reproduced.
Attachment #8595277 - Flags: review?(allstars.chh)
Attachment #8595277 - Flags: review?(allstars.chh) → review+
Adding verifyme to verify this issue, also please check the duplicates STR's bug 1155887.
Keywords: qawanted, verifyme
[Approval Request Comment]

New bug

User impact if declined: 

Sometimes NFC will not work after disable then enable

Testing completed:

Tested locally

Risk to taking this patch (and alternatives if risky):

Need to test basic NFC function again

String or UUID changes made by this patch:

No
Attachment #8595712 - Flags: approval-mozilla-b2g37?
QA Contact: pcheng
This issue is verified fixed on Flame 3.0 master. NFC can be disabled and enabled multiple times and still works. Also verified bug 1155887 is fixed by successfully transferring multiple pictures in Gallery.

Bug repro rate: 0/12

Device: Flame 3.0 Master (full flashed 319MB KK)
BuildID: 20150422010202
Gaia: 15134b080b5f406e5aa36f5136c17dafb4e31f64
Gecko: 946ac85af8f4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Leaving verifyme keyword for v2.2 verification.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=NFC] → [QAnalyst-Triage?][COM=NFC]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][COM=NFC] → [QAnalyst-Triage+][COM=NFC]
Flags: needinfo?(ktucker)
Attachment #8595712 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Adding qawanted to follow up and verify 2.2.
Keywords: qawanted
This issue is verified fixed on 2.2. NFC can be disabled and re-enabled and pictures can be transferred when it's enabled. Bug repro rate: 0/10.

Device: Flame 2.2 (KK, 319MB mem, full flash)
BuildID: 20150423002502
Gaia: b838d0e7c163e66660dcb6e387d8339944a7a30e
Gecko: 8dce56574f28
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+][COM=NFC] → [QAnalyst-Triage?][COM=NFC]
Flags: needinfo?(ktucker)
Keywords: qawanted, verifyme
QA Whiteboard: [QAnalyst-Triage?][COM=NFC] → [QAnalyst-Triage+][COM=NFC]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.