Closed Bug 1152500 Opened 4 years ago Closed 4 years ago

Flame: Camera cannot record video anymore once the volume buttons are rapidly pressed

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox41 fixed, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 unaffected, b2g-master verified)

RESOLVED FIXED
FxOS-S1 (26Jun)
Tracking Status
firefox41 --- fixed
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: njpark, Assigned: aosmond)

References

Details

Attachments

(3 files, 4 obsolete files)

STR:
Open Camera app, change to video mode
press the volume button to start recording, then press again to stop it
Press the volume button rapidly, until you see the message "Video not recorded. An error prevented Camera from recording the video"
Wait a while, and press the volume button again

Actual:
Video cannot be recorded, unless the app is killed and restarted
Expected:
After a while, the video can be recorded


Version Info:
Build ID               20150408010203
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150408.044148
Firmware Date          Wed Apr  8 04:41:59 EDT 2015
Bootloader             L1TC000118D0
qawanted for branch check.  As for regression range. I remember this was working okay in master only a couple weeks ago.  I didn't have to kill the app to get the recording to work again, (at least I remember it that way)
QA Contact: yue.xia
Attached file logcat_2106.txt (obsolete) —
This problem can be reproduced on latest build of Flame 3.0 by the STR in comment 0, but it cannot be reproduced on Flame2.0/2.1/2.2. On Flame2.0/2.1/2.2, device doesn't support pressing volume button to record video.
See attachment: logcat_2106.txt & Flame3.0Video.mp4

b2g-inbound regression window:
Last Working Environmental Variables:
Device: Flame
Build ID               20150224022325
Gaia Revision          31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gaia Date              2015-02-23 15:25:53
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/65a968102d6d
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.032622
Firmware Date          Thu Apr  9 03:26:33 EDT 2015
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame
Build ID               20150224042626
Gaia Revision          c357b8877d96e8009f1f98c84704dc0462ce42ce
Gaia Date              2015-02-24 06:29:58
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/be9b4a3b01ab
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.032622
Firmware Date          Thu Apr  9 03:26:33 EDT 2015
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia: c357b8877d96e8009f1f98c84704dc0462ce42ce
Gecko: 65a968102d6d

First Broken Gecko & Last Working Gaia - issue does NOT repro
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: be9b4a3b01ab
Attached video Flame3.0Video.mp4 (obsolete) —
See Also: → 1159572
After studying this, I think there are more than a few problems in both the app and Gecko state machines. Not surprised hammering causes problems.
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Attachment #8590645 - Attachment is obsolete: true
Attachment #8590647 - Attachment is obsolete: true
Fix existing potential intermittent bug in the test cases, it always worked but now it waits for device storage to confirm the file is deleted before continuing.
Attachment #8621887 - Attachment is obsolete: true
Attachment #8621920 - Flags: review?(jdarcangelo)
Attachment #8621898 - Flags: review?(dhylands)
Duplicate of this bug: 1126604
Duplicate of this bug: 1174014
Properly fix the test case this time (they passed but I didn't delete the old useless code).
Attachment #8621898 - Attachment is obsolete: true
Attachment #8621898 - Flags: review?(dhylands)
Attachment #8621940 - Flags: review?(dhylands)
Duplicate of this bug: 1157612
Flags: in-testsuite+
Comment on attachment 8621940 [details] [diff] [review]
[gecko] fix start/stop recording race condition and error handling, v2.1

Review of attachment 8621940 [details] [diff] [review]:
-----------------------------------------------------------------

Looks reasonable to me.
Attachment #8621940 - Flags: review?(dhylands) → review+
Comment on attachment 8621920 [details] [review]
[gaia] aosmond:bug1152500 > mozilla-b2g:master

LGTM, thanks! Left one small nit in the PR comments.
Attachment #8621920 - Flags: review?(jdarcangelo) → review+
(In reply to Justin D'Arcangelo [:justindarc] from comment #14)
> Comment on attachment 8621920 [details] [review]
> [gaia] aosmond:bug1152500 > mozilla-b2g:master
> 
> LGTM, thanks! Left one small nit in the PR comments.

Fixed.

Sheriffs: Note that these patches may land in any order, no fear of landing on gaia early/late. I've landed the gecko part already on b2g-inbound.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/9ba890d2ba08
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S1 (26Jun)
This bug has been verified as "pass" on latest Nightly build of Flame v3.0 by the STR in Comment 0.

Actual results: The error message "Video not recorded. An error prevented Camera from recording the video" will not pop up, and device always can continue to record video.
See attachment: verified_v3.0.3gp
Reproduce rate: 0/30


Device: Flame v3.0 build(Verified)
Build ID               20150618160206
Gaia Revision          55bac3c151bff4f0ce0e8715962c4676fefb0887
Gaia Date              2015-06-18 16:49:24
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/656ea3bfbb4e
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150618.192643
Firmware Date          Thu Jun 18 19:26:54 EDT 2015
Bootloader             L1TC000118D0
Blocks: 1217111
You need to log in before you can comment on or make changes to this bug.