Contacts sidebar mostly defaults to "All Address Books" - explore remembering previous choice or defaulting to another AB of user's choice

RESOLVED DUPLICATE of bug 1142705

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 1142705
3 years ago
3 years ago

People

(Reporter: sfhowes, Unassigned)

Tracking

({regression})

38 Branch
x86
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150409004007

Steps to reproduce:

Upon opening a Write window, the Contacts sidebar defaults to All Address Books, no matter which address book had been selected in a previous composition session.  Prior to the All Address Books introduction in TB 38, the selection in the sidebar was retained between sessions and TB restarts.



Expected results:

The address book selection should be maintained between sessions.  As a side note, the address book that was last selected in Address Book should probably be selected when Address Book is reopened, unlike now where All Address Books is the default.
Neither the old, nor the current, nor the expected behaviour is as straightforward as it looks.
User is free to open many compositions and choose a different AB in the contacts side bar of each.
So I don't see why or how we would keep them all in sync, and randomly apply one AB from one composition to future compositions.
Severity: normal → enhancement
Summary: Contacts sidebar and All Address Books → Contacts sidebar mostly defaults to "All Address Books" - explore remembering previous choice or defaulting to another AB of user's choice
(Reporter)

Comment 2

3 years ago
I think you would find that the overwhelming majority of users prefer the address book in the sidebar to be a sticky setting, but at the very least there should be a "pin" icon to set the address book, to a specific one, Personal Address Book or All Address Books.  Where is the evidence that users want the new method instead of the old method?  I foresee a debacle like the recent introduction of changes to autocomplete.

Comment 3

3 years ago
duping to bug 1142705 as that has a patch and a discussion of the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1142705

Comment 4

3 years ago
This is still a thing! Please check if there is someone who can make a special address book the standard addressbook or have a quick workaround. We are more than a hundred users over here and would really appreciate your efforts. Thank you very, very much!
You need to log in before you can comment on or make changes to this bug.