Closed Bug 1153155 Opened 5 years ago Closed 4 years ago

[Flame L] porting for b2g build

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: viralwang, Assigned: viralwang)

References

Details

Attachments

(5 files, 1 obsolete file)

we need to prepare b2g build for flame L
here's the local build we can boot into b2g with L now.
$ git clone https://github.com/viralwang/B2G -b flame-l .
$ ./config.sh flame-l
$ ./build.sh
$ ./flash.sh
Depends on: 1165774
Depends on: 1165313
t2m provide 29 repositories in their github and we should merge it in our github.
Attached file flame-l.xml (obsolete) —
Hi Michael,

I would like to land flame-l.xml on mozilla-b2g but there are some repositories still using t2m or my local github need your advice.

Some items will fork to mozilla-b2g with branch name "foxfone-one-lollipop"
bootable/bootloader/lk
bootable/recovery
device/t2m/flame
kernel
external/bluetooth/bluedroid
external/libnfc-nci
frameworks/base
hardware/libhardware
hardware/qcom/display
system/core

for those items I would like to use t2m as remote directly since some we don't need to modify the codes and we didn't have repositories on mozilla-b2g yet.
device/qcom/common
device/qcom/msm8610
hardware/qcom/sensors
vendor/qcom/opensource/wlan/prima

of course, patches folder will remove later.

Thank you.
Attachment #8610515 - Flags: feedback?(mwu)
t2m as a remote is fine while you're developing, but when you want builds to show up on tree herder, it will be easier to mirror repos to git.mozilla.org if they're hosted at https://github.com/mozilla-b2g/ . This can be done later - up to you.

Please submit patches for review. Don't put it in the manifest.
Attachment #8610515 - Flags: feedback?(mwu)
Hi Michael,

Take external/libnfc-nci for example, I think we can use t2m as remote like we did in flame-kk
(https://git.mozilla.org/external/t2m-foxfone/platform_external_libnfc-nci.git is mirrored from https://github.com/t2m-foxfone/platform_external_libnfc-nci.git)

I would like to do the same way to mirror repos to git.mozilla.org from https://github.com/t2m-foxfone
device/qcom/common
device/qcom/msm8610
hardware/qcom/sensors
vendor/qcom/opensource/wlan/prima
Actually we don't need to change the code in Moz side and it can reduce our maintain effort if we could point to t2m's github, should we still need to fork those repos to https://github.com/mozilla-b2g/ ?

For rest of them, I will use branch name "foxfone-one-lollipop" for flame-l if you don't have other concern.

Thank you for you feedback :)
Flags: needinfo?(mwu)
Depends on: 1168729
If we're already using repos from t2m-foxfone, then it's fine.

The only thing that I know we want to have our own repo for is device/t2m/flame. T2M modifies device/qcom/msm8610 but we use a proper device repo for that. Avoiding changes in device/qcom/common and device/qcom/msm8610 would be nice if possible.
Flags: needinfo?(mwu)
It make sense to move the changes in device-flame.
I think we can keep remote of device/qcom/common and device/qcom/msm8610 to caf and merge those necessary files in fevice-flame.
Thank you for your advice :)
Hi Michael,

I would like to new few branches for flame-l, could you please help to review the branch names and see if there's any improper? Thank you :)

bootable/bootloader/lk => foxfone-one-lollipop
bootable/recovery => foxfone-one-lollipop
device/t2m/flame => lollipop (kitkat for flame kk)
kernel => t2m-flame-3.4-l (t2m-flame-3.4-kk for flame kk)
external/bluetooth/bluedroid => foxfone-one-lollipop
frameworks/base => foxfone-one-lollipop
hardware/libhardware => foxfone-one-lollipop
hardware/qcom/display => foxfone-one-lollipop
system/core => foxfone-one-lollipop
Flags: needinfo?(mwu)
t2m use tag "LA.BF.1.1.2_rb1.12" as base and add their codes.
That's why we can't fork from "b2g-5.0.0_r6" in b2g and merge their codes in our branch :(
Hi Michael,

May I have your suggestion for comment 8 ?
I would like to merge those patches to our github.
Thank you :)
Depends on: 1171392
The b2g-* branches are always for the associated android-* tags. These tags *only* come from AOSP upstream. So it doesn't make sense to fork from b2g-* when we have a CAF based port because CAF is the main upstream. T2M is simply using tags provided by CAF, which is the real upstream.

Is t2m-foxfone using foxfone-one-lollipop as their branch name? If so, copying it is fine.
Flags: needinfo?(mwu)
Thank you Michael.
I will use the foxfone-one-lollipop for all the repositories from t2m then.
Hi Michael,

One last question about the branch name is about framework/av.

Since t2m didn't modify it in their side, so we still use "LA.BF.1.1.2_rb1.12" from CAF so far.
However, this tag is for Android version and we need this patch from CAF to make sure gecko build pass:
https://www.codeaurora.org/cgit/external/gigabyte/platform/frameworks/av/commit/?h=caf/LF.BR.1.2.3&id=a4b9ff7252272cedff593937e8e6dab842bd4209

May I use the branch name "LA.BF.1.1.2_rb1.12" for https://github.com/mozilla-b2g/platform_frameworks_av/ ?
Thank you.
Flags: needinfo?(mwu)
Depends on: 1173295
CAF tags are *all* ok to use if that's what the device is based on. This is what you should aim for in fact - use upstream tags and avoid forking on our side whenever possible. CAF manifests use a mix of both Android and B2G tags so it's not unusual to use an Android tag if that is what CAF is providing for their downstream.
Flags: needinfo?(mwu)
Depends on: 1175415
Attached file PR for b2g-manifest
Hi Michael,

Could you please help to review this manifest for flame-l?
Thank you.
Assignee: nobody → vwang
Attachment #8610515 - Attachment is obsolete: true
Attachment #8624128 - Flags: review?(mwu)
Attached file PR for B2G
Hi Michael,

I would like to add flame-l in config.sh
Thank you.
Attachment #8624130 - Flags: review?(mwu)
Attachment #8624130 - Flags: review?(mwu) → review+
Comment on attachment 8624128 [details] [review]
PR for b2g-manifest

I'm ok with this, but it looks like t2m is using all new repo names for this - they're all prefixed with android_. We'll need to get a bunch of new git.mozilla.org mirrors up to make that work.
Attachment #8624128 - Flags: review?(mwu) → review+
Hi Michael,

For those new repos already mirrored in bug 1171392.
Thank you for your help :)
https://github.com/mozilla-b2g/b2g-manifest/commits/master
https://github.com/mozilla-b2g/B2G/commits/master
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Hi Michael,

So sorry for bothering you again :(
I didn't notice that base-l.xml move to 5.1 already and I still use 5.0 in my github.
Could you please help to review this patch that I move flame-l.xml to use 5.0?
Thank you.
Attachment #8625252 - Flags: review?(mwu)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #8625252 - Flags: review?(mwu) → review+
Hi Michael,

https://github.com/mozilla-b2g/b2g-manifest/commits/master
just figure only use "./repo sync build" will miss the Makefile checking :(
please help to review this update patch.
Thank you so much.
Attachment #8625417 - Flags: review?(mwu)
Attachment #8625417 - Flags: review?(mwu) → review+
Blocks: Flame_L
https://github.com/viralwang/b2g-manifest/commit/a3885bacce79ec2cdd304b6e34dd3977a714d8a7
No longer blocks: Flame_L
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Josh, do we also need this for v2.2?
Flags: needinfo?(jocheng)
Blocks: Flame_L
Duplicate of this bug: 1170870
Duplicate of this bug: 1165774
Hi Viral,
Can you request 2.2 uplift approval?
Thanks!
blocking-b2g: --- → 2.2+
Flags: needinfo?(jocheng) → needinfo?(vwang)
Michael,

Since Viral is not in Mozilla, could you please uplift to v2.2?
I am not sure if we need to do any modification for the patch on v2.2.
Flags: needinfo?(mwu)
Bug 1177361 has landed on v2.2. That said, these builds need in-tree configs in b2g/config, no? i.e. http://mxr.mozilla.org/mozilla-central/source/b2g/config/flame-kk/
Flags: needinfo?(mwu)
Flags: needinfo?(viralwang)
You need to log in before you can comment on or make changes to this bug.