Closed Bug 1153500 Opened 7 years ago Closed 7 years ago

Get a new icon for the Notification permission prompt

Categories

(Core :: DOM: Push Notifications, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1192458

People

(Reporter: dougt, Assigned: phlsa)

References

Details

User Story

Acceptance Criteria: 

1. Generate Notification permission
2. Verify appearance of icon in permission doorhanger and anchor.

Attachments

(5 files, 4 obsolete files)

No description provided.
Flags: needinfo?(madhava)
Attached image icon-notificationsTray-push.svg (obsolete) —
Notification Icon

States Left-to-Right: Normal, Hover, Active
I think I want these in png, like the other ones.

  skin/classic/browser/Geolocation-16.png
  skin/classic/browser/Geolocation-16@2x.png
  skin/classic/browser/Geolocation-64.png
  skin/classic/browser/Geolocation-64@2x.png
  skin/classic/browser/Push-16.png
  skin/classic/browser/Push-16@2x.png
  skin/classic/browser/Push-64.png
  skin/classic/browser/Push-64@2x.png

Dolske, what do we use now?
Flags: needinfo?(dolske)
We have been replacing PNGs with SVG where possible. Just updated the add-ons install icons with SVG in bug 1162584
Yep, SVG is the new hotness. Gets you sharp images at both normal and OS X Retina resolutions, as well as handing all the oddball scaling factors on Windows, and all in just one file.
Flags: needinfo?(dolske)
Attached image Screenshot 2015-05-31 23.04.19.png (obsolete) —
Attachment #8613378 - Attachment is obsolete: true
The above screenshot is for "Notifications".
The above screenshot is for Push notifications.

I do not think I am happy with how this ended up (ignore fact that the smaller notification icon has 3 icons in it -- not just one).  Basically the notification and push look very similar and they will probably be used in conjunction with each other.
shorlander, if you like to discuss this week in person/vidyo, let me know.
Flags: needinfo?(shorlander)
Hi Doug - 

Is your concern that the concept/metaphor for the Push Notifications icon(s) is similar to that for Notifications but shouldn't be? I.e. do you they think they represent concepts that should be portrayed as more dissimilar? Or is it just that it's odd to have two icons that differ only very slightly that a user may encounter near each other in a task flow?

If it's the latter -- we could, in the sort term, just use the same new (better!) iconography in both cases and rely on the text in the question to make a difference clear to the user. If it's the former -- this is an issue we've been struggling with here for a while: how would you characterize the difference in how these two permissions will likely be used? I know you mentioned that Push Notifications can be used for more things like updating data in a web app in the background, but I thought we'd established that that was not the principal use, in the short term, anyway.


(On the three icons not one issue - you mean ignore it because the sprite's just not being used properly (i.e. all three states shown at the same time), right? So you're flagging that that's NOT the issue you're pointing out?)
It is odd to have two icons so similar for things that can have very different use cases.  We can use what we have in the short term, but I do not think that is great.  It might be that we join the permissions for web notifications and push.  We should work through these user experiences and try to understand what is best.

Can we do this for 41, or do you prefer that we go ahead and use these icons (instead of geo!) and follow up?
I'm concerned about the metaphor.  The hailer icon implies broadcast.  I think that a bell is a much closer match, though that has the unfortunate existing use for alarms, which might be a confusing near miss.

As for whether to show two different notifications, I think that we should be combining these two permissions prompts.  See https://docs.google.com/document/d/1yYUB4nn9Hu6vPHKp_eN_kXOG47gjteEv8QIf_l18q4w/edit
Hi Matej - I suggested to the Push team that you might be able to review the copy in the FAQ and doorhanger they created. The link to the FAQ is: https://docs.google.com/document/d/16-sqk6l_D22PFYXGaEN_8kwHrrhvvoOYx0h-OBIGF-I/edit?usp=sharing

This will be surfaced to all Firefox desktop users in GA in November.  Code hasn't landed yet, but localization would happen soon after.
Flags: needinfo?(matej)
(In reply to Mika from comment #18)
> Hi Matej - I suggested to the Push team that you might be able to review the
> copy in the FAQ and doorhanger they created. The link to the FAQ is:
> https://docs.google.com/document/d/16-sqk6l_D22PFYXGaEN_8kwHrrhvvoOYx0h-
> OBIGF-I/edit?usp=sharing
> 
> This will be surfaced to all Firefox desktop users in GA in November.  Code
> hasn't landed yet, but localization would happen soon after.

My edits and comments are in. Thanks.
Flags: needinfo?(matej)
What is the progress on this? Can we land the image?
Update please?
Flags: needinfo?(madhava)
Assignee: dougt → nobody
Depends on: 1201571
Attached image Bubble icon
The latest designs for the Notification permission in Control Center look like a thought bubble rather than a megaphone. See attachment from current designs for Control Center slated into 42. Should we use this for a combined Push Notifications icon for the permissions dialog?
Flags: needinfo?(philipp)
Blocks: 1201571
No longer depends on: 1201571
The two permission prompts are being combined and we just want a new icon now.
Summary: Get a better icon for the Push permission prompt → Get a new icon for the Notification permission prompt
Need icon.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Per shorlander: We're going to use the bubble with the exclamation mark.
Bryan, could you attach the correct assets here? Thanks!
Flags: needinfo?(shorlander)
Flags: needinfo?(philipp)
Flags: needinfo?(madhava)
Flags: needinfo?(bbell)
Attached image notifications.svg (obsolete) —
new notifications icon.
Attachment #8606261 - Attachment is obsolete: true
Flags: needinfo?(bbell)
Replacement for notificationsTray
Attachment #8606260 - Attachment is obsolete: true
Attached image notifications-32.svg
updated notification icon.
Attachment #8668277 - Attachment is obsolete: true
Thanks, Bryan! I'll update the permission prompt in bug 1192458.
Landing as part of bug 1192458, to reduce merge churn.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1192458
User Story: (updated)
You need to log in before you can comment on or make changes to this bug.