Can not display accent characters properly on Win98-Simp. Chinese

VERIFIED FIXED in mozilla0.9.8

Status

()

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: amyy, Assigned: ftang)

Tracking

({intl})

Trunk
mozilla0.9.8
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Build: 12-14 trunk build / Win98 Simplfied Chinese

Steps:
1. Launch browser and go http://fr.yahoo.com
2. Check the charset by going Edit | Character Coding, it marked as iso-8859-1
which is correctly.

Result:
Those accent characters are not display properly, they are either can not be
displayed or display as sort of kanji (chinese) face.  Changing auto-detect
options could not correct the wrong display.

Note: the page is displayed fine on IE.
(Reporter)

Updated

17 years ago
Keywords: intl
QA Contact: teruko → ylong
(Reporter)

Comment 1

17 years ago
Created attachment 61823 [details]
Screen shot for the display problem
(Assignee)

Comment 2

17 years ago
shanjian- it seems we are using the A version on Chinese and Korean Win95/98
also. I think we should not do so and only limited such approach for Japanese
Win95/98. The reason is Japanese window do NOT do font association but Chinese
and Korean window does. 
Assignee: yokoyama → shanjian

Comment 3

17 years ago
We only use A version when GetACP return 932 (shift-JIS). It might be a different
problem. sigh...
Status: NEW → ASSIGNED
(Assignee)

Comment 4

17 years ago
ylong, this only happen to chinese and korean system (win 95 and win 98) right ?

shanjian- read my early research notes on 
http://people.netscape.com/ftang/europtype.html
That is what I wrote 4 years ago and many thing changed. not sure it is related
or not 
(Assignee)

Comment 5

17 years ago
also, I remember some one told me long time ago there are a api way to turn off
the font association on C and k version of Win95/98 by using a undocumented
option flag.

(Assignee)

Comment 6

17 years ago
in addition to the comment above- the API I talk about only affect that
particular application. The registry hack will impact the whole system. 
(Assignee)

Comment 7

17 years ago
some infor about "Font Association" are described in 
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon98/html/vbconfontdisplayprintconsiderationsindbcsenvironment.asp

see http://support.microsoft.com/default.aspx?scid=kb;EN-US;q142607 :
Extra set for Chinese PRC locale (GB or GBK Code)
This set includes the following features: 
* Turning on/off the system default Font Association. For certain English
applications, turning off the Font Association is necessary to prevent High ANSI
characters (for example, smart quotes) from displaying as Chinese characters.

also 
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnintl/html/s24b6_j.asp


ok, here is the trick
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q171153

HOWTO: Display Graphic Chars on Chinese & Korean Windows (Q171153)
The information in this article applies to:

    * Microsoft Win32 Software Development Kit (SDK), used with:
          * Microsoft Windows 95
          * the operating system: Microsoft Windows NT
          * the operating system: Microsoft Windows 2000



SUMMARY

When an application tries to display extended ANSI (above Hex 80, graphic
characters like double dagger, curly quotes, and etc.) characters on Chinese and
Korean Windows 95 or Windows NT, these characters are actually displayed as
double-byte characters.

MORE INFORMATION

For example, under Windows 95 Korean version, when you select the Times New
Roman font, a word processor tries to display English text with curly quotes. As
a result, the system displays Korean characters instead of curly quotes. The
reason is that these extended area characters are also used as lead-byte for
double-byte character sets.

To display the extended ANSI character correctly on Chinese and Korean Windows
95 or Windows NT, the Font Association of the system should be turned off. By
default, Font Association is always on. To turn off the Font Association in your
application, use CreateFontIndirect() with lfClipPrecision in LogFont set as
0x40. This doesn't have any effect on non- Font Association system.

...
If you use Japanese Windows NT and Windows 95, you do not need to follow the
methods discussed above. They are already enabled to display extended ANSI
characters. Japanese Windows 95 doesn't have the Associated CharSet key and
Japanese Windows NT 4.0 has the Associated CharSet key defaulted to "no".





(Assignee)

Comment 8

17 years ago
Created attachment 62363 [details] [diff] [review]
experimental patch
(Assignee)

Comment 9

17 years ago
I have not test this patch yet. 
(Assignee)

Comment 10

17 years ago
yokoyama: can you reproduce the origional problem on your Chinese Win 2K ?
(Reporter)

Comment 11

17 years ago
I don't see this on Chinese W2k.

Comment 12

17 years ago
I guess ylong answered your question, frank.
Anything else you want me to do?
(Assignee)

Comment 13

17 years ago
could also cause 88496
(Assignee)

Comment 14

17 years ago
*** Bug 88496 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

17 years ago
I try the patch on sc win98. And we confirm that patch fix the problem. 
shanjian, can you r= that ?
Assignee: shanjian → ftang
Blocks: 104056
Status: ASSIGNED → NEW
Target Milestone: --- → mozilla0.9.8
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 16

17 years ago
Comment on attachment 62363 [details] [diff] [review]
experimental patch

Looks fine. r=shanjian
Attachment #62363 - Flags: review+
(Assignee)

Updated

17 years ago
Blocks: 104148
No longer blocks: 104056
Comment on attachment 62363 [details] [diff] [review]
experimental patch

sr=brendan@mozilla.org
Attachment #62363 - Flags: superreview+
(Assignee)

Updated

17 years ago
Blocks: 104060
No longer blocks: 104148
(Assignee)

Comment 18

17 years ago
fix and check in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 19

17 years ago
Verified fixed on 12-27 win32 trunk build on both Win98-S.CN and Win98-KO.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 20

17 years ago
*** Bug 113205 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
No longer blocks: 104060

Comment 21

17 years ago
*** Bug 121594 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.