Closed Bug 1154614 Opened 7 years ago Closed 7 years ago

[Flame][Settings]Try to rename my device in Settings->Bluetooth,system is hang.

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla40
blocking-b2g 2.5?
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: zikui.yang, Assigned: kats)

References

Details

(Keywords: regression, smoketest)

Attachments

(4 files)

[1.Description]:
[Flame][v3.0][Settings]Enter Settings->bluetooth,enable bluetooth and Visible to all,try to rename device,tap input box,system is crash,press power key/volume key/tap screen,there is no response.
Attachment:VIDEO0351_Compress.MP4 and logcat(16).txt
Happen time: 6:29

[2.Testing Steps]: 
1.Launch Settings
2.Tap Bluetooth
3.Toggle on bluetooth and toggle on Visible to all
4.Tap "Rename my device",try to rename device

[3.Expected Result]: 
5.You can rename device successfully.

[4.Actual Result]: 
4.The device is hang,press power key/volume key/tap screen,there is no response.

[5.Reproduction build]: 
Flame 3.0 (affected):
Build ID               20150414160204
Gaia Revision          8e28588496f82f8f069c171c65842d622b9d8d7d
Gaia Date              2015-04-14 18:43:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/de27ac2ab94f
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached video VIDEO0351_Compress.MP4
Attached file logcat(16).txt
A v3.0 regression.

Add tag -"regression" & "regressionwindow-wanted"
Keywords: regression
Summary: [Flame][Settings]Try to rename my device in Settings->Bluetooth,system is crash. → [Flame][Settings]Try to rename my device in Settings->Bluetooth,system is hang.
Hi Elie, I think the problem is relative with input focus. Is the problem only happened in this specific user story(settings::bluetooth::rename)? Are you able to reproduce it from other input field? Thanks.
Assignee: nobody → iliu
Flags: needinfo?(zikui.yang)
(In reply to Ian Liu [:ianliu] from comment #4)
> Hi Elie, I think the problem is relative with input focus. Is the problem
> only happened in this specific user story(settings::bluetooth::rename)? Are
> you able to reproduce it from other input field? Thanks.

Hi Lan
I tried to invoke keyboard in Clock/contact/Message/Mail/E.me/SIM PIN input/Wifi,and input some words to input box,It looks well. Till now,I found this issue only happened in Settings->BT->Rename my device.
Thanks.
Flags: needinfo?(zikui.yang) → needinfo?(iliu)
Elie, Thanks for your info. We can focus on what settings::bluetooth panel have done. Then, we are stuck in the hanged issue.
Flags: needinfo?(iliu)
Hi Xulei, Could you please help to investigate the issue? I cannot grep any console log and other operation while the issue is happened. Thanks.
Flags: needinfo?(xyuan)
I find out the problem is coming from access <input type="text">. If we don't access the input instance 'updateNameInput'[1], the platform won't be hanged.

Xulei, I try to mark out these code which is accessed with 'updateNameInput'. Then, the dialog show/hide normally. Not sure these info is helpful for you.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/bluetooth.js#L90-L95
[Blocking Requested - why for this release]:

A basic function is broken.
blocking-b2g: --- → 3.0?
Caused by APZ related patches.(Bug 1154130)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID:    20150414091119
Gaia:       c8cb0c0ebb8dd1f5c0c9037e38f8e4b237beb77b
Gecko:      598ccd9bc144
Version:    40.0a1 (3.0) 
Firmware:   v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken Environmental Variables:
Device:     Flame 3.0
BuildID:    20150414092719
Gaia:       c8cb0c0ebb8dd1f5c0c9037e38f8e4b237beb77b
Gecko:      879e74f2e74c
Version:    40.0a1 (3.0) 
Firmware:   v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce 
Gaia:  c8cb0c0ebb8dd1f5c0c9037e38f8e4b237beb77b
Gecko: 879e74f2e74c

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: c8cb0c0ebb8dd1f5c0c9037e38f8e4b237beb77b
Gecko: 598ccd9bc144
Attached file Thread backtrace
I can look into this.
Assignee: iliu → bugmail.mozilla
Component: Gaia::System → Panning and Zooming
Product: Firefox OS → Core
Appreciated!
Thanks Kartikaya! :)
Attached patch PatchSplinter Review
GetIndirectShadowTree tries to grab the lock, so holding the lock prior to calling it is a bad idea. I just rearranged this method to be consistent with the other nearby functions, which I think should be correct.
Attachment #8592833 - Flags: review?(dvander)
Duplicate of this bug: 1154706
Blocks: 1154749
Blocks: 1154751
Duplicate of this bug: 1154604
Comment on attachment 8592833 [details] [diff] [review]
Patch

Review of attachment 8592833 [details] [diff] [review]:
-----------------------------------------------------------------

Whoops, sorry about that.
Attachment #8592833 - Flags: review?(dvander) → review+
No longer blocks: 1154751
No longer blocks: 1154749
Landed directly on m-c so we can get new nightlies with the fix.

https://hg.mozilla.org/mozilla-central/rev/11077895df62
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(xyuan)
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Duplicate of this bug: 1154749
Moving markers over.

Also see below:
This issue is locking up the phone in several different areas. Here is a current list of known affected areas:

-Calendar when switching to Week or Day view
-Settings app, specifically in Sim Manager, as well as possibly in Bluetooth
-Email, on the Google sign in page, Manual Set Up page, and when changing to a second account in the Drawer.
QA Contact: ychung
This issue is verified fixed on Flame Master.

Result: Device functions properly without any issue when following STRs from Comment 0 and Comment 20.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150415095209
Gaia: 2dd89fef4fae4d86fd313037ef384086c2e0e8a5
Gecko: 11077895df62
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Duplicate of this bug: 1155607
You need to log in before you can comment on or make changes to this bug.