Using HTML composer in mail/news a ">" is added between quoted and new material

RESOLVED DUPLICATE of bug 165077

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 165077
16 years ago
10 years ago

People

(Reporter: Holger Metzger, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
mozilla1.1alpha

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [de] (Windows NT 5.0; U)
BuildID:    2001121508

Using the HTML composer for mail/news, when quoting something:

Example:
---------
> blahblahblah
> blahblahyaddayadda

My reply here....
-----------------------
turns into the following when it has been sent:
-----------------------
> blahblahblah
> blahblahyaddayadda
>
My reply here....
-----------------------
and extra ">" is added between quoted and new material.

Reproducible: Always
Steps to Reproduce:
1. Reply to a message using the HTML composer.

Actual Results:  ">" is added between quoted and new material.

Expected Results:  ">" shouldn't be added.

This might be connected to #102842.

Comment 1

16 years ago
I see this too and it annoys me.

Bug might be in the serializer (Browser: DOM To Text), not sure.

Holger, can't you confirm bugs? CONFIRMing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 2

16 years ago
> Holger, can't you confirm bugs?

I wouldn't dare! :-)

-Holger

Comment 3

16 years ago
I see this bug only, if I reply to a non-flowed mail (i.e. the ones emitted by 
4.x etc., not Mozilla. (flowed and non-flowed plaintext converters generate
different HTML.)
(Reporter)

Comment 4

16 years ago
I see the extra ">" all the time, whether the original /plaintext/ mail was in
f=f or not.
When the original has been in html and I reply in html or plaintext the extra
">" isn't there.

- Holger
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Comment 5

16 years ago
Seems it's not a bug, it's a (mis)feature to separate different quotation levels.
For me notoriously appears in plaintext editing - not always, in some 90%
(couldn't make out the rule though) and is very annoying with deeply nested
replies, i.e reasonable:

>>>>> a
>>>> b
>>> c
>> d
> e

f

after two replies turns into annoying:

>>>>>>> a
>>>>>>>
>>>>>>>
>>>>>> b
>>>>>>
>>>>>>
>>>>> c
>>>>>
>>>>>
>>>> d
>>>>
>>>>
>>> e
>>>
>>>
>>f
>>
>>
>g
>

h

Can it be related to Bug 34941?

Comment 6

16 years ago
> Can it be related to Bug 34941?

No, that bug is about the plaintext composer, while this one is about the HTML
composer.
And no, it's not a feature.

I'll mark bug 122925 a dup of this one. Not sure, why I filed a new bug back
then. (Oversight, different bug?)

Here's the reproduction from the other bug:

Reproduction:
1. Reply to a non-flowed plaintext mail (as sent by 4.x).
2. Put cursor in the quote, hit Return to break it.
3. Enter your text
4. Send as plaintext

Actual result:

Somebody wrote:
> quote
> quote
> 
Your text

> quote

Exptected result:

Somebody wrote:
> quote
> quote

Your text

> quote

Additional Comments:
That might be the problem I describe in
<http://bugzilla.mozilla.org/show_bug.cgi?id=102842#c12>, I don't remember anymore.
This might be libmime or Composition.

Comment 7

16 years ago
*** Bug 122925 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
reporter of bug 183134 claims to see this bug when replying in plain text mode 

Comment 9

15 years ago
*** Bug 183134 has been marked as a duplicate of this bug. ***
Product: MailNews → Core

Comment 10

13 years ago
The dupe is a later bug but has very detailed analysis of the problem.

*** This bug has been marked as a duplicate of 165077 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.