mozilla hangs on flash-rich pages

VERIFIED DUPLICATE of bug 132759

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 132759
16 years ago
15 years ago

People

(Reporter: Chunnuan Chen, Assigned: av (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011125
BuildID:    2001112501

mozilla hangs on flash-rich pages

Reproducible: Always
Steps to Reproduce:
1.go to http://news.sina.com.cn
2.if 1 doesn't hang the browser, click a few links
3. the broswer will hang soon

Comment 1

16 years ago
*** Bug 72635 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
i see this one on windows too. cpu goes to 100% after  I click on 2-3 random 
links on the page (I did not install the font that was required on this page). I 
see a lot of pop ups flooding on the screen and then the browser just stops 
responding.
OS: Linux → All
Hardware: PC → All

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Same problem on linux 2001121715 at http://www.7up.com

Comment 4

16 years ago
is this a new problem (regression) or an exsisting one (dup)?

Comment 5

16 years ago
Surely, this is not happening for all flash pages, BUT, the 7up page and the 
above test url do really slow tdown the machine and it's difficult to navigate 
since the cpu goes to 100%. I think this is new, there might be a few similar 
bugs..I will try to find dups.

Comment 6

16 years ago
http://www.7up.com is probably a dup of 115808 and it's linux only regression ,
but win32 platform problem in general (100% cpu loading when flash plugin is 
playing some *.swf ) is not new, 4.x has the same problem. BTW linux plugin 
could work fine with the same file. I haven't try it on mac.

Comment 7

16 years ago
Created attachment 62227 [details]
an example of .swf which eats ~100% cpu on w2k

here is an example of such .swf file I've borrowed from http://news.sina.com.cn

Comment 8

16 years ago
this is not a new bug - also reported in bug 99361

Comment 9

16 years ago
and bug 101879

Comment 10

16 years ago
I ran into this at http://www.port.am/maprus/framesrus.html
(goes computedbound, UI freezes).  I'm currently running
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc1) Gecko/20020417
with Shockwave Flash 5.0 r41

With Netscape 6.22, slightly different symptoms - goes computebound,
but the UI still responds.

With Netscape 4.79, works fine (if slowly - low bandwidth part of the
web, I think).

I can't yet say whether http://news.sina.com.cn fails for me - it's
still loading after about 10 minutes.

Comment 11

16 years ago
The plug-ins triage team (av, beppe, peterl, serge and shrir) have reviewed this
issue and have made the following determination:

This is a dup of bug 132759, even though this was reported prior to that bug.

*** This bug has been marked as a duplicate of 132759 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 12

15 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.