Closed Bug 1156881 Opened 6 years ago Closed 6 years ago

Crash in QuotaManager::AbortCloseStoragesForProcess while stability testing

Categories

(Core :: DOM: Core & HTML, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1152407

People

(Reporter: ggrisco, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [b2g-crash][caf-crash 445][caf priority: p1][CR 826233])

Crash Data

Attachments

(2 files)

Saw this crash signature while running stability tests:

[@ nsCOMPtr::nsCOMPtr | mozilla::dom::quota::QuotaManager::AbortCloseStoragesForProcess | mozilla::dom::ContentParent::ShutDownProcess | RunnableMethod >::Run ]

This looks like similar crash to bug 1154445, so wanted to provide the data to see if it's helpful.
Whiteboard: [CR 826233] → [caf priority: p1][CR 826233]
Whiteboard: [caf priority: p1][CR 826233] → [b2g-crash][caf-crash 445][caf priority: p1][CR 826233]
Keywords: crash
Hi Jan,

Is this bug a duplicate of bug 1152407, or do they share the same root cause and fix? Their crash signatures look similar.

Mike
Component: Stability → DOM
Flags: needinfo?(Jan.Varga)
Product: Firefox OS → Core
(In reply to Mike Lee [:mlee] from comment #4)
> Hi Jan,
> 
> Is this bug a duplicate of bug 1152407, or do they share the same root cause
> and fix? Their crash signatures look similar.
> 
> Mike

Yeah, it's the same root cause.
Flags: needinfo?(Jan.Varga)
See Also: → 1152407
Thanks Jan. Since you're working on the other related bug, should you also be set as the assignee for this one?
Flags: needinfo?(Jan.Varga)
Hi Mike, Hi Jan,
should we duplicate this one to bug 1152407?
According to comment 5, duplicate this case to bug 1152407.

--
Keven
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1152407
No longer blocks: CAF-v2.2-metabug
blocking-b2g: 2.2? → ---
Flags: needinfo?(Jan.Varga)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.