Closed Bug 1156934 Opened 5 years ago Closed 3 months ago

Be more efficient with how we update the LookAndFeel int cache in the content process

Categories

(Core :: Widget, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla78
Fission Milestone M7
Tracking Status
e10s + ---
firefox40 --- wontfix
firefox78 --- fixed

People

(Reporter: mconley, Assigned: emilio)

References

Details

(Whiteboard: tpi:+,[qf:p3:resource])

Attachments

(1 file)

Bug 1096093 adds a mechanism for transferring a cache of LookAndFeel values from the parent process to content processes. This cache is updated when the parent notices that the system theme has changed.

It's updated once per PresContext, via the ThemeChanged IPDL message over PBrowser.

We should really only need to do this once per content process.
tracking-e10s: --- → +
Priority: -- → P4
Whiteboard: tpi:+
Depends on: 1382326

Actually hurts E10S more than fission (as there are less content processes than tabs (typically) in e10s)

Whiteboard: tpi:+ → tpi:+,[qf]
Fission Milestone: --- → ?
Priority: P4 → P3

Emilio suggested notifying all content processes of the change (probably using ContentParent::GetAll()), then notifying all prescontexts within the process from there.

Flags: needinfo?(emilio)

Jim thinks this will get fixed by LookAndFeel remoting for win32k lockdown. He'll ask gcp.

Tracking for Fission M7 Beta

Severity: normal → S3
Fission Milestone: ? → M7
Depends on: 1640191
Whiteboard: tpi:+,[qf] → tpi:+,[qf:p3:resources]
Whiteboard: tpi:+,[qf:p3:resources] → tpi:+,[qf:p3:resource]
Depends on: 1640264
Assignee: nobody → emilio
Flags: needinfo?(emilio)

This should fix the issue for preallocated processes that still don't
host any document, and also send a few less IPC messages.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/360c1a12d594
Notify all content processes when LookAndFeel changes. r=jesup
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Duplicate of this bug: 1638618
You need to log in before you can comment on or make changes to this bug.