Closed Bug 1158270 Opened 6 years ago Closed 6 years ago

Plugins can't run if e10s is force-disabled

Categories

(Core :: Plug-ins, defect)

40 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: alice0775, Assigned: Felipe)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]: regression

Though Flash plugin "always activate" in  about:addons,
Flash plugin is disabled,  fals to run.

Steps to reproduce:
1. Open non-e10s browser
2. Open http://www.adobe.com/software/flash/about/
     or any other page http://edition.cnn.com/videos
 
Actual results:
Flash plugin fails to run

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4bae26d5e06f&tochange=19d97c221555
Regressed by:
19d97c221555	Brad Lassey — bug 1155976 - Loading plugins in a non-e10s window hangs the browser on Mac r=jimm
Flags: needinfo?(blassey.bugs)
Summary: Flash plugin is disabled, fals to run without e10s → Flash plugin is disabled, fails to run without e10s
It failed if non-e10s window was opened from File menu.
However , it worked if e10s was disabled from option.
And Flash plugin also fails on Windows10TP and Windows8.1 because e10s was disabled (An accessibility tool is or was active) by default.
Duplicate of this bug: 1158408
Duplicate of this bug: 1158451
(In reply to Alice0775 White from comment #1)
> It failed if non-e10s window was opened from File menu.
> However , it worked if e10s was disabled from option.

This is intentional, the purpose of bug 1155976 is to disable plugins for "non-e10s windows" because they can't run at the same time on e10s and non-e10s windows.

(In reply to Alice0775 White from comment #2)
> And Flash plugin also fails on Windows10TP and Windows8.1 because e10s was
> disabled (An accessibility tool is or was active) by default.

This is a bug, currently any user with e10s force disabled (e.g. for Accessibility, lack of hardware accel, etc.) will have plugins disabled. I'll post a patch.
Assignee: nobody → felipc
Status: NEW → ASSIGNED
Flags: needinfo?(blassey.bugs)
Summary: Flash plugin is disabled, fails to run without e10s → Plugins can't run if e10s is force-disabled
Attached patch PatchSplinter Review
Some of the prefs might be true but e10s can still be globally disabled because it was force disabled.
Attachment #8597706 - Flags: review?(jmathies)
Is it impossible to run two plugin containers for e10 and non-e10?
(In reply to laz2727 from comment #7)
> Is it impossible to run two plugin containers for e10 and non-e10?

Yeah, at the moment this is not properly supported, and we think fixing that would be harder than what's worth spending time, since this configuration (e10s and non-e10s at the same time) is not meant to exist in the long run.
Attachment #8597706 - Flags: review?(jmathies) → review+
(In reply to laz2727 from comment #7)
> Is it impossible to run two plugin containers for e10 and non-e10?

We have no plans to support something like this in release.
I had to revert to "firefox-35.0a1.en-US.win64-x86_64.installer" (the only one I have)  and turned off "Automatically install updates (recommended: improved security)", it is now set at "Check for updates, but let me choose whether to install them" whuch will be never until the Flash situation is resolved because at this level it works.
(In reply to htacoma@spamcop.net from comment #10)
> I had to revert to "firefox-35.0a1.en-US.win64-x86_64.installer" (the only
> one I have)  and turned off "Automatically install updates (recommended:
> improved security)", it is now set at "Check for updates, but let me choose
> whether to install them" whuch will be never until the Flash situation is
> resolved because at this level it works.

this should be fixed in the next Nightly
Depends on: 1158713
https://hg.mozilla.org/mozilla-central/rev/f43178fc99aa
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
(In reply to :Felipe Gomes from comment #12)
> (In reply to htacoma@spamcop.net from comment #10)
> > I had to revert to "firefox-35.0a1.en-US.win64-x86_64.installer" (the only
> > one I have)  and turned off "Automatically install updates (recommended:
> > improved security)", it is now set at "Check for updates, but let me choose
> > whether to install them" whuch will be never until the Flash situation is
> > resolved because at this level it works.
> 
> this should be fixed in the next Nightly

Applied "Nightly 40.1a1 20150427030207 Nightly" and Flash would not start.
Again reverted to 35.0a1
(In reply to Han Tacoma-Emons from comment #14)
> (In reply to :Felipe Gomes from comment #12)
> > (In reply to htacoma@spamcop.net from comment #10)
> > > I had to revert to "firefox-35.0a1.en-US.win64-x86_64.installer" (the only
> > > one I have)  and turned off "Automatically install updates (recommended:
> > > improved security)", it is now set at "Check for updates, but let me choose
> > > whether to install them" whuch will be never until the Flash situation is
> > > resolved because at this level it works.
> > 
> > this should be fixed in the next Nightly
> 
> Applied "Nightly 40.1a1 20150427030207 Nightly" and Flash would not start.
> Again reverted to 35.0a1

the fix did NOT make the Nightly, landed/merged too late, will be tomorrow now.
I'm in 40.0a1 (2015-04-27) and flash is loading for me in a non-e10s browser.
(Re-posting my comment to correct a typo):
(In reply to Jim Mathies [:jimm] from comment #16)
> I'm in 40.0a1 (2015-04-27) and flash is loading for me in a non-e10s browser.

I only hit this bug if e10s is force-disabled *due to an a11y tool having been active* -- i.e. if e10s is force-disabled via the pref "browser.tabs.remote.autostart.disabled-because-using-a11y"

(And I do hit it in current nightly, but not in latest inbound build.)

So I think comment 15 is correct.
I verified that this is fixed in today's nightly.
 BROKEN: 40.0a1 (2015-04-27)
 FIXED: 40.0a1 (2015-04-28)

(Tested by setting the pref in comment 18 to true, in a fresh profile, and then trying to load http://homestarrunner.com/ in that profile.)

Clearing "tracking-firefox40" request, since this is fixed now.
Status: RESOLVED → VERIFIED
I verified too last update FF 40.0a1 (2015-04-29) repaired my Flash Player. (thanks)

But still can't enable E10S and see comment "Enable E10S (multi-process) (disabled: An accessibility tool is or was active. See bug 1115956.)".
Yup. As that message says, "see bug 1115956" (specifically bug 1115956 comment 12) if you see that message & want to enable e10s. :)
I still get this when I open a new non-e10s window in the latest nightly build.
(In reply to Matt Cosentino from comment #22)
> I still get this when I open a new non-e10s window in the latest nightly
> build.

Yeah, this is intentional, plugins aren't supported in non-e10s windows. See comment 5 or 8 for the reason.
You need to log in before you can comment on or make changes to this bug.