Make tinderbox printline and other off-screen job data more discoverable

VERIFIED FIXED

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: aklotz, Assigned: jfrench)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
In bug 913244, jmaher added the ability to upload the trace file from a failed xperf run. TBPL's UI would give us a handy link to that file.

Could we add that link to the treeherder UI?
Do we rely on TinderboxPrints for this in Treeherder?
actually this is displayed but way down on the list in the lefthand side of the popup display pane.  It was a lot easier to find this in tbpl- maybe we can do something here to make those hidden links more visible?
It seems like the general complaint is that "artifact uploaded" field in the job pane in the summary view is not sufficiently obvious. Show we put this in the error summary?
yeah, if we could get that in the error summary or make it easier in treeherder to know that there are links and data in that left hand side of the preview pane!

Comment 7

3 years ago
I'm not sure the error summary is the right place for this - perhaps another tab in that panel?
We discussed this in the meeting. I believe we agreed that an "Extra info" (other name suggestions welcome) containing this information is the way to go.
(Assignee)

Comment 9

3 years ago
I'll have a look at this and if I make progress I'll assign myself.
(Assignee)

Comment 10

3 years ago
Created attachment 8600091 [details]
extraInfoWip1

Current WIP for our 'Extra info' tab. Looking at it locally, imo I think we should consider having this printline data only in this tab; rather than leaving them also at the bottom of the job details panel (was discussed in the TH mtg today).

I think replicating the data would be kind of confusing to the user, and increases visual/comprehension workload.

I wonder if we can get away with moving 'Buildername' also to the tab. ie. Do sheriffs and users need to see it right away on job load?
Flags: needinfo?(wkocher)
(Assignee)

Updated

3 years ago
Summary: Add link to etl blob in failed xperf tests → Make tinderbox printline and other off-screen job data more discoverable
Comment on attachment 8600091 [details]
extraInfoWip1

Sounds good to me. I'd move the new tab to the end of the row of tabs (or at least not between the Failure Summary and Annotation tabs).
Flags: needinfo?(wkocher)
Attachment #8600091 - Flags: feedback+
(Assignee)

Comment 12

3 years ago
Sounds good. I'm also thinking we might rename this tab "Job info", or similar. I will muse on that some more while I work on a related discovery tweak.
(Assignee)

Updated

3 years ago
Assignee: nobody → tojonmz
Status: NEW → ASSIGNED
(Assignee)

Comment 13

3 years ago
Created attachment 8601580 [details] [review]
treeherder-ui-PR#508

Please see above PR for status and review. I want to do a bit more testing prior to merge.
Attachment #8601580 - Flags: review?(cdawson)
Comment on attachment 8601580 [details] [review]
treeherder-ui-PR#508

This looks good to me.  As long as we still default to the "Failure Summary" tab first, which it looks like we do.
Attachment #8601580 - Flags: review?(cdawson) → review+
(Assignee)

Comment 15

3 years ago
Correct, we still default to Failure Summary. Thanks camd, I will re-base and merge tomorrow. :)
(Assignee)

Comment 16

3 years ago
Some discussions going on in the PR re: the details count, will hold off merging for now.
(Assignee)

Comment 18

3 years ago
Marking fixed per above merge. I will verify on the next push to stage/prod.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

3 years ago
Verified fixed on stage.
Status: RESOLVED → VERIFIED

Updated

3 years ago
Depends on: 1166984

Updated

3 years ago
Depends on: 1166028

Updated

3 years ago
Duplicate of this bug: 1085725
You need to log in before you can comment on or make changes to this bug.