[e10s] When you click-and-drag on a <select>, its selected option doesn't change until you release click

RESOLVED FIXED in Firefox 51

Status

()

Core
Layout: Form Controls
P2
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: dholbert, Assigned: Neil Deakin)

Tracking

(Blocks: 1 bug)

Trunk
mozilla51
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox40 affected, firefox51 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
STR:
 1. Visit this URL:
data:text/html,<html><select><option>1</option><option>2</option><option>3</option></html>

 2. Click-and-hold on the <select> element, and move your cursor across the now-visible menu items.

EXPECTED RESULTS: Menu items should be selected/highlighted as I mouse across them.

ACTUAL RESULTS: Selected item does not change until I release my click.


Mozilla/5.0 (X11; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Nightly with disabled e10s has EXPECTED RESULTS.
Nightly with enabled e10s gives ACTUAL RESULTS.

(Note: I originally reported this in bug 1154841 comment 2, when trying to reproduce mconley's symptoms there, but I'm spinning this off to a new bug since it's pretty different from that bug.)
tracking-e10s: --- → ?
Assignee: nobody → gwright

Updated

3 years ago
tracking-e10s: ? → m8+
tracking-e10s: m8+ → +
Duplicate of this bug: 1165782

Comment 2

3 years ago
AFAIK, the issue is not present with FF on Windows in e10s mode, only Linux (and maybe OSX).

Comment 3

3 years ago
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID 	20160204030229

User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID 	20160204004009

Tested this on Aurora 46 and Nightly 47: 
 - Ubuntu 15.04 64x - Reproduced with e10s enabled, works with e10s disabled.
 - Windows 7 64x  - Works as expected both with e10s enabled and disabled.
 - Mac 10.10 - Works as expected both with e10s enabled and disabled.

So, this confirms what Loic said in comment 2: only Linux is affected.

Updated

3 years ago
OS: Unspecified → Linux
Priority: -- → P2
(Assignee)

Comment 4

2 years ago
Created attachment 8772467 [details] [diff] [review]
Clear capture when any menu is opened

The issue here is that a mouse capture is added on the remote <browser> when clicking and holding in the content area, preventing mouse events from targeting the popup. This patch ensures the capture is cleared when the select popup opens.
Assignee: gwright → enndeakin
Status: NEW → ASSIGNED
(Assignee)

Updated

2 years ago
Blocks: 1226915
(Assignee)

Comment 5

2 years ago
Created attachment 8774817 [details] [diff] [review]
Patch with test
Attachment #8772467 - Attachment is obsolete: true
Attachment #8774817 - Flags: review?(tnikkel)
Attachment #8774817 - Flags: review?(tnikkel) → review+
(Assignee)

Comment 6

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/474fb44b90095c411a55306b012f6447e1bfda28
Bug 1159301, clear the mouse capture whenever a menu is opened, r=tn

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/474fb44b9009
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla51

Updated

2 years ago
See Also: → bug 1327149
You need to log in before you can comment on or make changes to this bug.