Closed Bug 1159457 Opened 5 years ago Closed 5 years ago

Re-arrange Homescreen to accommodate Spark apps

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-master fixed)

RESOLVED FIXED
2.2 S13 (29may)
blocking-b2g 2.5+
Tracking Status
b2g-master --- fixed

People

(Reporter: drs, Assigned: daleharvey)

References

Details

(Whiteboard: [spark][systemsfe])

Attachments

(1 file, 7 obsolete files)

See bug 1158367 for discussion.

I'm not attached to any one way of arranging these apps, but we should definitely at least have something a little more sane than grouping all of the new apps at the end of the Homescreen.

I do think we should definitely switch to 4 icons per column, though. It looks and works a lot better with the new hardware.
Attachment #8598910 - Flags: review?(kgrandon)
Comment on attachment 8598910 [details] [diff] [review]
Re-arrange Homescreen to accommodate Spark apps.

Review of attachment 8598910 [details] [diff] [review]:
-----------------------------------------------------------------

R-, but only because it's invalid JSON.

Another thing that I think we should do now that we want to re-arrange the core apps, is find a way for this to get populated in the distribution folder during the b2g build.

I also don't think that we should change to 4 columns, but we can check with UX on that.
Attachment #8598910 - Flags: review?(kgrandon) → review-
Whoops, good catch. Updated PR.

I spoke with Patryk about this and he's going to come up with a proposal for what we'll do here. We may or may not need to make any changes, so I'm going to hold off on reviews for now until we know what we're doing.
Attachment #8598910 - Attachment is obsolete: true
Flags: needinfo?(padamczyk)
We should stick with 3 columns by default, the homescreen was designed with that layout in mind, and we (UX team) feel that the 3 columns look great on the hardware. If the device was bigger like the Z3, then we'd consider 4 columns.

Here's the proposed default hierarchy, it moves the Spark apps up so they appear on 4th row but still keeps the key apps that most people will want to use on above:

https://docs.google.com/a/mozilla.com/spreadsheets/d/1M5OZDRz3eJ_Cqh7v36jYbTsp0_09VbvtbHRRP5LAYZ8/edit?usp=sharing
Flags: needinfo?(padamczyk)
Ok, thanks for the proposal. I think we should really avoid putting the Spark apps into a folder. We're trying to draw attention to them, and make it clear that this isn't just Firefox OS v2.2 loaded onto an Aries device. Hiding them behind a folder makes it less likely that people will discover and use them.
Flags: needinfo?(padamczyk)
Hey Doug, the way we designed folders actually help group apps not hide them, by default the folder is expanded so the app icons are large. All the apps are visible and if anything highlighted due to the white frosted background.
Flags: needinfo?(padamczyk)
Ah, yeah, I thought that by "folder" you meant "collection". I see now, thanks.
See Also: → 1159989
We're going to use the Gaia customization framework instead of modifying the default Homescreen configuration.

Ted, could you take driving the support for Homescreen changes in the customization framework?
Flags: needinfo?(tclancy)
Okee doke.
Flags: needinfo?(tclancy)
Assignee: drs → tclancy
Attached file Bug-1159457-homescreen-arrangement (obsolete) —
Attachment #8598907 - Attachment is obsolete: true
Attachment #8598929 - Attachment is obsolete: true
Attachment #8603562 - Flags: review?(drs)
Attachment #8603562 - Attachment is obsolete: true
Attachment #8603562 - Flags: review?(drs)
Attached file Bug-1159457-homescreen-arrangement (obsolete) —
I'm not sure what value of GAIA_DISTRIBUTION_DIR we'll end up using, so this patch assumes GAIA_DISTRIBUTION_DIR will be set to the default value, which is 'distribution'.
Attachment #8603607 - Flags: review?(drs)
The customization framework works fine, but the documentation at https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/Market_customizations_guide is a little incomplete. I've just updated it.
Okay, apparently GAIA_DISTRIBUTION_DIR should be 'spark'. I've updated the patch to make that so.
Comment on attachment 8603607 [details] [review]
Bug-1159457-homescreen-arrangement

We're trying to get rid of the lightsaber repo, so we should no longer be landing new content there. It's ok to make changes to helper scripts though, like building with the "spark" customization set.

We should add this file directly to the Gaia repo. The changes to the lightsaber repo's Makefile are nice, though.

Please separate this into two parts, one for the lightsaber repo changes, and one for the Gaia spark/ folder. Ask me to review the lightsaber part, and you can ask :daleharvey and :kgrandon to review the other part.
Attachment #8603607 - Flags: review?(drs) → review-
Attachment #8603607 - Attachment is obsolete: true
Attachment #8604162 - Flags: review?(drs)
Comment on attachment 8604162 [details] [review]
[gaia] tedders1:bug-1159457-spark-homescreen-layout-part-1 > mozilla-b2g:master

I left a few comments on the PR.

Dale, could you answer the question that I left for you on the PR? Once we have that dealt with, you can actually review it.

Patryk, I think we forgot the Contacts app in the new layout. Please take a look.
Flags: needinfo?(padamczyk)
Attachment #8604162 - Flags: review?(drs)
Attachment #8604162 - Flags: review-
Attachment #8604162 - Flags: feedback?(dale)
Comment on attachment 8604163 [details] [review]
Bug 1159457 - part 2: Use spark customization directory for homescreen layout.

See my comments on the PR.
Attachment #8604163 - Flags: review?(drs) → review-
Sorry. I added contacts to line 22: https://docs.google.com/spreadsheets/d/1M5OZDRz3eJ_Cqh7v36jYbTsp0_09VbvtbHRRP5LAYZ8/edit#gid=0

Also all the "spark apps" like Foxfooding should be in the same folder, so added that in as well well.
Flags: needinfo?(padamczyk)
Comment on attachment 8604162 [details] [review]
[gaia] tedders1:bug-1159457-spark-homescreen-layout-part-1 > mozilla-b2g:master

I think we should put these in either `/customizations/spark/` or `/distributions/spark`, so the example customisations can be alongside as well as any other future distributions. Other than that looks good cheers
Attachment #8604162 - Flags: feedback?(dale) → feedback+
Actually realise 'distribution' folder is used by the default gaia build, '/distro/spark/` or moving everything for `/customizations/spark` probably less confusing
As other bug, Teds flooded with bidi stuff so taking, this is ready when we agree on which folder to land with
Assignee: tclancy → dale
No longer blocks: 1158367
Attachment #8610110 - Flags: review?(drs)
Comment on attachment 8610110 [details] [review]
[gaia] daleharvey:1159457 > mozilla-b2g:master

I left a few comments on the PR. You can ignore the one about the certified Spark apps for now. We'll deal with that in a follow-up once we figure out our strategy there.
Attachment #8610110 - Flags: review?(drs) → review-
Comment on attachment 8610110 [details] [review]
[gaia] daleharvey:1159457 > mozilla-b2g:master

Fixed up the tanx link, collections are going and will add certified apps seperately
Attachment #8610110 - Flags: review- → review?(drs)
Comment on attachment 8610110 [details] [review]
[gaia] daleharvey:1159457 > mozilla-b2g:master

Looks good.
Attachment #8610110 - Flags: review?(drs) → review+
Attachment #8604162 - Attachment is obsolete: true
Attachment #8604163 - Attachment is obsolete: true
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Merged, will open a new bug for the certified apps

https://github.com/mozilla-b2g/gaia/commit/8a3cbc9c8922b9480df740a895d6c3781add6fdf
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Blocks: spark-build
Blocks: 1169353
Target Milestone: --- → 2.2 S13 (29may)
Whiteboard: [spark] → [spark][systemsfe]
blocking-b2g: spark+ → 2.5+
You need to log in before you can comment on or make changes to this bug.