[Dialer]The "Deselect all" is truncated when editing call logs.

VERIFIED DUPLICATE of bug 1159644

Status

defect
VERIFIED DUPLICATE of bug 1159644
4 years ago
4 years ago

People

(Reporter: yue.xia, Assigned: gsvelto)

Tracking

({regression})

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: LocRun2.2)

Attachments

(3 attachments)

Reporter

Description

4 years ago
[1.Description]:
[Flame][v2.2][Dialer]Set device language to Bengali India, make a call and enter call log edit view, the "Deselect all" is truncated.
See attachment: bn-IN_Deselect all.png

[2.Testing Steps]: 
1. Insert SIM card into device and set device language to Bengali India
2. Open the Phone app and make a call
3. After ending the call, select the Call log tab to enter it
4. Select the edit icon

[3.Expected Result]: 
4. The "Deselect all" should not be truncated.

[4.Actual Result]: 
4. The "Deselect all" is truncated.

[5.Reproduction build]: 
Device: Flame 2.1 user (Unaffected)
Build ID               20150428001200
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/5f2c57b580ff
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150428.035731
Firmware Date          Tue Apr 28 03:57:42 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user (Affected)
Build ID               20150428002500
Gaia Revision          9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gaia Date              2015-04-27 20:41:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e79c19bf19bf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150428.042314
Firmware Date          Tue Apr 28 04:23:26 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Comment 1

4 years ago
This problem can be reproduced on latest user build of Flame2.1 & Flame2.2 in Greek language by the STR in comment 0.
See attachment: Greek_Deselect all.png

Device: Flame 2.1 user (Unaffected)
Build ID               20150429001202
Gaia Revision          9fda4aec7f9495a27a335ccaf3b1a4dc9c4c6db0
Gaia Date              2015-04-28 19:33:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/38ab00c01159
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.034244
Firmware Date          Wed Apr 29 03:42:55 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user (Affected)
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.040640
Firmware Date          Wed Apr 29 04:06:52 EDT 2015
Bootloader             L1TC000118D0
Reporter

Updated

4 years ago
Whiteboard: LocRun2.2,MGSEI-l10n-1F-Bengali India → LocRun2.2,MGSEI-l10n-1F-Bengali India,MGSEI-l10n-1F-Greek
If I understand correctly, this should be fixed with Bug 1157173. Please verify once fix lands. thanks
Also, blocking on this since it's a regression and affects meaning of string
blocking-b2g: --- → 2.2+
Keywords: regression
See Also: → 1157173
Wrong bug! Ignore comment 2 please, updating bug to reflect this
Keywords: verifyme
See Also: 1157173
Assignee: nobody → gsvelto
Target Milestone: --- → 2.2 S12 (15may)
Fixed by patch on bug 1159644
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1159644
Reporter

Comment 5

4 years ago
This problem is verified pass on latest user build of Flame 2.2 in the language of Spanish, Serbian Cyrillic, Russian, Bengali India, Greek, Polish, Basque, Portuguese from Brazil, Portuguese from Portugal and Arabic.
Please see attachment: Verify_Pass_2.2user_All language_Deselect all.png

Device: Flame2.2 user (Pass)
Build ID               20150511162500
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150511.195649
Firmware Date          Mon May 11 19:56:59 EDT 2015
Bootloader             L1TC000118D0
Reporter

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2,MGSEI-l10n-1F-Bengali India,MGSEI-l10n-1F-Greek → LocRun2.2
You need to log in before you can comment on or make changes to this bug.