Closed Bug 1157173 Opened 5 years ago Closed 5 years ago

[First Time Experience] The "Change" are overlapped and truncated in Date&time page.

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S11 (1may)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: zikui.yang, Assigned: sfoster)

References

Details

(Keywords: regression, Whiteboard: LocRun2.2, [systemsfe])

Attachments

(4 files)

[1.Description]:
[l10n][v2.2][First Time Experience]Russian:Goto Date&time page in FTE, the strings "Change" are overlapped and truncated.
Attchment:2015-04-22-09-39-33.png

[2.Testing Steps]: 
1.Launch FTE
2.Set langua to Russian
3.Tap next goto Date&time page

[3.Expected Result]: 
3.The strings "Change" should not be overlapped and truncated.

[4.Actual Result]: 
3.The strings "Change" are overlapped and truncated .

[5.Reproduction build]: 
Device: Flame 2.2 user (Affected)
Build ID               20150421002501
Gaia Revision          828dd03a0e3b140d74b2e49355197df4d91d9227
Gaia Date              2015-04-20 18:28:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/36f72a3efb9b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.042925
Firmware Date          Tue Apr 21 04:29:36 EDT 2015
Bootloader             L1TC000118D0

Device Flame 2.1 user build (Unaffected)
Build ID               20150421001205
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b85d4f4a6d61
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.040717
Firmware Date          Tue Apr 21 04:07:27 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
12258
Attached image 2015-04-22-09-39-33.png
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Russia → LocRun2.2, MGSEI-l10n-1F-Russian
Summary: [110n][First Time Experience]Russian:The "Change" are overlapped and truncated in Date&time page. → [l10n][First Time Experience]Russian:The "Change" are overlapped and truncated in Date&time page.
regression from 2.1. (same string used in 2.1 and 2.2, checked on transvision here: https://transvision.mozfr.org/?recherche=Change&repo=gaia&sourcelocale=en-US&locale=ru&search_type=strings)
Nominating as this affects a shipping locale, and probably others. 
Flagging UX for help on this. thanks
blocking-b2g: --- → 2.2?
Component: ru / Russian → Gaia::First Time Experience
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: regression
Product: Mozilla Localizations → Firefox OS
Summary: [l10n][First Time Experience]Russian:The "Change" are overlapped and truncated in Date&time page. → [First Time Experience] The "Change" are overlapped and truncated in Date&time page.
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Russian → LocRun2.2
Whiteboard: LocRun2.2 → LocRun2.2,MGSEI-l10n-1F-Russian
Regression so + on this.
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(firefoxos-ux-bugzilla)
Whiteboard: LocRun2.2,MGSEI-l10n-1F-Russian → LocRun2.2,MGSEI-l10n-1F-Russian [systemsfe]
Assignee: nobody → sfoster
It would help a lot if we can get a 2.1 and 2.2 screenshot for regressions.
Flags: needinfo?(lebedel.delphine)
Gregor: please in general prefer to need info the tester who filed the bug for these kinds of things.
Elie: When there's a regression, please remember and tell your team to provide the screenshots for both versions. I've seen a few bugs missing this.

Keeping the ni on me for this to provide a screenshot later today. thanks
Flags: needinfo?(zikui.yang)
Attached image 2.1 screenshot
Hmm screenshot from 2.1 shows that in 2.1, it already barely fit
Flags: needinfo?(lebedel.delphine)
(In reply to Delphine Lebédel [:delphine - use need info] from comment #5)
> Gregor: please in general prefer to need info the tester who filed the bug
> for these kinds of things.
> Elie: When there's a regression, please remember and tell your team to
> provide the screenshots for both versions. I've seen a few bugs missing this.
> 
> Keeping the ni on me for this to provide a screenshot later today. thanks

OK,thanks for reminding.
Flags: needinfo?(zikui.yang)
Target Milestone: --- → 2.2 S11 (1may)
Comment on attachment 8598343 [details] [review]
[gaia] sfoster:ftu-change-btn-bug-1157173 > mozilla-b2g:master

Mike can you look at this one? From the PR, the main change here is using content-box for box sizing, plus tweaks on the width/padding values. I've set max-width to 40% which is about as big as it can be without the layout breaking down. It shouldnt come to that but 'Change' does translate to a rather long string in some languages. I figure legibility trumps here and we would rather get a legible label in the extreme case.

If you plug a long string in there, the top timezone 'change' button starts to overlap Antartica. Without redesigning this screen (bug #1067636) we don't have a good fix for this - probably best addressed on case-by-case basis with localizers.
Attachment #8598343 - Flags: review?(mhenretty)
We've had several recent regression that were essentially padding/truncation issues within buttons. I'd like to figure out what caused this regardless of the fix we use here. Let's get a regression-window here to find the regressing patch.
QA Contact: bzumwalt
See Also: → 1155906
Mozilla-Inbound Regression Window:

Last working Mozilla-Inbound build:
Device: Flame 3.0
Build ID: 20150319193147
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 4d2d97b3ba34
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First broken Mozilla-Inbound build:
Device: Flame 3.0
Build ID: 20150319211513
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 9590d9ed9e76
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


Working Gaia with Broken Gecko issue DOES reproduce:
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 9590d9ed9e76

Working Gecko with Broken Gaia issue does NOT reproduce:
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: 4d2d97b3ba34


Mozilla-Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4d2d97b3ba34&tochange=9590d9ed9e76


Issue appears to occur due to changes made in bug 1010675
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Also happens in Serbian Cyrillic, as per dupe Bug 1159145
Comment on attachment 8598343 [details] [review]
[gaia] sfoster:ftu-change-btn-bug-1157173 > mozilla-b2g:master

In light of the platform fix that caused this regression, I think this is a good fix.
Attachment #8598343 - Flags: review?(mhenretty) → review+
Keywords: checkin-needed
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
https://github.com/mozilla-b2g/gaia/pull/29756

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#AV0oF0fETvuAZVPxpYmcRg

The pull request failed to pass integration tests. It could not be landed, please try again.
Tests are green with rebased PR, trying again to land...
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#mU6dnfUDSSiqoBNuS_wOjg

The pull request failed to pass integration tests. It could not be landed, please try again.
Closed/re-opened PR. Tests are green again, fingers-crossed that'll do it.
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#vkfNG4LeTy-qr7PNepa3WA

The pull request failed to pass integration tests. It could not be landed, please try again.
Merged to master: https://github.com/mozilla-b2g/gaia/commit/d62c0bec329216edba8218f0cb5b950f8ba3dd40
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Delphine, this bug is probably not the one you are thinking of. The fix here is very specific to these particular buttons, in the FTU app and it wont fix bug 1159644 or bug 1159646. We dont have a bug yet for the shared button styles, but I suspect bug 1155906 will either morph to cover that, or get duped to another.
See comment #21
Flags: needinfo?(lebedel.delphine)
thanks for clarifying Sam! Understood, will update them.
Flags: needinfo?(lebedel.delphine)
Issue verified fixed on Flame 3.0

When language is set to Russian, the string "Change" is not overlapping button.

Leaving verifyme for 2.2 uplift.

Device: Flame 3.0
Build ID: 20150504010202
Gaia: e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gecko: dc5f85980a82
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Hi Sam,
Could you raise approval to land on 2.2? Thanks!
Flags: needinfo?(sfoster)
Comment on attachment 8598343 [details] [review]
[gaia] sfoster:ftu-change-btn-bug-1157173 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Buttons on FTU Date/Time screen; fix fallout from bug 1010675
[User impact] if declined: In some locales, the labels on this screen may be truncated, illegible and/or unclear
[Testing completed]: Tested on device in multiple languages, verified on master
[Risk to taking this patch] (and alternatives if risky): V. low, patch only touches FTU stylesheet, and targets these buttons specifically.
[String changes made]: None
Flags: needinfo?(sfoster)
Attachment #8598343 - Flags: approval-gaia-v2.2?
Attachment #8598343 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Elie, could you help verify v2.2?
Flags: needinfo?(zikui.yang)
(In reply to Hermes Cheng[:hermescheng] from comment #28)
> Elie, could you help verify v2.2?

This issue verified pass on flame 2.2
Flame 2.2:
Build ID               20150512002502
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150512.041644
Firmware Date          Tue May 12 04:16:55 EDT 2015
Bootloader             L1TC000118D0
Refer to picture    Russian_change_verified pass.png
Flags: needinfo?(zikui.yang)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2,MGSEI-l10n-1F-Russian [systemsfe] → LocRun2.2, [systemsfe]
You need to log in before you can comment on or make changes to this bug.