Closed Bug 1159768 Opened 5 years ago Closed 2 years ago

Stop forcing the dom.webcomponents.enabled preference to true in the test harness

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1398981
Tracking Status
firefox40 --- affected

People

(Reporter: bzbarsky, Unassigned)

References

Details

This makes it impossible to properly test that we don't ship support when we don't mean to.

The tests that rely on this preference should set it as needed.
I'm just going to work around this in bug 1159742.  We won't have any testing for accidentally shipping ShadowRoot... but we don't right now anyway.  :(
No longer blocks: 1159742
William told me he thinks we need to rewrite some tests for this to work.
Assignee: wchen → nobody
Priority: -- → P3
See Also: → 1398981
I think this has been fixed by bug 1398981, feel free to reopen if it's not the case.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1398981
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.