Cannot delete a folder on the mail server into Trash

VERIFIED WONTFIX

Status

P4
normal
VERIFIED WONTFIX
17 years ago
10 years ago

People

(Reporter: yinbolian, Assigned: naving)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ns621_sun, bt4615927)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; 0.7) Gecko/20010316
BuildID:    2001031614

The problem takes place when when the account resides on a mail server.you
Cannot delete a folder on the mail server into the Trash.
But it works well on the local account.





Reproducible: Always
Steps to Reproduce:
steps to reproduce:
1. open the Mail
2. select an account resides on a mail server
3. create an new folder on it:  right click on the account, and select "New
Folder...", input the new folder's name, then press OK
4. as the new folder appears on the folder tree, right click on it and select
"Delete Folder.."
5. Press OK to confirm the question: "Are you sure you want to move the selected
folder into the Trash ?"
6. An Alert Window pops up and says: "the current command did not succeed. The
mail server responded: RENAME failed: Cannot rename mailbox, Not a directory."


Actual Results:  the action fails and folder is still on the list


Expected Results:  the folder should be in the Trash

Machine: SUNW,Sun-Blade-100;sparc;sun4u
OS: SunOS Release 5.9 s81_51
Mail Server: IMAP
(Reporter)

Updated

17 years ago
Priority: -- → P4
Whiteboard: ns621_sun, bt4615927

Comment 1

17 years ago
Reporter,
Please download a recent build and report back.   The build you are using is 
really old.  
Current build that I am using 2001-12-17-06 workforme. I can create and delete 
the folder.  
Assignee: racham → naving
Component: Account Manager → Mail Window Front End
QA Contact: nbaca → sheelar
(Assignee)

Comment 2

17 years ago
--> imap
Assignee: naving → mscott
Component: Mail Window Front End → Networking - IMAP
QA Contact: sheelar → huang
(Assignee)

Comment 3

17 years ago
reassigning
Assignee: mscott → naving

Comment 4

17 years ago
I can reproduce this bug(including using mozilla 0.9.7). The IMAP server I'm 
using is 'Solstice (tm) Internet Mail Server (tm) 2.0p9 IMAP4 service'.
This bug is produced for the following reason: this IMAP server doesn't really 
uses folders, it implements such commands as 'Create', 'Delete', etc, just 
using a file and puts all the messages in the file using some delimiter. 
Howerer, the default delete mode of mozilla is 'MoveToTrash' now. So when the 
user delete some folder, mozilla tries to move it to Trash using 'Rename' 
command, and the server says it is not a directory. Further more, it is 
impossible to move a folder to another on this server.

Comment 5

17 years ago
Hi, Bienvenu, according to Stephend's suggestion, I add you to this CC list. I 
want to solve this bug. Stephend think Navin and you may help me much.

Comment 6

17 years ago
Created attachment 63471 [details]
a suggested fix of this bug, discussion wanted

I think this patch is not the final, including no changes in the interface, but
it can delete folder now. Suggestion and discussion are wanted.

Comment 7

17 years ago
maybe you could explain what your patch is doing? It looks like it's simply
trying to detect the delete folder to trash case and NOT report errors in that
case, which is maybe great for your situation, but not so great for other users
that have other errors when deleting folders and would like to know about them.
Perhaps you could attach a protocol log so we could see if the server gives any
indication that there can be no sub-folders of the trash.
I wonder how we handle this case when using the mbox mailbox format on UW
servers, which has a similar problem - the trash folder can't have sub-folders
if it has messages in it.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

17 years ago
Just as you said, I think if a user want to delete a folder, mozilla should 
delete it(no matter what method mozilla uses). Otherwise, the folders will 
become more and more as the user create new folders. It's bothering. So in the 
code, I check if a user want to put a folder in the Trash, if so, I forbid to 
report the error when using "Rename" method and then use "Delete" method to 
delete it, if error still exists, mozilla reports it.

Following is the protocol log of the "Rename" command:
a01 rename "aaa" "Trash/aaa"
a01 NO RENAME failed: Cannot rename mailbox, Not a directory

In addition, the IMAP server I'm using is similar to UW servers, the Trash 
folder can has only messages in it(in fact, the Trash is just a file). And all 
the real folders can only have sub folders or fake folders(like Trash) in it, 
it can't contain messages. When I set the "dual_use_folders" flag to FALSE(by 
changing code or by clearing the setting of "Edit"->"Main & Newsgroup Accout 
Settings..."->"Server Settings"->"Advanced..."->"Server supports folders that 
contain sub-folders and messages"), mozilla can delete folders correctly
(using "Delete" method). So I think we can change the default setting 
of "Server supports folders that contain sub-folders and messages" from TRUE to 
FALSE to solve this problem, and probably solve the problem of UW servers.

Comment 9

17 years ago
Hi, Bienvenu and Navin, can we get the "dual_use_folders" flag from IMAP server 
online?

Comment 10

17 years ago
but the delete could have failed to put the sub-folder in the trash for many
reasons, only one of which happens to be your case of the trash not allowing
sub-folders.

No, we can't find out the dual_use folders setting from the server. That's why
we made it a preference. And it sounds like the preference works fine.

Comment 11

17 years ago
Because this advanced setting is confused for most users that are not familiar
with IMAP and we should let the basic functions of mozilla work(such as deleting
a folder in the mail server. Putting a folder in the Trash instead of deleting
it so that this operation can be undone is an enhanced function), further more,
in the help, it is said that "In most cases, advanced IMAP server settings are
automatically supplied by the server." and the content of this setting is
"support for subfolders"(in the 'Setting IMAP Server Information' part. These
sayings are also confused.), in my opinion, it's a better way to clear this
default setting and change the help part of this setting as following: 'Server
supports folders that contain both sub-folders and messages or just contain
either sub-folders or messages'. If so, this 'delete' operation can work
widely(including UW servers, I think. Bienvenu, can you test it or can you tell
me where I can download a UW server?), and if some users' IMAP server supports
the enhanced function to support folders that can contain both sub-folders and
messages and they want to use this function, they can select this setting.

Comment 12

17 years ago
we're not going to change the default.  marking wontfix because it sounds like
the original problem mentioned in this bug is solved by changing the pref.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
*** Bug 117395 has been marked as a duplicate of this bug. ***
*** Bug 101923 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
Verified WONTFIX based on above discussion & comments.
Status: RESOLVED → VERIFIED

Comment 16

16 years ago
*** Bug 135406 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
*** Bug 183598 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
Maybe I'm wasting my time adding a comment to a verified wontfix bug, but...

I think marking WONTFIX is crazy.

I have deletion pref set to "move to trash" because I want deleted messages
moved to the trash.  That means if I need to delete a folder, I have to go into
preferences, change deletion pref to "remove immediately", delete the folder,
then restore the pref.  That's a dodgy workaround, not a solution.

Reopen, anyone?

Comment 19

16 years ago
if you want, you can just shift delete the folder, so it doesn't go into the
trash. Is that acceptable?

Comment 20

16 years ago
*** Bug 131049 has been marked as a duplicate of this bug. ***

Comment 21

14 years ago
*** Bug 258409 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.