Closed Bug 1161071 Opened 5 years ago Closed 5 years ago

Improve location bar and toolbar scrolling

Categories

(Firefox for iOS :: Browser, defect)

Other
iOS
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fennec + ---

People

(Reporter: st3fan, Assigned: sleroux)

References

Details

Attachments

(1 file)

PR
47 bytes, text/x-github-pull-request
bnicholson
: review+
Details | Review
We currently scroll the location- and toolbar away when you scroll the web view content. I think we want this to be on-parity with Safari. So that it behaves and feels the same way. It currently does not in subtle ways.

Couple of notes:

* When we switch tabs, we should show the toolbars again
* When reading view is enabled, there is an additional view under the location bar with reading view settings. This view should also animate away as documented in https://bugzilla.mozilla.org/show_bug.cgi?id=1148408#c3
* On iPad there is no bottom toolbar

It would also be really nice to have an API to show/hide the toolbars so that we can trigger it programmaticaly. For example when we open a page in Reading Mode, we should trigger the toolbars to go away.
Darrin, can you maybe add some more hints from a UX perspective?
Flags: needinfo?(dhenein)
Assignee: nobody → sleroux
> * When we switch tabs, we should show the toolbars again
We already do this... does it not work? https://github.com/mozilla/firefox-ios/blob/master/Client/Frontend/Browser/BrowserViewController.swift#L831

> * On iPad there is no bottom toolbar
Portrait as well. We already do this...

We also already have an API for showing and hiding these in BrowserViewController (i.e. hideToolbars/showToolbars).
Blocks: 1141598
Duplicate of this bug: 1148408
I think aiming for safari/Facebook iOS parity is a good start. I can answer specific questions as they come up. I noticed the animation for 'snapping' is still pretty slow too.
Flags: needinfo?(dhenein)
Attached file PR
Left comments on Github. Eventually I'd probably want to clean up the state that's being tracked in this VC since it feels a bit unwieldy. 

Also, Darrin mentioned some additional behavior where when the user is making small scroll adjustments upwards, the toolbars don't fade in right away. I haven't included that yet in this patch
Attachment #8602817 - Flags: review?(wjohnston)
Attachment #8602817 - Flags: review?(bnicholson)
Comment on attachment 8602817 [details] [review]
PR

Looking good to me. Left some questions/comments in the PR.
Attachment #8602817 - Flags: review?(bnicholson) → feedback+
Comment on attachment 8602817 [details] [review]
PR

LGTM, with some minor cleanup suggestions in the PR.
Attachment #8602817 - Flags: feedback+ → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Attachment #8602817 - Flags: review?(wjohnston)
I see the back/forward/etc buttons not entirely faded out in the iPad simulator. Follow up?
You need to log in before you can comment on or make changes to this bug.