Closed Bug 1162005 Opened 5 years ago Closed 5 years ago

Pocket panel doesn't autofit size (width/height) to localized content (scrollbars, content partially hidden)

Categories

(Firefox :: Pocket, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1163360
Tracking Status
firefox40 --- affected

People

(Reporter: aryx, Unassigned)

References

Details

Attachments

(2 files)

Attached image screenshot of issue
Firefox Nightly, self-compiled and the strings in dictionary.js replaced with the German ones (bug 1161841). Windows 8.1

The Pocket panel doesn't autofit if localized content gets used which can be longer than English one, e.g. scrollbars are shown and content partially hidden (in the screenshot: Logging in with already existing account).

Or in other words:

jaws * shorlander: a **tiny** win is that the text may translate to shorter strings in some locales
shorlander * but translate to twice as long in German ;)
shorlander * (i just made that up, I have no idea)
Related to this, but not due to locale: on the en-us build there is a lot of whitespace on the 'saved to pocket' panel if you don't have a premium account that provides suggested tags (see screenshot). in general the panel should resize to fit the content i think.
I believe this will be fixed by bug 1161793 when the auto-resize lands.
Blocks: Pocket
Depends on: 1161793
(In reply to Bryan Clark (Firefox PM) [:clarkbw] from comment #2)
> I believe this will be fixed by bug 1161793 when the auto-resize lands.

Probably not :(

The Pocket code is providing a hard-coded width and height for the panel sizes. We are not using computed sizes to scale the panel.
Priority: -- → P1
Just came across this bug. I'm flagging it internally, we'll aim to get a fix for this in the Tuesday drop.
Bug 1163360 tweaked layout for the various locales, and the screenshots using the code we pulled for integration looked good.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1163360
You need to log in before you can comment on or make changes to this bug.