Closed Bug 116263 Opened 19 years ago Closed 19 years ago

"File Type" selection in Save Page dialog isn't remembered

Categories

(Core Graveyard :: File Handling, defect, P2)

defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.8

People

(Reporter: Biesinger, Assigned: bugs)

References

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.6+) Gecko/20011218
BuildID:    2001121803

When choosing File/Save Page As, I am offered to save the complete web page or
only HTML.

As I need "only HTML" more often than "complete page", it would be nice if the
selection would be remembered

Reproducible: Always
Steps to Reproduce:
1. Visit any page
2. Choose File/Save Page As
3. Choose "HTML only" and click OK
4. Choose File/Save Page As again

Actual Results:  "Web Page, complete" is selected

Expected Results:  "HTML Only" is selected, like the last time I saved a page
Assigning to ben
Assignee: law → ben
OS: Windows 98 → All
Hardware: PC → All
Blocks: 115634
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla0.9.8
see patch in 115148
okay, adding dep so that i remember to check this once bug 115148 is fixed.
Depends on: 115148
Fix checked in
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Sorry for the spam in another bug. This is the bug I'm having trouble with.

I'm using Mozilla 0.9.7, Build ID: 2002011803, Windows 98, with a fresh profile
and this bug is still affecting me, even though the bug is Resolved Fixed.

I can reproduce the problem. Open Mozilla. Go to File | Save Page As, see that
the default file type is set to "Web Page, complete," and change it to "HTML
only." Save the file. Go to File | Save Page As again, and the default file type
is still set to "Web Page, complete."
Not fixed on build 2002011604 either. Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
missed a file. a=asa (on behalf of drivers) for checkin.
Keywords: mozilla0.9.8+
Fixed. 
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
works great on linux rh7.2 and win2k [2001.01.24.0x comm].

unable to vrfy on mac due to bug 107521.
Depends on: 107521
No longer depends on: 107521
Depends on: 107521
vrfy
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.