Forward button doesn't work after backtracking from named anchor

VERIFIED DUPLICATE of bug 15441

Status

()

Core
Embedding: APIs
P3
normal
VERIFIED DUPLICATE of bug 15441
18 years ago
16 years ago

People

(Reporter: Nicholas Cull, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
This bug follows on from bug 9952, and occurs on the 1999081008 build of Mozilla,
on Windows NT 4 Workstation.

To reproduce:

* Start Mozilla
* Enter the URL for the test case (will attach one shortly)
* Click on the link, which jumps you down to the middle of the page
* Use the back button to go back to the top of the page
* Observe that the forward button is disabled.

Expected behaviour:

* Mozilla should enable the forward button to allow you to re-visit the named
  anchor you just came back from.
(Reporter)

Comment 1

18 years ago
Created attachment 1203 [details]
Test case showing problem with forward button.
(Reporter)

Updated

18 years ago
Whiteboard: [TESTCASE]
(Reporter)

Comment 2

18 years ago
Attached a testcase, which is modified from the second testcase of bug 11453.
(Reporter)

Comment 3

18 years ago
Duh! Fixed the first test case, which was pointing to a local image on my
hard drive.

See also bug 11631, which was found while creating the second test case.
(Reporter)

Comment 4

18 years ago
Ok, I'm too sleepy now. Ignore my previous comment about test cases, which
was meant for bug 11453. However, bug 11631 may well be related to this one.
Status: NEW → ASSIGNED
Target Milestone: M12
I'm aware of the problem and the potential solutions. It just needs lot of
testing before I can check in a fix.
Target Milestone: M12 → M11
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 15441 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
VERIFIED dupe.
You need to log in before you can comment on or make changes to this bug.