Crash [@ _ZThn8_N7mozilla3dom7workers24serviceWorkerScriptCache12_GLOBAL__N_114CompareNetwork14OnStartRequestEP10nsIRequestP11nsISupports ]

RESOLVED FIXED in Firefox 40

Status

()

Core
DOM: Service Workers
--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Robin Whittleton, Assigned: Ehsan)

Tracking

({regression, topcrash})

41 Branch
mozilla41
regression, topcrash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40+ fixed, firefox41+ fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150511122605

Steps to reproduce:

Not reproducible unfortunately. I left my computer alone for a standup with my usual set of tabs (couple of GMails, Google Calendar, some Github repos etc) and when I came back it had crashed.


Actual results:

Bang: https://crash-stats.mozilla.com/report/index/4d28e709-418c-45ab-8076-8ec7a2150512


Expected results:

No bang.

I wouldn’t normally have bothered filing, but the crash signature looked pretty strange and the 8 other reports ( https://crash-stats.mozilla.com/report/list?product=Firefox&range_unit=days&range_value=3&signature=_ZThn8_N7mozilla3dom7workers24serviceWorkerScriptCache12_GLOBAL__N_114CompareNetwork14OnStartRequestEP10nsIRequestP11nsISupports ) have all happened in the last 3 days so presumably it’s something recent. The signature makes it look like a service worker issue, but feel free to move if it’s not.
(Reporter)

Updated

3 years ago
Crash Signature: [@ _ZThn8_N7mozilla3dom7workers24serviceWorkerScriptCache12_GLOBAL__N_114CompareNetwork14OnStartRequestEP10nsIRequestP11nsISupports ]
Component: Untriaged → Untriaged
Product: Firefox → Core
(Reporter)

Updated

3 years ago
Component: Untriaged → DOM: Service Workers
(Reporter)

Updated

3 years ago
Severity: normal → critical
(Reporter)

Comment 1

3 years ago
Possible dupe of #1163404 and #1163593 ?
(Reporter)

Comment 2

3 years ago
Bug #1163403 and bug #1163593 even.
(Assignee)

Updated

3 years ago
Assignee: nobody → ehsan
(Assignee)

Updated

3 years ago
Blocks: 1164065
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1163403
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1163593
(Assignee)

Comment 5

3 years ago
I tried to find a way to reproduce this so that I can write a test case for it, so far without success.  But this is clearly happening because we're aborting the CompareNetwork object, and not handling that properly in OnStartRequest.
(Assignee)

Comment 6

3 years ago
Created attachment 8605474 [details] [diff] [review]
Handle aborted CompareNetwork jobs properly in CompareNetwork::OnStartRequst
(Assignee)

Updated

3 years ago
Blocks: 1059784
Marking this as NEW based on comment 5.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 8605474 [details] [diff] [review]
Handle aborted CompareNetwork jobs properly in CompareNetwork::OnStartRequst

Review of attachment 8605474 [details] [diff] [review]:
-----------------------------------------------------------------

preemptive r+ :)

Updated

3 years ago
Duplicate of this bug: 1164065

Comment 10

3 years ago
[Tracking Requested - why for this release]:
This is one of the top 10 crashes we have with people still on builds of 40, so I expect it to be there in Dev Edition as well (unless it's specific to e10s).
Crash Signature: [@ _ZThn8_N7mozilla3dom7workers24serviceWorkerScriptCache12_GLOBAL__N_114CompareNetwork14OnStartRequestEP10nsIRequestP11nsISupports ] → [@ _ZThn8_N7mozilla3dom7workers24serviceWorkerScriptCache12_GLOBAL__N_114CompareNetwork14OnStartRequestEP10nsIRequestP11nsISupports ] [@ mozilla::dom::workers::serviceWorkerScriptCache::`anonymous namespace''::CompareNetwork::OnStartRequest(nsIReq…
status-firefox40: --- → affected
tracking-firefox40: --- → ?

Comment 11

3 years ago
It's not specific to e10s, I had the same crash with 41 Nightly and e10s disabled yesterday.
(Assignee)

Comment 12

3 years ago
Yeah, this is unrelated to e10s.
(Assignee)

Updated

3 years ago
Blocks: 1159378
No longer blocks: 1164065
Keywords: regression, topcrash
(Assignee)

Comment 13

3 years ago
Comment on attachment 8605474 [details] [diff] [review]
Handle aborted CompareNetwork jobs properly in CompareNetwork::OnStartRequst

(marking as r+ as per comment 8!)
Attachment #8605474 - Flags: review+
(Assignee)

Comment 14

3 years ago
Comment on attachment 8605474 [details] [diff] [review]
Handle aborted CompareNetwork jobs properly in CompareNetwork::OnStartRequst

Approval Request Comment
[Feature/regressing bug #]: Bug 1159378
[User impact if declined]: This is a topcrasher on Nightly.
[Describe test coverage new/current, TreeHerder]: None, I couldn't come up with an easy way to test this.
[Risks and why]: Very low risk, just adding a null check.
[String/UUID change made/needed]: none
Attachment #8605474 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

3 years ago
status-firefox41: --- → affected
tracking-firefox41: --- → ?
Since this is a crash, and a regression, enabled tracking for 40 and 41.
tracking-firefox40: ? → +
tracking-firefox41: ? → +
Comment on attachment 8605474 [details] [diff] [review]
Handle aborted CompareNetwork jobs properly in CompareNetwork::OnStartRequst

Safe fix. Let's put this directly on Aurora to address the crash before we re-enable updates.
Attachment #8605474 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/3913a94d7f25
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #16)
> Comment on attachment 8605474 [details] [diff] [review]
> Handle aborted CompareNetwork jobs properly in CompareNetwork::OnStartRequst
> 
> Safe fix. Let's put this directly on Aurora to address the crash before we
> re-enable updates.

Awesome, just ran into this on Aurora 41. :)
(Assignee)

Comment 20

3 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/72b2c07a0e84
status-firefox40: affected → fixed
Jeff, did you run into this crash in Aurora FF41? Can you please re-open the bug if that is the case?
Flags: needinfo?(jgriffiths)
(In reply to Ritu Kothari (:ritu) from comment #21)
> Jeff, did you run into this crash in Aurora FF41? Can you please re-open the
> bug if that is the case?

Not so far, but I will re-open if I see it.
Flags: needinfo?(jgriffiths)
You need to log in before you can comment on or make changes to this bug.