[OTA] Unable to find System Update

VERIFIED FIXED

Status

Taskcluster
General
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: YeojinC, Assigned: aus)

Tracking

({regression, smoketest})

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8604681 [details]
logcat_20150512_0739.txt

+++ This bug was initially created as a clone of Bug #1161579 +++

Description:
When a user attempts to perform an OTA from the build 20150511010202, they will observe that no update will be found after numerous attempts to 'Search for Updates' in settings.

Repro Steps:
1) Update a Flame to 20150511010202.
2) Open Settings.
3) Enable Wi-Fi.
4) Navigate to Device Information.
5) Search for Updates.

Actual:
Unable to find OTA

Expected:
OTA is found and available for user to update


Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150511010202
Gaia: 6089234ace8b294a8feef064387604bae16254e3
Gecko: d8420a541d1c
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 5/5
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)

Updated

3 years ago
Blocks: 1164041
[Blocking Requested - why for this release]:

Sanity blocker. Regression. Requesting a window
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: qaurgent, regressionwindow-wanted
OTA updates work just fine on today's build when pointing to the Nightlytest channel in both Full Flash and Shallow Flash.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150511010202
Gaia: 6089234ace8b294a8feef064387604bae16254e3
Gecko: d8420a541d1c
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Flags: needinfo?(ktucker)
Keywords: qaurgent, regressionwindow-wanted
NI Naoki to take a look here.
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(ktucker)

Comment 4

3 years ago
05-12 07:39:58.830   209   209 I Gecko   : UpdatePrompt: Forcing update check
05-12 07:39:58.840   209   209 I Gecko   : *** AUS:SVC Checker: checkForUpdates, force: true
05-12 07:39:58.840   209   209 I GeckoConsole: AUS:SVC Checker: checkForUpdates, force: true
05-12 07:39:58.910   209   209 I Gecko   : *** AUS:SVC Checker:getUpdateURL - update URL: https://aus4.mozilla.org/update/3/B2G/40.0a1/20150511010202/flame-userdebug/en-US/nightly/Boot2Gecko%203.0.0.0-prerelease%20(SDK%2019)/default/default/update.xml?force=1

05-12 07:39:58.910   209   209 I GeckoConsole: AUS:SVC Checker:getUpdateURL - update URL: https://aus4.mozilla.org/update/3/B2G/40.0a1/20150511010202/flame-userdebug/en-US/nightly/Boot2Gecko%203.0.0.0-prerelease%20(SDK%2019)/default/default/update.xml?force=1

05-12 07:39:58.910   209   209 I Gecko   : *** AUS:SVC Checker:checkForUpdates - sending request to: https://aus4.mozilla.org/update/3/B2G/40.0a1/20150511010202/flame-userdebug/en-US/nightly/Boot2Gecko%203.0.0.0-prerelease%20(SDK%2019)/default/default/update.xml?force=1

05-12 07:39:58.910   209   209 I GeckoConsole: AUS:SVC Checker:checkForUpdates - sending request to: https://aus4.mozilla.org/update/3/B2G/40.0a1/20150511010202/flame-userdebug/en-US/nightly/Boot2Gecko%203.0.0.0-prerelease%20(SDK%2019)/default/default/update.xml?force=1

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
No data on XML file.
I found that the device name is "flame-userdebug". It's not flame.
Hi Naoki,
I heard some changes of the device from you, can you help on this?

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=OTA]
Code searching : reland in https://bugzilla.mozilla.org/show_bug.cgi?id=1154947 caused issue.  forward fix is to include userdebug in the exception, I think?

Specifically : https://hg.mozilla.org/mozilla-central/rev/cd229a55ed1c

Going to make a patch and ask aus for a review.
Created attachment 8605636 [details] [diff] [review]
Bug_1164037.patch

Hey aus, can you review?  I added userdebug to the if in an or statement.  pvtbuilds makes userdebug builds, not user builds, so it still broke flame.

The other option is just to replace the user with userdebug... If you want me to do that I can make the change.

Please NI me after the review.
Attachment #8605636 - Flags: review?(aus)
Flags: needinfo?(nhirata.bugzilla) → needinfo?(aus)
(Assignee)

Comment 8

3 years ago
Comment on attachment 8605636 [details] [diff] [review]
Bug_1164037.patch

lgtm as is. I will take the liberty of pushing this to b2g-inbound so we have it tomorrow. :)
Flags: needinfo?(aus)
Attachment #8605636 - Flags: review?(aus) → review+
Thanks, Aus!

An afterthought:

I just realized, the other thing I could have potentially done was create a new rule for flame-userdebug as a nightly build using balrog, I think... though it may require trial and error.

That way we don't need the if statement at all.

If this doesn't make it in time, I'll make a new rule for the flame-userdebug to see if that method might work as a nightlytest2...   I don't think I want to make too many new rules though [nor is it my intent do all these small tweak mods constantly].

Comment 11

3 years ago
The bug also exists in the latest Flame 2.1 & 2.2 User version today. When we connect to wifi, and search OTA,  no updates can found after numerous attempts to 'Search for Updates' in settings.

Device: Flame 2.2 user(Fail):
Build ID               20150512002502
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150428.042314
Firmware Date          Tue Apr 28 04:23:26 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.1 user(Fail):
Build ID               20150512001201
Gaia Revision          c80865cb0bf73f1b97defbc646083b404feb3ac4
Gaia Date              2015-05-12 06:26:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/2fd3ef3fc14a
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150321.195232
Firmware Date          Sat Mar 21 19:52:42 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][COM=OTA] → [QAnalyst-Triage+][COM=OTA][MGSEI-Triage+]
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
blocking-b2g: 3.0? → 3.0+
You need to be on today's build OTAing to tomorrow build in order to verify the fix.

In order for us to fix that OTA for the broken build you have, this is from bhearsum :
"in general, any unique build configuration that wants updates should have a unique build target
otherwise it's a mess trying to submit to balrog and set up rules
and each unique build configuration should give a different platform to balrog-submitter.py, which maps that to the build target via platforms.py

if you get all of that stuff correct, you end up with nice blobs with different platforms for each unique build configuration, and you can point a single rule per channel at them (instead of the multiple rule hacks we had to do for flame kk"

ie : "probably requires a change to https://github.com/mozilla/build-tools/blob/master/lib/python/release/platforms.py#L22, and probably a change to whatever is calling into it" and a rule added to balrog
sunny, the patch that I made only affects M-C and the reasoning I believe for 2.2 / 2.1 may be different.  We'll need to investigate those seperately...
https://hg.mozilla.org/mozilla-central/rev/7dd66a9ecce5
Assignee: nobody → aus
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S12 (15may)

Comment 15

3 years ago
Hi, Sunny,

Please file another bug to follow up and attach debug logs.
Thanks.
Flags: needinfo?(wangxiaomei)

Comment 16

3 years ago
Hi,William,
I have submit a new bug.Please see bug 1165195.

Updated

3 years ago
Flags: needinfo?(wangxiaomei)

Updated

3 years ago
See Also: → bug 1165195
Created attachment 8607098 [details] [diff] [review]
Bug1160671_take2.patch

Hey Aus can you review please?
I added a check for the sdk kitkat.
Attachment #8607098 - Flags: review?(aus)
Comment on attachment 8607098 [details] [diff] [review]
Bug1160671_take2.patch

Please do not push this patch.  wcosta is going to make a server side fix to fix the issue there.
Attachment #8607098 - Flags: review?(aus) → review-
Closing issue.  Server side issue.  We're going to fix it thee.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
issue isn't client side, it's server side : see bug 1164939
Note, if you want to see that it is working, change the URL for OTA by substituting %PRODUCT_DEVICE% w/ flame-kk

you should be able to see and download the update.


https://github.com/walac/gecko-dev/commit/ee26c4975f1f6db4c18d31d2bd6e9860a09f7b44 is in the works to try to fix the issue.  I am concerned that the name of the file might throw it off in not finding the mar file.
Works for me since yesterday.
status-b2g-v2.1: affected → fixed
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: 2.2 S12 (15may) → 2.2 S13 (29may)
This issue is fixed in yesterday's 3.0 build but does not seem fixed for yesterday's 2.2 or 2.1 builds (have to be on those to update).

Environmental Variables:
Device: Flame 3.0
BuildID: 20150526010203
Gaia: 7cd4130d4f988562a77d126860408ada65bb95ef
Gecko: 43f2f0c506ea
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150526002558
Gaia: 6a8d171d00efe8b27cba91bf1d789ab824579664
Gecko: 46f6c7327ab0
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1
BuildID: 20150526001202
Gaia: 0d343f49c0e0a3928a4f456faf98e37bb26a6ef6
Gecko: 6e357036c54b
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=OTA][MGSEI-Triage+] → [QAnalyst-Triage?][COM=OTA][MGSEI-Triage+][failed-verification]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker) → needinfo?(nhirata.bugzilla)
Ktucker, please use bug 1165195 for tracking 2.1/2.2 OTA issue.
Flags: needinfo?(nhirata.bugzilla)
Removing the failed verification tag since this is being tracked in bug 1165195.
QA Whiteboard: [QAnalyst-Triage?][COM=OTA][MGSEI-Triage+][failed-verification] → [QAnalyst-Triage+][COM=OTA][MGSEI-Triage+]
status-b2g-v2.5: --- → verified
status-b2g-v2.5: verified → ---
Moving the bug to the component where the regression came from.
blocking-b2g: 2.5+ → ---
status-b2g-v2.1: fixed → ---
status-b2g-v2.2: fixed → ---
status-b2g-master: verified → ---
status-firefox41: fixed → ---
Component: Gaia::System → General
Product: Firefox OS → Taskcluster
Target Milestone: 2.2 S13 (29may) → ---
You need to log in before you can comment on or make changes to this bug.