Closed Bug 1164103 Opened 5 years ago Closed 5 years ago

Browsing video crashes in [@ libc-2.12.so@0x12d6d7 ] (Firefox37.x)

Categories

(Core :: Audio/Video, defect, critical)

37 Branch
Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1172600

People

(Reporter: jiayublog, Unassigned)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

Attached file sinof.html
User Agent: Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

Firefox36.x version of the browser can browse video page, but after the upgrade to version Firefox37.x browse video page will cause the browser to crash. Repeatedly so.

System: CentOS6.6 GNOME2.28.2
FireFox: 37.0.2
Update method:
wget http://download.firefox.com.cn/releases/firefox/37.0/zh-CN/Firefox-latest.tar.bz2
tar -jxvf Firefox-latest.tar.bz2
\cp -r firefox /usr/lib/
\cp -r firefox/firefox /usr/bin/



Actual results:

Browser crashes, browse video page lead to new updated browser crashes.


Expected results:

http://mozilla.com.cn/thread-327643-1-1.html
https://crash-stats.mozilla.com/report/index/bp-4a354992-b0a2-4e94-840c-40f512150404
https://crash-stats.mozilla.com/report/index/bp-d27ebf7d-cd04-41ea-abfc-79b232150404
https://forums.adobe.com/message/7404697#7404697
https://crash-stats.mozilla.com/report/index/bd95f56f-3efa-4662-9422-a8ae92150424
Shockwave Flash:11.2.202.457
VLC Multimedia Plugin (compatible Totem 2.28.6)
Windows Media Player Plug-in 10 (compatible; Totem)
DivX Web Player version 1.4.0.233
QuickTime Plug-in 7.2.0
Severity: normal → critical
Crash Signature: [@ libc-2.12.so@0x12d6d7 ]
Component: Untriaged → Video/Audio
Keywords: crash
OS: Unspecified → Linux
Product: Firefox → Core
Summary: firefox37.x Browse crash video page → Browsing video crashes in [@ libc-2.12.so@0x12d6d7 ] (Firefox37.x)
Version: unspecified → 37 Branch
reporter, do you have a link (video webpage) to reproduce the crash of Firefox on Linux?
Flags: needinfo?(jiayublog)
http://v.qq.com/
http://t.qq.com/hainianxiandao
http://sports.qq.com/a/20150519/060994.htm?tu_biz=1.114.2.3
Open the connection browser crashes,thanks
Flags: needinfo?(jiayublog)
Duplicate of this bug: 1167837
This fault is still not resolved,
Edwin is looking at this in bug 1172600, so duping forward by exception (sorry - seems the stack signature is slightly different thanks to the libc offset, so socorro didn't find this when I looked if there were other bugs filed for it).
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1172600
(In reply to :Gijs Kruitbosch from comment #7)
> Edwin is looking at this in bug 1172600, so duping forward by exception
> (sorry - seems the stack signature is slightly different thanks to the libc
> offset, so socorro didn't find this when I looked if there were other bugs
> filed for it).
> 
> *** This bug has been marked as a duplicate of bug 1172600 ***

Thank you for your attention. I seem to solve the problem yourself. http://mozilla.com.cn/thread-330954-1-1.html
Steps like this:
1:In the about: config settings media.gstreamer.enabled;false
2:Edit\Preferences\Application Select, specify the appropriate action
3:about:config Modify these items
accessibility.typeaheadfind.flashBar;0
extensions.mediaplayerconnectivity.activityMP3;true
extensions.mediaplayerconnectivity.activityPls;true
extensions.mediaplayerconnectivity.activityQt;true
extensions.mediaplayerconnectivity.activityRm;true
extensions.mediaplayerconnectivity.activityWaveMidiAuAif;true
extensions.mediaplayerconnectivity.activityWm;true
extensions.mediaplayerconnectivity.autoplay;false
extensions.mediaplayerconnectivity.playermp3;/usr/local/bin/gmplayer
extensions.mediaplayerconnectivity.playerparamsmp3;%f
extensions.mediaplayerconnectivity.playerparamspls;%f
extensions.mediaplayerconnectivity.playerparamsqt;%f
extensions.mediaplayerconnectivity.playerparamsrm;%f
extensions.mediaplayerconnectivity.playerparamswavemidiauaif;%f
extensions.mediaplayerconnectivity.playerparamswm;%f
extensions.mediaplayerconnectivity.playerpls;/usr/local/bin/gmplayer
extensions.mediaplayerconnectivity.playerqt;/usr/local/bin/gmplayer
extensions.mediaplayerconnectivity.playerrm;/usr/local/bin/gmplayer
extensions.mediaplayerconnectivity.playerwavemidiauaif;/usr/local/bin/gmplayer
extensions.mediaplayerconnectivity.playerwm;/usr/local/bin/gmplayer
extensions.mediaplayerconnectivity.smartPlay;true
extensions.shownSelectionUI;true
extensions.{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}.install-event-fired;true
extensions.{84b24861-62f6-364b-eba5-2e5e2061d7e6}.description;使用外部媒体播放程序直接播放视频流
flashgot.extensions;3gp,fly,mp4,mpg,wma,wmv

media.fragmented-mp4.exposed;true
media.fragmented-mp4.ffmpeg.enabled;true
media.fragmented-mp4.gmp.enabled;true
media.fragmented-mp4.use-blank-decoder;false
media.getusermedia.screensharing.enabled;true

media.gmp-gmpopenh264.enabled;false
media.gmp-gmpopenh264.lastUpdate;1432325471
media.gstreamer.enabled;false
media.mediasource.enabled;false
media.mediasource.mp4.enabled;true
media.mediasource.webm.enabled;false
media.mediasource.whitelist;true
media.navigator.enabled;true
media.ogg.enabled;true
media.opus.enabled;true
media.peerconnection.video.enabled;true
media.peerconnection.video.h264_enabled;false
media.play-stand-alone;true
media.raw.enabled;true
media.video_stats.enabled;true
media.wave.enabled;true
media.webm.enabled;true
pagesaver.playsoundoncapture;true
plugin.disable_full_page_plugin_for_types;application/pdf,audio/x-wav,audio/wav,audio/midi,video/mp4,video/quicktime
plugin.soname.list;libXt.so:libXext.so
plugin.state.flash;2
plugin.state.libplugins;2
plugin.state.libtotem-cone-plugin;2
plugin.state.libtotem-gmp-plugin;2
plugin.state.libtotem-mully-plugin;2
plugin.state.libtotem-narrowspace-plugin;0
plugin.state.npesteid-firefox-plugin;2

Now browse those pages will no longer crash.
(In reply to jiayublog from comment #8)
> (In reply to :Gijs Kruitbosch from comment #7)
> > Edwin is looking at this in bug 1172600, so duping forward by exception
> > (sorry - seems the stack signature is slightly different thanks to the libc
> > offset, so socorro didn't find this when I looked if there were other bugs
> > filed for it).
> > 
> > *** This bug has been marked as a duplicate of bug 1172600 ***
> 
> Thank you for your attention. I seem to solve the problem yourself.
> http://mozilla.com.cn/thread-330954-1-1.html
> Steps like this:
> 1:In the about: config settings media.gstreamer.enabled;false


Yes, this workaround was provided 2 years ago. :)
https://bugzilla.mozilla.org/show_bug.cgi?id=935458#c5
You need to log in before you can comment on or make changes to this bug.