jolla.com crashes firefox

RESOLVED WONTFIX

Status

()

Core
Audio/Video: Playback
--
critical
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: Todd, Unassigned)

Tracking

({crash, crashreportid})

38 Branch
x86_64
Linux
crash, crashreportid
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

Scientific Linux 6.6 x 64
firefox-38.0.5.tar.bz2 x64

https://jolla.com upon enter the web site causes Firefox to crash


Add-ons: %7B1BC9BA34-1EED-42ca-A505-6D2F1A935BBB%7D:4.1.3.1,bibletoolbar%40bibletoolbar.net:4.0.0,%7Be968fc70-8f95-4ab9-9e79-304de2a71ee1%7D:0.7.3.1-signed,%7B7bf7c1c3-d8e7-4020-ab38-a829c76693d5%7D:4.1-signed,%7B1A2D0EC4-75F5-4c91-89C4-3656F6E44B68%7D:0.6.3.1-signed,bookmarkcurrenttabset%40jake.kasprzak.ca:0.2.4.1-signed,%7B4093c4de-454a-4329-8aff-c6b0b123c386%7D:0.8.14.1-signed,tiletabs%40DW-dev:12.9.1-signed,undoclosedtabsbutton%40supernova00.biz:3.9.4.1-signed,%7Ba7c6cf7f-112c-4500-a7ea-39801a327e5f%7D:2.0.24.1-signed,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:38.0.5,%7B086e582e-455b-4289-bfab-e90da7c0558b%7D:1.3.1-signed,tabsonbottom%40piro.sakura.ne.jp:0.5.1-signed,%7Bb9bfaf1c-a63f-47cd-8b9a-29526ced9060%7D:1.8.3.1-signed,cliget%40zaidabdulla.com:1.2.3.1-signed,%7Bfe272bd1-5f76-4ea4-8501-a05d35d823fc%7D:2.1.9.1-signed,firefox%40ghostery.com:5.4.5.1-signed
BuildID: 20150525141253
CrashTime: 1433787595
EMCheckCompatibility: true
Email: toddandmargo@zoho.com
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1433225758
Notes: OpenGL: NVIDIA Corporation -- GeForce GTX 460/PCIe/SSE2 -- 4.4.0 NVIDIA 340.46 -- texture_from_pixmap

ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SecondsSinceLastCrash: 44716
StartupTime: 1433787552
Theme: classic/1.0
Throttleable: 1
URL: https://jolla.com/
Vendor: Mozilla
Version: 38.0.5
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.

Comment 1

3 years ago
Follow https://bugzilla.mozilla.org/show_bug.cgi?id=1172608#c1 please.
Flags: needinfo?(ToddAndMargo)
(Reporter)

Comment 2

3 years ago
It does not crash in safe mode.

But here is the rub.  It crashes with every single extension disabled (and FF restarted).  Huh?

What next?
Flags: needinfo?(ToddAndMargo)

Comment 3

3 years ago
Does it still crash when you disable hardware acceleration under Preferences → Advanced → General then restart Firefox?

Please use a build from mozilla.org then attach the information detailed in the following article.
https://www.mozilla.org/firefox/all/
https://developer.mozilla.org/docs/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → critical
Keywords: crash
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 4

3 years ago
(In reply to Gingerbread Man from comment #3)
> Does it still crash when you disable hardware acceleration under Preferences
> → Advanced → General then restart Firefox?

Hardware Acceration was already turned off

> 
> Please use a build from mozilla.org

That is the one I use.  Now on 38.0.6 x64

> then attach the information detailed in
> the following article.
> https://www.mozilla.org/firefox/all/
> https://developer.mozilla.org/docs/How_to_get_a_stacktrace_for_a_bug_report

https://crash-stats.mozilla.com/report/index/160bf156-f6c4-4c67-9736-fb2492150609

Updated

3 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Video/Audio
Ever confirmed: true
Keywords: crashreportid
Product: Firefox → Core

Comment 5

3 years ago
There are a number of socorro reports for this signature, and all of the ones I've seen have gstreamer as the next stackframe. Edwin, is there any chance you can look into this?
Crash Signature: [@ libc-2.12.so@0x1282b6 ]
Flags: needinfo?(edwin)

Comment 6

3 years ago
(also, there are still crashes on 41, so I'm assuming this still exists)
We should have a null check at [1] to paper over it for now. A bit flat out at the moment to fix the root cause.

Keeping ni? so I don't forget.

[1] http://hg.mozilla.org/releases/mozilla-release/annotate/76f8f33b6577/dom/media/gstreamer/GStreamerReader.cpp#l235
Flags: needinfo?(edwin)
oops.
Flags: needinfo?(edwin)

Updated

3 years ago
Duplicate of this bug: 1164103

Updated

3 years ago
Duplicate of this bug: 1172893

Comment 11

3 years ago
Seems there are a number of bugs on file for this, with various @libc stacks where the second frame is this gstreamer thing. Robert, is there some reasonable way to ask socorro about any of the others when the libc offset changes due to different versions of libc or whatever?
Flags: needinfo?(kairo)

Comment 12

3 years ago
(In reply to :Gijs Kruitbosch from comment #11)
> Seems there are a number of bugs on file for this, with various @libc stacks
> where the second frame is this gstreamer thing. Robert, is there some
> reasonable way to ask socorro about any of the others when the libc offset
> changes due to different versions of libc or whatever?

The only reasonable way to get decent stats is to actually get symbols uploaded for all those glibc builds of the various distros.
That said, I'm not even sure what your actual question is, what do you want to search Socorro for?

And yes, gstreamer stuff crashes all the time. I guess we probably should just rip all gstreamer support out of Firefox.
Flags: needinfo?(kairo)

Comment 13

3 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #12)
> That said, I'm not even sure what your actual question is, what do you want
> to search Socorro for?

Sorry if I was unclear. I want a list/stats of all crashes (and associated bugs) with a glibc top frame and the next frame being the one this bug is about.

(I'm not aware of there being a way to search socorro for anything but the top frame.)
Flags: needinfo?(kairo)

Comment 14

3 years ago
Sorry, there is no possibility to search for frames beyond the top frame. I have reopened bug 480503 to reflect that.
Flags: needinfo?(kairo)
Duplicate of this bug: 1172608
(Reporter)

Comment 16

3 years ago
Hi All,

If it helps, I went into about:config and switched "media.gstreamer.enabled" to "False" and Jolla.com no longer crashes.

-T
Component: Audio/Video → Audio/Video: Playback
Blocks: 1208910
gstreamer is going in bug 1234092
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Flags: needinfo?(edwin)
Comment hidden (spam)
You need to log in before you can comment on or make changes to this bug.