distribution directory not removed on pave over install

VERIFIED FIXED in Firefox 38.0.5

Status

()

Firefox
Installer
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

unspecified
Firefox 41
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox38+ wontfix, firefox38.0.5+ verified, firefox39+ verified, firefox40 fixed, firefox41 fixed, firefox-esr31 wontfix, firefox-esr3839+ verified)

Details

Attachments

(1 attachment)

Comment hidden (empty)
Note: the code that caused this was added for the update hotfix so we can support installing without removing the distribution dir for repacks such as the eu-ballot
Created attachment 8606048 [details] [diff] [review]
patch

Meh!
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Attachment #8606048 - Flags: review?(spohl.mozilla.bugs)
status-firefox38: --- → affected
status-firefox38.0.5: --- → affected
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox-esr31: --- → affected
status-firefox-esr38: --- → affected
[Tracking Requested - why for this release]:
This causes bugs such as bug 1164858
tracking-firefox38: --- → ?
tracking-firefox38.0.5: --- → ?
tracking-firefox39: --- → ?
Attachment #8606048 - Flags: review?(spohl.mozilla.bugs) → review+
Comment on attachment 8606048 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: Bug 1164858 - added to support installing without removing the distribution dir for repacks such as the eu-ballot
[User impact if declined]: Users installing a non repack build over a repack build won't have the repack customizations removed.
[Describe test coverage new/current, TreeHerder]: Thoroughly tested locally.
[Risks and why]: Little to none. The patch is a simple one line fix that just initializes an nsis variable
[String/UUID change made/needed]: None
Attachment #8606048 - Flags: approval-mozilla-beta?
Attachment #8606048 - Flags: approval-mozilla-aurora?
Comment on attachment 8606048 [details] [diff] [review]
patch

Should also get this in esr38
Attachment #8606048 - Flags: approval-mozilla-esr38?
https://hg.mozilla.org/mozilla-central/rev/b2f7c610539c
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox41: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Comment on attachment 8606048 [details] [diff] [review]
patch

Should be in the first beta of 39 and ESR 38.1.0.
Attachment #8606048 - Flags: approval-mozilla-esr38?
Attachment #8606048 - Flags: approval-mozilla-esr38+
Attachment #8606048 - Flags: approval-mozilla-beta?
Attachment #8606048 - Flags: approval-mozilla-beta+
Attachment #8606048 - Flags: approval-mozilla-aurora?
Attachment #8606048 - Flags: approval-mozilla-aurora+

Comment 9

3 years ago
Comment on attachment 8606048 [details] [diff] [review]
patch

Approval Request Comment: comment #5

Tracking for 38.0.5 was requested so I suspect this needs uplifting to release for the 38.0.5 release. Sylvestre, can you clarify?
Flags: needinfo?(sledru)
Attachment #8606048 - Flags: approval-mozilla-release?
Comment on attachment 8606048 [details] [diff] [review]
patch

Well, Robert didn't ask for it but I am happy to take it too.
Flags: needinfo?(sledru)
Attachment #8606048 - Flags: approval-mozilla-release? → approval-mozilla-release+
status-firefox38: affected → wontfix
tracking-firefox38: ? → +
tracking-firefox38.0.5: ? → +
tracking-firefox39: ? → +
status-firefox-esr31: affected → wontfix
Flags: qe-verify+
QA Contact: alexandra.lucinet

Comment 15

3 years ago
Verified fixed with 38.0.5 beta 3 EME free build (Build ID: 20150518141916), under Windows 7 64-bit - distribution folder is correctly removed.
Status: RESOLVED → VERIFIED
status-firefox38.0.5: fixed → verified
Flags: qe-verify+
Flags: qe-verify+

Comment 16

3 years ago
Verified fixed with 39.0b4 EME free build 2 (Build ID: 20150609130336), under Windows 7 64-bit and Windows 8.1 32-bit.
status-firefox39: fixed → verified
Removing qe-verify+ since this was already verified on Firefox 38.0.5 and 39.
Flags: qe-verify+
Reproduced with Firefox 38 RC build 3 under Win 7 64-bit.
There are no repack builds for ESR, so I installed 38.1esr build over a regular 38 repack build and the distribution folder was correctly removed. Marking as verified.
status-firefox-esr38: fixed → verified
tracking-firefox-esr38: --- → 39+
You need to log in before you can comment on or make changes to this bug.