L10n sizing issues with New Tab intro

RESOLVED DUPLICATE of bug 1172987

Status

()

Firefox
New Tab Page
RESOLVED DUPLICATE of bug 1172987
3 years ago
3 years ago

People

(Reporter: tchevalier, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox40 affected, firefox41 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8606388 [details]
Nightly, French

The New Tab intro has a few issues on localized builds:

- Menu title overflows on the right margin

- "Example Title" is not localized (Missing string).

- "Back" and "Continue the tour" buttons have fixed width (150px) and are truncating long translations. Width should be dynamic here.

Updated

3 years ago
Blocks: 1138818
Whiteboard: .?
Created attachment 8606394 [details]
Italian build

In case of Italian it's the last item.

The same issues happen in the real menu, that's tracked in bug 1164594 (I guess the fix should replicate the real behavior).

Comment 2

3 years ago
(In reply to Théo Chevalier [:tchevalier] from comment #0)
> - "Example Title" is not localized (Missing string).
This string is also missing from Aurora 40. To not break string freeze, I can think of some quick options:

- use some other new tab string, e.g.,
newtab.intro.header.welcome=Welcome to New Tab on %1$S!
newtab.intro.header.update=New Tab got an update!

- use brandShortName "Firefox" as the tile title

I'm assuming it will not be acceptable to have "Example Title" show up in localized builds.

Any other suggestions? Or do we just fix the string and request approval for aurora?
Flags: needinfo?(francesco.lodolo)
"Example Title" is definitely bad, the UI looks half translated.

What about using "www.mozilla.org" or similar? Tiles usually have URLs in that position, and we won't need a localizable string for that. 

I'd be absolutely fine also with using "Mozilla Firefox", "Mozilla", or "Firefox" from branding.properties
Flags: needinfo?(francesco.lodolo)

Comment 4

3 years ago
(In reply to Francesco Lodolo [:flod] (UTC+2) from comment #3)
> What about using "www.mozilla.org" or similar? Tiles usually have URLs in
> that position, and we won't need a localizable string for that. 
Aha! Clever. Let's do that!

Updated

3 years ago
status-firefox40: --- → affected
status-firefox41: --- → affected
Summary: L10n issues with New Tab intro → L10n sizing issues with New Tab intro

Comment 5

3 years ago
Let's focus this bug on the sizing issues: menu, button, etc.

I split off the Example Title to bug 1165430.

Updated

3 years ago
Blocks: 1145418

Updated

3 years ago
Assignee: nobody → msamuel
Duplicate of this bug: 1170171

Updated

3 years ago
Duplicate of this bug: 1170146

Updated

3 years ago
Blocks: 1140185
No longer blocks: 1145418

Updated

3 years ago
Iteration: --- → 41.3 - Jun 29

Comment 8

3 years ago
Is there anything else in this bug that wasn't covered by bug 1172987? That fixed the menu sizing and changed the buttons to have min-width 150px instead of fixed width 150px.

If not, we can mark this dupe of bug 1172987.

Comment 9

3 years ago
Created attachment 8621682 [details]
screenshot of fr l10n nightly with extra text

screenshot with edited text from a firefox-41.0a1.fr.mac.dmg build 12-Jun-2015 13:13  http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central-l10n/

Updated

3 years ago
Assignee: msamuel → nobody
No longer blocks: 1140185, 1138818
Status: NEW → RESOLVED
Iteration: 41.3 - Jun 29 → ---
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Whiteboard: .?
Duplicate of bug: 1172987
Just confirming that everything looks good from there too, thanks.
You need to log in before you can comment on or make changes to this bug.