Closed Bug 1167000 Opened 5 years ago Closed 5 years ago

[Aries] FM Radio does not function

Categories

(Firefox OS Graveyard :: Gaia::FMRadio, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, b2g-master affected)

RESOLVED DUPLICATE of bug 1169778
blocking-b2g -
Tracking Status
b2g-master --- affected

People

(Reporter: bzumwalt, Unassigned)

References

()

Details

(Whiteboard: [3.0-Daily-Testing],[spark])

Attachments

(1 file)

Attached file Logcat
Description:
When user launches FM Radio app with headphones plugged in the loading icon over play button never disappears and no sound plays. If user taps play button loading icon disappears, but no sound plays and further tapping of the play button has no discernable effect. 

Repro Steps:
1) Update a Xperia Z3 Compact (B2G)
 to 20150516173908
2) Launch FM Radio with headphones plugged in

Actual:
FM Radio will not play and does not function.

Expected:
FM Radio will play radio and function as expected.

Environmental Variables:
Device: Xperia Z3 Compact (3.0)
Build ID: 20150516173908
Gaia: 4c0f36e9dfe017bf2a698d416a57c8156b43383d
Gecko: 2f6ea66057fe
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 41.0a1 (3.0)
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Repro frequency: 3/3, 100%
See attached: Youtube video clip & logcat
Youtube link: http://youtu.be/yviWRo4QFoY
Issue does NOT reproduce on Flame 3.0

Launching FM Radio with headphones plugged in allows user to play music. All functions of FM Radio on Flame work as expected.

Device: Flame 3.0
Build ID: 20150520010202
Gaia: 600fd8249960b8256af9de67d9171025bb9a3ff3
Gecko: ac277e615f8f
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

FM Radio is a major function of the device and should work properly so nominating this spark?
blocking-b2g: --- → spark?
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Whiteboard: [spark] → [3.0-Daily-Testing],[spark]
FM radio is not going to be working for V1 in Spark.  We will be remove the FM radio from build so it doesn't show up.
blocking-b2g: spark? → -
Depends on: 1169118
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1169118
Sorry for the future dup; we're removing the app.

(fyi that I did the future dup)
Flags: needinfo?(pbylenga)
Flags: needinfo?(ktucker)
Flags: needinfo?(pbylenga)
Flags: needinfo?(ktucker)
This is a core application and device functionality broken, we can hide it but we should still be fixing it
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I'm duping this to bug 1169778, since that bug has much more information about the actual problem and how to solve it.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1169778
You need to log in before you can comment on or make changes to this bug.