[Aries][Dialer] SIM pin prompt does not show until restart when toggling airplane mode

RESOLVED DUPLICATE of bug 1170353

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1170353
3 years ago
3 years ago

People

(Reporter: DerekH, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing][spark], URL)

Attachments

(1 attachment)

Created attachment 8611393 [details]
logcat_20150527_1213.txt

Description:
The user can enable airplane mode to disable all outgoing signals. When the user disables airplane mode all connections should attempt to re-connect. When this happens the user should be prompted to enter in their SIM pin, but on the aries the prompt is never shown. The user will not see this prompt until the device is restarted

Prerequisite: Have a SIM pin enabled on the device

Repro Steps:
1) Update a Xperia Z3 Compact (B2G) to 20150526220312
2) Drag down the notification bar
3) Tap on the airplane icon to enable airplane mode
4) Tap on the airplane icon to disable airplane mode


Actual:
The SIM pin prompt is not shown when airplane mode finishes disabling. Prompt is not show until restart


Expected:
The SIM pin prompt appears when the SIM pin is disabled


Environmental Variables:
Device: Xperia Z3 Compact (B2G) 3.0
Build ID: 20150526220312
Gaia: b168b4e2b04ecc2c0a6dcd591679d7694128fb32
Gecko: cafc8056bea143c379643eb9d7c502cc9a2cac25
Version: 41.0a1 (3.0)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


Repro frequency:10/10
See attached: Logcat, Video - https://youtu.be/EnMFsp_bhCo
This issue does NOT occur on Flame 3.0

The SIM pin prompt appears when the SIM pin is disabled

Environmental Variables:
Device: Flame 3.0
BuildID: 20150527010201
Gaia: 8ca93673869a64e09ed6153c5402896822dfb253
Gecko: ff2e07228041
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage?]
Summary: [Aries][Dialer] SIM pin does not show until restart when toggling airplane mode → [Aries][Dialer] SIM pin prompt does not show until restart when toggling airplane mode
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]: Regression from Flame, with a high user impact.
blocking-b2g: --- → spark?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Blocks: 1171119
See Also: → bug 1170353
blocking-b2g: spark? → -
See Also: → bug 1163732
[Blocking Requested - why for this release]: See comment 2.
blocking-b2g: - → 3.0?
Status: NEW → RESOLVED
blocking-b2g: 3.0? → ---
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1170353
You need to log in before you can comment on or make changes to this bug.