Telephony marionette-webapi test, test_outgoing_radio_off.js, failed on emulator-kk

RESOLVED FIXED in Firefox 41

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: edgar, Assigned: edgar)

Tracking

unspecified
2.2 S14 (12june)
ARM
Gonk (Firefox OS)
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox41 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
https://treeherder.allizom.org/#/jobs?repo=try&revision=6794612b4298&filter-searchStr=mnw&exclusion_profile=false

16:48:52     INFO -  05-27 16:23:13.230 I/Gecko   (   58): MARIONETTE TEST RESULT:TEST-UNEXPECTED-FAIL | test_outgoing_radio_off.js | undefined - got 6, expected 0
Just share some experiences: yesterday I hit this when I ran a bunch of telephony tests at once; I didn't see this if I simply ran this single tests.
(Assignee)

Comment 2

4 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #0)
> https://treeherder.allizom.org/#/jobs?repo=try&revision=6794612b4298&filter-
> searchStr=mnw&exclusion_profile=false
> 
> 16:48:52     INFO -  05-27 16:23:13.230 I/Gecko   (   58): MARIONETTE TEST
> RESULT:TEST-UNEXPECTED-FAIL | test_outgoing_radio_off.js | undefined - got
> 6, expected 0

We expect that emulator-kk dials emergency call via slot 0, but it dials via slot 6.
When dialling emergency call, the cardState of slot 6 didn't finish updating yet. So TelephonyService chose slot 6 to dial emergency call.

> 16:48:51     INFO -  05-27 16:23:06.040 I/Gecko   (   58): MobileConnectionProvider[6]: setRadioEnabled: false
> 16:48:51     INFO -  05-27 16:23:10.270 I/Gecko   (   58): TelephonyService: Dialing 112, clientId: 0
> 16:48:51     INFO -  05-27 16:23:10.420 I/Gecko   (   58): MobileConnectionProvider[6]: setRadioEnabled: true
> 16:48:51     INFO -  05-27 16:23:10.540 I/Gecko   (   58): IccService: notifyCardStateChanged for service Id: 6, CardState: 4294967295
(Assignee)

Comment 3

4 years ago
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #1)
> Just share some experiences: yesterday I hit this when I ran a bunch of
> telephony tests at once; I didn't see this if I simply ran this single tests.

Thanks for sharing.
I couldn't reproduce this on emulator-x86-kk locally (even ran all telephony tests), looks like emulator-kk on treeherder is pretty slow and cause this failure.
Reducing the number of sim enabled (bug 1163483) might help this. I have no idea how much it will help, but I can give it a shot.
(Assignee)

Comment 4

4 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #3)
> Reducing the number of sim enabled (bug 1163483) might help this. I have no
> idea how much it will help, but I can give it a shot.

Let's see does it help: https://treeherder.allizom.org/#/jobs?repo=try&revision=6c502634de82&exclusion_profile=false
(Assignee)

Comment 5

4 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #4)
> (In reply to Edgar Chen [:edgar][:echen] from comment #3)
> > Reducing the number of sim enabled (bug 1163483) might help this. I have no
> > idea how much it will help, but I can give it a shot.
> 
> Let's see does it help:
> https://treeherder.allizom.org/#/
> jobs?repo=try&revision=6c502634de82&exclusion_profile=false

Another try: https://treeherder.allizom.org/#/jobs?repo=try&revision=460c52eac3d7&exclusion_profile=false
(Assignee)

Comment 6

4 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #5)
> Another try:
> https://treeherder.allizom.org/#/
> jobs?repo=try&revision=460c52eac3d7&exclusion_profile=false

Enabling 2 sim only (bug 1163483) improves a lot, but I still saw the same failure a few times, although the fail rate is low.
(Assignee)

Comment 7

4 years ago
Created attachment 8613403 [details] [diff] [review]
Patch, v1

Another thought: wait icc status to finish updating when enabling/disabling radio power.

try: https://treeherder.allizom.org/#/jobs?repo=try&revision=cfb8c8670fd6&exclusion_profile=false
(Assignee)

Comment 8

4 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #7)
> Created attachment 8613403 [details] [diff] [review]
> Patch, v1
> 
> Another thought: wait icc status to finish updating when enabling/disabling
> radio power.
> 
> try:
> https://treeherder.allizom.org/#/
> jobs?repo=try&revision=cfb8c8670fd6&exclusion_profile=false

Another try:
https://treeherder.allizom.org/#/jobs?repo=try&revision=03bab49390c2&exclusion_profile=false
(Assignee)

Comment 9

4 years ago
Created attachment 8613837 [details] [diff] [review]
Patch, v2
Attachment #8613403 - Attachment is obsolete: true
(Assignee)

Comment 10

4 years ago
Comment on attachment 8613837 [details] [diff] [review]
Patch, v2

Review of attachment 8613837 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Hsinyi, may I have your review? Thank you.
Attachment #8613837 - Flags: review?(htsai)
(Assignee)

Updated

4 years ago
Assignee: nobody → echen
(Assignee)

Updated

4 years ago
Component: Emulator → RIL
Comment on attachment 8613837 [details] [diff] [review]
Patch, v2

Review of attachment 8613837 [details] [diff] [review]:
-----------------------------------------------------------------

Yay~ let's ship it. Thanks for this :)
Attachment #8613837 - Flags: review?(htsai) → review+
https://hg.mozilla.org/mozilla-central/rev/a1c63bd7e0b9
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox41: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S14 (12june)
You need to log in before you can comment on or make changes to this bug.