Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Add Windows 10 media queries

RESOLVED FIXED in Thunderbird 41.0

Status

Thunderbird
Theme
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 41.0
All
Windows 10

Thunderbird Tracking Flags

(thunderbird39 fixed, thunderbird40 fixed, thunderbird41 fixed, thunderbird_esr3839+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
With bug 1169981 Windows 10 has it's own media queries. We need to add them to our theme to style TB correctly under Windows 10. Without the non-default theme rules are used.
(Assignee)

Comment 1

2 years ago
Created attachment 8616372 [details] [diff] [review]
supportWin10.patch

Unlikely to FX we need the special queries because we differentiate between Classic/HC, Vista/Win7 and Win8/Win10. FX differentiates only between Classic/HC/Win8/Win10 and Vista/Win7.

But this additional query isn't bad as Microsoft said Win 10 would be the last Windows version. After this where are only updates.

But we could also think about going the FX way, which is not as good on HC themes, like TB. If we do this, this should be a new bug after this one is closed.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8616372 - Flags: review?(bwinton)
(Assignee)

Comment 2

2 years ago
Oops, wrong bug in comment 0. The correct is bug 1166867 and it landed on ESR38. So our bug needs also to land on ESR38.
(Assignee)

Comment 3

2 years ago
Created attachment 8617960 [details] [diff] [review]
supportWin10.patch

Added the fix from bug 1169911 to get rid of the too wide active border on both sides in the titlebar.
Attachment #8616372 - Attachment is obsolete: true
Attachment #8616372 - Flags: review?(bwinton)
Attachment #8617960 - Flags: review?(bwinton)
Comment on attachment 8617960 [details] [diff] [review]
supportWin10.patch

Ugh.  Large patch.  But it looks good…  r=me.
Attachment #8617960 - Flags: review?(bwinton) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
(Assignee)

Comment 5

2 years ago
Comment on attachment 8617960 [details] [diff] [review]
supportWin10.patch

[Approval Request Comment]
Regression caused by (bug #): 1166867, which is also in mozilla-esr38
User impact if declined: Not correct styling of the default theme
Testing completed (on c-c, etc.): awaiting c-i
Risk to taking this patch (and alternatives if risky): Low, it's only CSS with media queries.
Attachment #8617960 - Flags: approval-comm-esr38?
Attachment #8617960 - Flags: approval-comm-beta?
Attachment #8617960 - Flags: approval-comm-aurora?

Comment 6

2 years ago
https://hg.mozilla.org/comm-central/rev/d5fc93ab5c95

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 41.0

Comment 7

2 years ago
Comment on attachment 8617960 [details] [diff] [review]
supportWin10.patch

http://hg.mozilla.org/releases/comm-aurora/rev/87aeed0319fb
https://hg.mozilla.org/releases/comm-beta/rev/839e5b1bcdb6
Attachment #8617960 - Flags: approval-comm-beta?
Attachment #8617960 - Flags: approval-comm-beta+
Attachment #8617960 - Flags: approval-comm-aurora?
Attachment #8617960 - Flags: approval-comm-aurora+

Updated

2 years ago
status-thunderbird39: --- → fixed
status-thunderbird40: --- → fixed
status-thunderbird41: --- → fixed
status-thunderbird_esr38: --- → affected

Comment 8

2 years ago
Comment on attachment 8617960 [details] [diff] [review]
supportWin10.patch

http://hg.mozilla.org/releases/comm-esr38/rev/08caa558cf7d
Attachment #8617960 - Flags: approval-comm-esr38? → approval-comm-esr38+

Updated

2 years ago
status-thunderbird_esr38: affected → fixed
tracking-thunderbird_esr38: --- → 39+
You need to log in before you can comment on or make changes to this bug.