Address bar will not load an autocompleted URL if you edit it

RESOLVED FIXED

Status

()

Firefox
Location Bar
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({regression, reproducible})

Trunk
regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 unaffected, firefox41 affected)

Details

(Whiteboard: fixed by bug 1172937)

(Reporter)

Description

2 years ago
STR:
0. Create a new user profile.
1. In the address bar, enter "cnn.com".
2. See that "http://www.cnn.com/" loaded.
3. Open a new tab.
4. In the new tab's address bar, enter "cnn.com".
5. See that the address bar will autocomplete "www.cnn.com/".
6. Use the Backspace key to delete the trailing "/" character.
7. Hit the Enter key to load "cnn.com" again.

RESULT:
Nothing happens. No page loads. This is a regression in Nightly 41.
(Reporter)

Comment 1

2 years ago
Marco, does this look like a regression from your unified autocomplete changes in bug 1168811?

This is the regression range for this bug:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=bea6758824d9&tochange=6b20dd2e20cc
Blocks: 1168811
Flags: needinfo?(mak77)
Keywords: regressionwindow-wanted
I think this is basically the same as bug 1172937
Blocks: 995091
Flags: needinfo?(mak77)
Flags: qe-verify+
QA Contact: andrei.vaida
Duplicate of this bug: 1175612

Updated

2 years ago
Depends on: 1172937

Updated

2 years ago
Duplicate of this bug: 1183081
fixed by bug 1172937.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Flags: qe-verify+
QA Contact: andrei.vaida
Whiteboard: fixed by bug 1172937
You need to log in before you can comment on or make changes to this bug.