The default bug view has changed. See this FAQ.

Take "Bug 1143570 - Copy/Paste into plain text editor deletes newlines from quoted text" in TB 38.x

RESOLVED FIXED

Status

Thunderbird
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Jorg K (GMT+1), Assigned: rkent)

Tracking

({regression, testcase})

Trunk
regression, testcase
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird39 wontfix, thunderbird40 wontfix, thunderbird41 fixed, thunderbird_esr3839+ fixed)

Details

(Reporter)

Description

2 years ago
+++ This bug was initially created as a clone of Bug #1143570 +++

It's a regression, we have the TB 38 release branch, so it's a good candidate for inclusion in TB 38.1
(Reporter)

Comment 1

2 years ago
Aurora approval for mozilla40 has been requested (bug 1143570 comment #48), so TB 40 and 41 would automatically get the fix.
status-thunderbird38: --- → affected
status-thunderbird39: --- → wontfix
status-thunderbird40: --- → affected
status-thunderbird41: --- → affected
tracking-thunderbird_esr38: --- → ?
(Assignee)

Updated

2 years ago
tracking-thunderbird_esr38: ? → +
(In reply to Jorg K from comment #1)
> Aurora approval for mozilla40 has been requested (bug 1143570 comment #48),
> so TB 40 and 41 would automatically get the fix.

AIUI that would be insufficient. It would additionally need to be approved and landed on ESR
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #2)
> (In reply to Jorg K from comment #1)
> > Aurora approval for mozilla40 has been requested (bug 1143570 comment #48),
> > so TB 40 and 41 would automatically get the fix.
> 
> AIUI that would be insufficient. It would additionally need to be approved
> and landed on ESR

Ah, nevermind. I mean insufficient for TB38. But you clearly got that already
(Reporter)

Comment 4

2 years ago
I don't understand that you're saying. We could land it on the TB 38 release branch as per comment #0.
TB 40 and 41 would be fixed when the M-C stuff lands on Gecko 40 and 41.

Anyway, the patches in bug 1143570 will be backed out since they are causing regressions.
So right now, there is no need for action. Keep watching bug 1143570 and bug 1174521 and bug 1174834.
(Reporter)

Comment 5

2 years ago
I was wrong. Bug 1143570 has two parts, the part that fixes the problem (part 1) and an optimisation that was backed out (part 2). Part 1 is part of Mozilla 41. So in summary:
Take https://hg.mozilla.org/mozilla-central/rev/fafce41ffcee on the TB 38 release branch.
(Assignee)

Updated

2 years ago
status-thunderbird38: affected → ---
status-thunderbird_esr38: --- → affected
(Reporter)

Comment 6

2 years ago
I've just tested/confirmed that the problem is in TB 38 but not in a daily version, so the patch should be good to go.
(Assignee)

Comment 7

2 years ago
a=rkent

https://hg.mozilla.org/releases/mozilla-esr38/rev/e351b6e79cd6
Assignee: nobody → rkent
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-thunderbird40: affected → wontfix
status-thunderbird41: affected → fixed
status-thunderbird_esr38: affected → fixed
tracking-thunderbird_esr38: + → 39+
Resolution: --- → FIXED
(Reporter)

Comment 8

2 years ago
In bug 1174452 comment #6 Robin Whittle claims that this is still an issue:

Are you 100% sure that this persists in TB 38.1.0? We know it was an issue in TB 38.0.1.
I test it like this: I use <shift> reply, and then copy/paste the ">" lines. Works for me in TB 38.1.
If the problem really still exists, please attach the message that you're replying to.
Flags: needinfo?(rw)

Comment 9

2 years ago
I just installed Early Bird Thunderbird (Windows 7, installed from 40.0b1-candidates/build3/win32/en-GB/ an hour ago, which I am able to use thanks to what I learned about SSL in bug 1184488) and the behavior is still the same: when copying blue text to the clipboard, multiple consecutive spaces are retained but newlines are lost.

So I think this problem is not resolved, at least for 40.0.
Flags: needinfo?(rw)
(Reporter)

Comment 10

2 years ago
You don't understand which fix was landed where.
The core fix in bug 1143570 was landed on mozilla41 (see bug 1143570 comment #49).

This fix is therefore contained in TB 41 (Earlybird) or TB 42 (Daily). It is *NOT* contained in any TB 40! Additionally the change in mozilla41 was "uplifted" to TB 38.1.0 (not 38.0.1) as part of this bug.

So please use TB 38.1.0 or TB 41 or TB 42 to try it. Do not use TB 40 (the beta which is in preparation).
Flags: needinfo?(rw)

Comment 11

2 years ago
I tried http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central-l10n/ thunderbird-42.0a1.en-GB.win32.installer.exe 25-Jul-2015 12:41.  This bug 1173261 appears to be fixed, but not bug 1174452, which also concerns copying to the clipboard.
Flags: needinfo?(rw)
You need to log in before you can comment on or make changes to this bug.