Closed Bug 1173606 Opened 5 years ago Closed 5 years ago

[Dialer] It displays a placeholder confirmation message when deleting contacts from Phone app

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: pcheng, Assigned: gsvelto)

References

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(4 files, 1 obsolete file)

Attached image screenshot of issue
Description:
When deleting a contact or multiple contacts from within Phone app, it shows a placeholder confirmation message.

This issue can also be observed when attempting to import from memory card but there's no vcf file on memory card.

STR:
1) Create a contact in Contacts app
2) Go to Phone app, switch to contacts tab
3) Attempt to delete a contact either via editing an individual contact or via Gear icon > Delete Contacts
4) Observe the confirmation message

Expected: The confirmation message looks relevant to the user action, such as "Delete [x number of] contacts?" or compare this dialog to the dialog from Contacts app.

Actual: It says "Confirmation message" on the dialog. See screenshot.

Additional STR:
1) There is no vcf file on internal SD storage
2) Go to Phone app, switch to contacts tab
3) Tap on Gear icon on upper right > Import Contacts > Memory card

The same dialog is shown as above.

Repro rate: 5/5

Device: Flame (KK, full flashed, 319MB)
BuildID: 20150609160220
Gaia: 31ef8deec7a04a988eb92309178b87cc0bde8220
Gecko: 8be8deb10e4f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
2.2 is unaffected. Relevant messages are shown when doing the STRs.

Device: Flame 2.2
BuildID: 20150610002502
Gaia: 06edb0f8db7c2f45cde54401a8593663059861a4
Gecko: a3d7b08fb0ec
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing]
[Blocking Requested - why for this release]:

Recent regression. Nominating this 3.0? since this message does not make sense.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: bzumwalt
Likely another fallout of bug 1066347. Before doing a regular regression window: QA wanted to check the build before April 10th 2015 at 04:16:20 Pacific Time, and the build after.
Looks like you are correct Johan, this issue appears to have been caused by changes made in bug 1066347

Working B2G-Inbound build:
Device: Flame 3.0
Build ID: 20150410033337
Gaia: 749b6eb12c103f4119f1f85c72dbe7791684d8dc
Gecko: b99b34dc9bd4
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Broken B2G-Inbound build:
Device: Flame 3.0
Build ID: 20150410044437
Gaia: 6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Gecko: 5a1b56e833f0
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Working Gaia with Broken Gecko issue 
Gaia: 749b6eb12c103f4119f1f85c72dbe7791684d8dc
Gecko: 5a1b56e833f0

Working Gecko with Broken Gaia issue 
Gaia: 6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Gecko: b99b34dc9bd4


B2G-Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/749b6eb12c103f4119f1f85c72dbe7791684d8dc...6e403dbb863fb9ec41bd22b6583e2eff5045d78b
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Zibi, can you take a look at this please? This looks to have been caused by the landing for bug 1066347.
Blocks: 1066347
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(gandalf)
Zibi already commented on bugs similar to this one. We won't roll back the changes from bug 1066347. We need somebody from the Contact team to fix the string location.
Flags: needinfo?(gandalf)
Comms triage: Regression.
blocking-b2g: 3.0? → 3.0+
B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150410033337
Gaia: 749b6eb12c103f4119f1f85c72dbe7791684d8dc
Gecko: b99b34dc9bd4
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150410044437
Gaia: 6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Gecko: 5a1b56e833f0
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working gaia / First Broken gecko - 
Gaia: 749b6eb12c103f4119f1f85c72dbe7791684d8dc
Gecko: 5a1b56e833f0

First Broken gaia / Last Working gecko - 
Gaia: 6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Gecko: b99b34dc9bd4

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/749b6eb12c103f4119f1f85c72dbe7791684d8dc...6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Flags: needinfo?(ktucker)
Please ignore comment 8.  This was posted to the wrong bug.
Flags: needinfo?(ktucker)
See Also: → 1154415
Can we get a logcat? That usually helps identify which entities are missing.
qawanted to get a logcat.
Keywords: qawanted
Attached file Logcat
Issue reproduces on latest Flame 3.0

Attached Logcat

Device: Flame 3.0
Build ID: 20150618010201
Gaia: b404c41c5471c31610e64defb74ec066b411e724
Gecko: a3f280b6f8d5
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Duplicate of this bug: 1177114
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Attachment #8640436 - Attachment description: [gaia] gabrielesvelto:bug-1173606-delete-confirmation-1l0n > mozilla-b2g:master → [gaia] gabrielesvelto:bug-1173606-delete-confirmation-l10n > mozilla-b2g:master
Attachment #8640436 - Attachment is obsolete: true
Comment on attachment 8640438 [details] [review]
[gaia] gabrielesvelto:bug-1173606-delete-confirmation-l10n > mozilla-b2g:master

This patch addresses all the issues described in the STR as well as others that I could identify while testing. There are probably more missing l10n strings when opening the contacts app from the dialer and I fear that chasing all of them will be a game of whack-a-mole; however since we're looking at splitting the dialer from the contacts app it makes no sense to spend significant time tracking them down.
Attachment #8640438 - Flags: review?(thills)
Comment on attachment 8640438 [details] [review]
[gaia] gabrielesvelto:bug-1173606-delete-confirmation-l10n > mozilla-b2g:master

Hi Gabriele,

It looks good and i also did test out and it solves the issue. I had one question about the moving of voicemail.{locale}.properties.  Was that just an organizational thing?

Thanks,

-tamara
Attachment #8640438 - Flags: review?(thills) → review+
Thanks for the review Tamara, I've retriggered the tests because I didn't have time to merge this before going on PTO and wanted to be sure everything is alright.
Merged to gaia/master 34f1426aa0e6d5677145ff10e9bbcb006852ee90

https://github.com/mozilla-b2g/gaia/commit/34f1426aa0e6d5677145ff10e9bbcb006852ee90
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: When importing contact from SD card or deleting contact in Phone app, the confirmation dialog shows normally.
See attachment: verified_FlameKK_v2.5.png
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150818150207
Gaia Revision          507ba38fb64b27f87d11f4104dfcc58448e12b1a
Gaia Date              2015-08-18 10:50:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c272af993c23e803f6ea7798a812b0c8abfad4d
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150818.184156
Firmware Date          Tue Aug 18 18:42:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20150818233027
Gaia Revision          1e1197e0e8e64307aa382ffba4711d1c661de7ca
Gaia Date              2015-08-18 16:54:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/88e1d293ffa9faf065b2a944c94a2705aabf1fb9
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150818.225517
Firmware Date          Tue Aug 18 22:55:24 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.