Bugs should be able to be assigned to more than one product and component

RESOLVED DUPLICATE of bug 178303

Status

()

bugzilla.mozilla.org
General
RESOLVED DUPLICATE of bug 178303
3 years ago
3 years ago

People

(Reporter: miker, Unassigned)

Tracking

Production

Details

It is often very hard to keep track of bugs because we are forced to choose a single component for them to be assigned to.

e.g.
A problem with indexedDB in the devtools storage inspector would normally be filed under:
Product: Firefox
Component: Developer Tools: Storage Inspector

But then if it needs platform work it gets moved to:
Product: Core
Component: DOM: IndexedDB

When platform have finished their side of things it very rarely gets assigned back to the original component and disappear only to be found years later.

This would be solved if we could assign the bug to multiple products and components e.g.:
Product: Core
Component: DOM: IndexedDB
And:
Product: Firefox
Component: Developer Tools: Storage Inspector
from bug 178303:

If a bug seems to belong to several components, this means the bug has different issues which should be fixed separately, each having its own bug filed in its respective component. Then the initial bug should be marked as depending on these bugs. As said in comments 2 and 4, we won't go into this direction.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 178303
You need to log in before you can comment on or make changes to this bug.