Undeleted mail (undo) doesn't show up immediately

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
3 years ago
13 days ago

People

(Reporter: Daniel Krebs, Unassigned)

Tracking

31 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150511103818

Steps to reproduce:

Using Linux Mint 17.1 x64  TB 31.7.0 and IMAP

Delete a mail (it gets moved to trash) and undo that by pressing CTRL + Z.


Actual results:

The mail is not showing the folder (to where it got moved out of trash) until I refresh the Folder by either pressing F5 or shortly switching to any other folder and switching back.


Expected results:

The undeleted mail should show up immediately.

Comment 1

3 years ago
Do you see the problem if you update to version 38 from https://www.mozilla.org/en-US/thunderbird/ ??
Flags: needinfo?(net-bugzilla)
(Reporter)

Comment 2

3 years ago
I tried using version 38.0.1, a test mail account and taking over my old profile - same problem. Then started with a fresh profile and a test account. Things got better. I tried several times and it now takes about 10-15 seconds until the restored mail reappears. Seems like the "IMAP IDLE" setting in account settings influences the behaviour. Turning it on and the mails get shown after the 10-15 seconds delay, turning it off and the mentioned manual refresh is necessary. 
What I don't understand: Thunderbird initiates the deletion and undeletion of the mail so it should know about it, regardless of the IMAP settings, shouldn’t it?
Flags: needinfo?(net-bugzilla)

Comment 3

3 years ago
Wayne, it would be good to have some way to group bugs related to undo in Thunderbird. Jorgk recently took on one of these, perhaps he could clean up the whole area. It has been largely neglected for a long time.

Comment 4

3 years ago
Here is the query. Most are confirmed bugs
https://bugzilla.mozilla.org/buglist.cgi?v4=mail%20messag&f1=short_desc&o3=nowordssubstr&list_id=12329109&short_desc=Undelet%20undo&v3=address%20compo&o1=nowordssubstr&resolution=---&classification=Client%20Software&classification=Components&f4=short_desc&query_format=advanced&f3=component&o4=anywordssubstr&f2=OP&short_desc_type=anywordssubstr&v1=address%20contact%20news&product=MailNews%20Core&product=Thunderbird

Updated

3 years ago
Component: Untriaged → Folder and Message Lists

Comment 5

2 years ago
Daniel can you check this list please to see if one matches?

(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #4)
> Here is the query. Most are confirmed bugs
> https://bugzilla.mozilla.org/buglist.
> cgi?v4=mail%20messag&f1=short_desc&o3=nowordssubstr&list_id=12329109&short_de
> sc=Undelet%20undo&v3=address%20compo&o1=nowordssubstr&resolution=---
> &classification=Client%20Software&classification=Components&f4=short_desc&que
> ry_format=advanced&f3=component&o4=anywordssubstr&f2=OP&short_desc_type=anywo
> rdssubstr&v1=address%20contact%20news&product=MailNews%20Core&product=Thunder
> bird
Flags: needinfo?(net-bugzilla)
Summary: Undeleted mail doesn't show up immediately → Undeleted mail (undo) doesn't show up immediately
(Reporter)

Comment 6

2 years ago
Hi Wayne,
sorry, I didn't understand that you your list was meant for me to check in the first place. So now I did, I think the following bugs might be related:
https://bugzilla.mozilla.org/show_bug.cgi?id=533951
https://bugzilla.mozilla.org/show_bug.cgi?id=813680
-> Although both seem to be related to filters or search folders both suffer from a similar kind of "refresh" issue, where a mail is moved (aka deleted/undeleted) but not displayed until some kind "refresh" is done by reloading/switching folders.

Most of the other bugs seem to include altered mail content (like changed subject line) which I cannot report, like this one: https://bugzilla.mozilla.org/show_bug.cgi?id=923002

DK
Flags: needinfo?(net-bugzilla)

Comment 7

2 years ago
Daniel, is this the unified Inbox?  Or the Inbox of a single account
(Reporter)

Comment 8

2 years ago
I don't use the unified inbox, it happens in the inbox as well as in subfolders.

DK

Comment 9

2 years ago
I see this too - sometimes. Perhaps a funciton of the imap server?
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → bug 533951, bug 813680

Comment 10

11 months ago
I also have this problem, whenever I delete a message by accident and then undo it won't reappear in the inbox unless I switch to another folder and then back to the inbox. My mail server is yahoo imap. This issue may be a duplicate of bug #813680 from 2012.

Also the undo message is confusing, it says "deleted message from trash" (already reported by someone else as bug #533949).

Comment 11

9 months ago
This seems to be dependent on the IMAP server. Outlook.Com reports
IMAP4rev1 server version 17.4.0.0 ready (BAY451-IMAP108)
CAPABILITY IMAP4rev1 CHILDREN ID NAMESPACE UIDPLUS UNSELECT AUTH=PLAIN AUTH=XOAUTH2 SASL-IR


and I there's a huge delay in the message returning to the inbox.

The Exchange server at my work reports
The Microsoft Exchange IMAP4 service is ready.
CAPABILITY IMAP4 IMAP4rev1 AUTH=NTLM AUTH=GSSAPI AUTH=PLAIN UIDPLUS CHILDREN IDLE NAMESPACE LITERAL+

and there's no delay.

Comment 12

9 months ago
Tuffmail's IMAP server reports
IMAP4 ready
CAPABILITY IMAP4 IMAP4rev1 ACL QUOTA LITERAL+ NAMESPACE UIDPLUS ID NO_ATOMIC_RENAME UNSELECT CHILDREN MULTIAPPEND SORT THREAD=ORDEREDSUBJECT THREAD=REFERENCES ANNOTATEMORE IDLE LISTEXT LIST-SUBSCRIBED AUTH=PLAIN

and it doesn't have the delay.
tracking-thunderbird54: --- → ?
Ignore my changes to tracking flags, I'm investigating bug 1344233.
tracking-thunderbird54: ? → ---
(Reporter)

Comment 14

13 days ago
I just noticed that it's working now as it should (~2 second delay) under Fedora 26 and 52.4.0 (64-Bit). I don't know if this was fixed by a Thunderbird update or switching the OS though..

Comment 15

13 days ago
Thanks for the update
Status: NEW → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.