[Aries] Notification panel drag transitions becomes flickery if you drag it in landscape mode

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::System::Window Mgmt
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: jlorenzo, Assigned: jedireza)

Tracking

({foxfood, regression})

unspecified
FxOS-S1 (26Jun)
foxfood, regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-master verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
[Blocking Requested - why for this release]: You can break the notification panel by using it in landscape mode.

STR
1. On the homescreen, drag down the notification panel and drag it up => OK, the transition is smooth
2. Launch an app which allows landscape mode (like browser)
3. Drag the notification panel down and drag it up => KO, the panel moves up and down instead of going forward 1 direction
4. Go back on the homescreen, and go as in step 1

Results
Same thing as when you're in lanscape mode. Now the notification panel will remain jittery until you restart the phone.  See video for details: https://goo.gl/58deRt

Build info
This occurs only on the Aries device, not on the Flame with a recent build. This is also a regression from the last couple of day. I remember using the notification panel in landscape like 4 or 5 days ago, without any issue.

[1] Build ID               20150614032352
Gaia Revision          1bf2da102560481748ff3f6202fbed5c4daa5832
Gaia Date              2015-06-13 00:22:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c223b8844264
Gecko Version          41.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150612.053308
Firmware Date          Fri Jun 12 05:33:15 UTC 2015
Bootloader             s1

[2] Build ID               20150615010203
Gaia Revision          1bf2da102560481748ff3f6202fbed5c4daa5832
Gaia Date              2015-06-13 00:22:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3c26bef95d54
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150615.044754
Firmware Date          Mon Jun 15 04:48:05 EDT 2015
Bootloader             L1TC000118D0
Doesn't really seem like an APZ issue but a regression window would tell us where to move it. Could be either layout or graphics.
status-b2g-master: unaffected → affected
Version: 38 Branch → 41 Branch

Comment 2

3 years ago
Central Regression Window:

Last Working
Environmental Variables
Device: Aries 3.0
BuildID: 20150611131651
Gaia: 68269e7b6510930eb2f644f69d27d456c1bdec75
Gecko: 9ebd530c5843
Version: 41.0a1 (3.0)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken
Environmental Variables:
Device: Aries 3.0
BuildID: 20150614233012
Gaia: 1bf2da102560481748ff3f6202fbed5c4daa5832
Gecko: 3c26bef95d54
Version: 41.0a1 (3.0) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0


Last Working gaia / First Broken gecko - This issue 
Gaia: 68269e7b6510930eb2f644f69d27d456c1bdec75
Gecko: 3c26bef95d54

First Broken gaia / Last Working gecko
Gaia: 1bf2da102560481748ff3f6202fbed5c4daa5832
Gecko: 9ebd530c5843
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted

Comment 3

3 years ago
Currently unable to grab Gaia from First Broken build.

Updated

3 years ago
QA Contact: jthomas
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
I did some local builds and I believe this is a gaia regression, not a gecko one. I'll bisect the gaia range down.
The first bad commit is 79fef2149ee52942b51ce5bafaf2e456608dcb44, from bug 1171235.
Blocks: 1171235
Component: Panning and Zooming → Gaia::System::Window Mgmt
Keywords: regressionwindow-wanted
Product: Core → Firefox OS
Version: 41 Branch → unspecified
Hi Reza, can you look into this? It's a regression from a change you landed. Thanks!
Flags: needinfo?(rakhavan)
(Assignee)

Comment 8

3 years ago
I'm not convinced this is caused by the work in bug 1171235.

In order to test this, I checked out commit c197046b16eda6e74c6a47a3bb0d402d43280ada, which was the commit before mine. I ran the same tests as in the attached video and got the same results.
Flags: needinfo?(rakhavan)
I reconfirmed that against master gecko (git SHA 1e96343), gaia commit fb7e0cc (parent of your change, effectively same as c197046) is good and gaia commit 79fef21 is bad. Did you test on Aries or some other device?

Also, are you certain you saw the regression on c197046? To me it wasn't very clear what the issue was in the video but after seeing the regression on the device it was very obvious when it was happening and when it was not. It seems to happen as soon as you lift your finger after dragging the notification bar halfway. As long as the finger stays down everything is fine.
Flags: needinfo?(rakhavan)
(Assignee)

Comment 10

3 years ago
I got my hands on an aries device and I was able to reproduce the behavior in landscape orientation. I'll take this bug and attempt a fix.
Flags: needinfo?(rakhavan)
(Assignee)

Updated

3 years ago
Assignee: nobody → rakhavan
(Assignee)

Comment 11

3 years ago
I've also found that once I go into landscape orientation and pull down the notification panel, when I go back into portrait the visual behavior/performance stays poor.
Yes, the behaviour staying bad after going back to portrait was mentioned in comment 0.
(Assignee)

Comment 13

3 years ago
I narrowed the change in behavior to the variable change in `apps/system/style/definitions.cs` where we change `--software-home-button-height: 4.4rem;` to `--software-home-button-height: 5rem;`.

Then I looked for uses of this variable and found reference to it (and a mention of the software home button) in the utility tray style sheet. There's a comment about making it easier to drag the utility tray when there is a software home button enabled.

I think; the helper style only needs to be applied in portrait orientation since the software home button is on the right side of the screen in landscape orientation. I tried wrapping the style in a media query and it seems to have fixed the problem.

If someone else can confirm or correct my findings I'd appreciate it.

https://github.com/mozilla-b2g/gaia/compare/master...jedireza:utility-tray-animation-flickery?expand=1

----

I'm cc'ing Alberto Pastor who introduced the helper in bug 1172050.

Commit: https://github.com/mozilla-b2g/gaia/commit/391a2e4d9695cefd665e03300365a0b95fb69ff9#diff-25db15b84f47f67424a1a0c90f062535R135

----
Flags: needinfo?(apastor)
(In reply to Reza Akhavan [:jedireza] from comment #13)
> I narrowed the change in behavior to the variable change in
> `apps/system/style/definitions.cs` where we change
> `--software-home-button-height: 4.4rem;` to `--software-home-button-height:
> 5rem;`.
> 
> Then I looked for uses of this variable and found reference to it (and a
> mention of the software home button) in the utility tray style sheet.
> There's a comment about making it easier to drag the utility tray when there
> is a software home button enabled.
> 
> I think; the helper style only needs to be applied in portrait orientation
> since the software home button is on the right side of the screen in
> landscape orientation. I tried wrapping the style in a media query and it
> seems to have fixed the problem.
> 
> If someone else can confirm or correct my findings I'd appreciate it.
> 
> https://github.com/mozilla-b2g/gaia/compare/master...jedireza:utility-tray-
> animation-flickery?expand=1
> 
> ----
> 
> I'm cc'ing Alberto Pastor who introduced the helper in bug 1172050.
> 
> Commit:
> https://github.com/mozilla-b2g/gaia/commit/
> 391a2e4d9695cefd665e03300365a0b95fb69ff9#diff-
> 25db15b84f47f67424a1a0c90f062535R135
> 
> ----

Reza, you are totally right. We should only apply that trick when we are in portrait mode. Feel free to send a patch and I'll be happy to review it. Thanks!
Flags: needinfo?(apastor)
(Assignee)

Comment 15

3 years ago
Created attachment 8624081 [details] [review]
PR: Only apply helper in portrait orientation
Attachment #8624081 - Flags: review?(apastor)
Comment on attachment 8624081 [details] [review]
PR: Only apply helper in portrait orientation

LGTM. Thanks!
Attachment #8624081 - Flags: review?(apastor) → review+
(Assignee)

Comment 17

3 years ago
Thanks Alberto.

Kartikaya, would you be willing to confirm or correct my results? If you're able to confirm the fix, the patch is ready and has been reviewed.
Flags: needinfo?(bugmail.mozilla)
Patch works for me, thanks!
Flags: needinfo?(bugmail.mozilla)
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/78ed09346841bbcc565ccf1fe61a2c674496785e
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S1 (26Jun)
This issue is verified fixed on Aries. Pulling down and up the utility tray the animation is smooth and no flickering occurs.

Device: Aries (dogfood debug)
BuildID: 20150622124551
Gaia: 311c4e59936a407e64509f54fecb440d8a78e3c8
Gecko: be81b8d6fae9
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (3.0 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
(Reporter)

Updated

3 years ago
Keywords: foxfood
(Reporter)

Updated

3 years ago
Keywords: dogfood
blocking-b2g: spark? → 2.5?
You need to log in before you can comment on or make changes to this bug.